today's git snapshot

This commit is contained in:
Adam Jackson 2017-11-06 13:49:21 -05:00
parent 4c47ac4973
commit 4ed50364ed
3 changed files with 21 additions and 44 deletions

View file

@ -1,26 +1,13 @@
From c2b4d93a5e4796ca53361c61d7e31edc24241932 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 20 Mar 2016 13:26:25 +0100
Subject: [PATCH 1/4] llvm SONAME without version
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 5f75c60..d77f907 100644
index 0116b90743..4f5c8e31da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2387,7 +2387,7 @@ if test "x$MESA_LLVM" != x0; then
@@ -2646,7 +2646,7 @@ detect_old_buggy_llvm() {
dnl ourselves.
dnl (See https://llvm.org/bugs/show_bug.cgi?id=6823)
if test "x$enable_llvm_shared_libs" = xyes; then
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
+ LLVM_SO_NAME=LLVM
AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes])
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
+ LLVM_SO_NAME=LLVM
AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes])
if test "x$llvm_have_one_so" = xyes; then
--
2.7.4
if test "x$llvm_have_one_so" = xyes; then

View file

@ -58,12 +58,14 @@
Name: mesa
Summary: Mesa graphics libraries
Version: 17.2.4
Release: 1%{?rctag:.%{rctag}}%{?dist}
Version: 17.3.99.0
Release: 0.1%{?rctag:.%{rctag}}%{?dist}
License: MIT
URL: http://www.mesa3d.org
Source0: https://mesa.freedesktop.org/archive/%{name}-%{version}%{?rctag:-%{rctag}}.tar.xz
#Source0: https://mesa.freedesktop.org/archive/%{name}-%{version}%{?rctag:-%{rctag}}.tar.xz
# wrong version number, sorry about that
Source0: mesa-17.3.0-devel.tar.xz
Source1: vl_decoder.c
Source2: vl_mpeg12_decoder.c
# src/gallium/auxiliary/postprocess/pp_mlaa* have an ... interestingly worded license.
@ -71,19 +73,15 @@ Source2: vl_mpeg12_decoder.c
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
Source3: Mesa-MLAA-License-Clarification-Email.txt
# https://cgit.freedesktop.org/~ajax/mesa/log/?h=mesa-17.2-s3tc
Patch0: 0001-mesa-Squash-merge-of-S3TC-support.patch
Patch1: 0001-llvm-SONAME-without-version.patch
Patch2: 0002-hardware-gloat.patch
Patch3: 0003-evergreen-big-endian.patch
Patch4: 0004-bigendian-assert.patch
Patch5: vc4-Don-t-advertise-tiled-dmabuf-modifiers-if-we-can-t-use-them.patch
# glvnd support patches
# non-upstreamed ones
Patch10: glvnd-fix-gl-dot-pc.patch
Patch11: 0001-Fix-linkage-against-shared-glapi.patch
#Patch11: 0001-Fix-linkage-against-shared-glapi.patch
# backport from upstream
@ -143,7 +141,6 @@ BuildRequires: libclc-devel opencl-filesystem
BuildRequires: vulkan-devel
%endif
BuildRequires: python-mako
BuildRequires: libstdc++-static
%ifarch %{valgrind_arches}
BuildRequires: pkgconfig(valgrind)
%endif
@ -369,7 +366,8 @@ Headers for development with the Vulkan API.
%endif
%prep
%autosetup -n %{name}-%{version}%{?rctag:-%{rctag}} -p1
#autosetup -n %{name}-%{version}%{?rctag:-%{rctag}} -p1
%autosetup -n %{name}-17.3.0-devel -p1
%if 0%{sanitize}
cp -f %{SOURCE1} src/gallium/auxiliary/vl/vl_decoder.c
cp -f %{SOURCE2} src/gallium/auxiliary/vl/vl_mpeg12_decoder.c
@ -377,10 +375,6 @@ Headers for development with the Vulkan API.
cp %{SOURCE3} docs/
# this is a hack for S3TC support. r200_screen.c is symlinked to
# radeon_screen.c in git, but is its own file in the tarball.
cp -f src/mesa/drivers/dri/{radeon,r200}/radeon_screen.c
%build
autoreconf -vfi
@ -389,8 +383,7 @@ autoreconf -vfi
#
# We do say 'catch' in the clover and d3d1x state trackers, but we're not
# building those yet.
export CXXFLAGS="%{?with_opencl:-frtti -fexceptions} %{!?with_opencl:-fno-rtti -fno-exceptions}"
export LDFLAGS="-static-libstdc++"
# export CXXFLAGS="%{?with_opencl:-frtti -fexceptions} %{!?with_opencl:-fno-rtti -fno-exceptions}"
%ifarch %{ix86}
# i do not have words for how much the assembly dispatch code infuriates me
%global asm_flags --disable-asm
@ -430,13 +423,6 @@ export LDFLAGS="-static-libstdc++"
%endif
%{?dri_drivers}
# libtool refuses to pass through things you ask for in LDFLAGS that it doesn't
# know about, like -static-libstdc++, so...
sed -i 's/-fuse-linker-plugin|/-static-lib*|&/' libtool
sed -i 's/-nostdlib//g' libtool
sed -i 's/^predep_objects=.*$/#&/' libtool
sed -i 's/^postdep_objects=.*$/#&/' libtool
sed -i 's/^postdeps=.*$/#&/' libtool
%make_build MKDEP=/bin/true V=1
%install
@ -694,6 +680,9 @@ popd
%endif
%changelog
* Mon Nov 06 2017 Adam Jackson <ajax@redhat.com> - 17.3.99.0-0.1
- today's git snapshot
* Tue Oct 31 2017 Peter Robinson <pbrobinson@fedoraproject.org> 17.2.4-1
- Update to 17.2.4 GA

View file

@ -1 +1,2 @@
SHA512 (mesa-17.2.4.tar.xz) = 665b63aab6af3f8f263f182d85d9ad71db7a23bcbaf67d62fe53c258cb0f600266ac82e72d681ec20cf7c66b47d4076aad5c3f553519f19110ee577da2707085
SHA512 (mesa-17.3.0-devel.tar.xz) = 5ea482ad85d93cc0fd18ba96539fc7b4cf26da225a39d5c66e5f8e0cb9f2e468333ff655ec8f28480720a35b38508463069add04843d5170b62a0ddc73ae5cd2