mirror of
https://src.fedoraproject.org/rpms/nodejs18.git
synced 2024-11-28 11:06:08 +00:00
b9ddd6c483
- Use %{?epel} tag to maintain a single specfile - Relax openssl requirement to 1.0.1+ for EPEL 7 - Don't use weak dependencies in EPEL
76 lines
2.8 KiB
Diff
76 lines
2.8 KiB
Diff
From 6ecf32b36eab498da24a5e23d08713e19ab341a5 Mon Sep 17 00:00:00 2001
|
|
From: Stephen Gallagher <sgallagh@redhat.com>
|
|
Date: Thu, 8 Sep 2016 12:54:20 -0400
|
|
Subject: [PATCH] Use Fedora OpenSSL build flags
|
|
|
|
---
|
|
deps/openssl/config/Makefile | 5 ++++-
|
|
deps/openssl/openssl.gypi | 9 ++++++---
|
|
2 files changed, 10 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/deps/openssl/config/Makefile b/deps/openssl/config/Makefile
|
|
index c8155b16d8dcfbc7ade7cd463248236d989b0599..7a319fd13b06b0520b3e118691381f27fdccf1a0 100644
|
|
--- a/deps/openssl/config/Makefile
|
|
+++ b/deps/openssl/config/Makefile
|
|
@@ -1,8 +1,11 @@
|
|
PERL = perl
|
|
CONFIGURE = ./Configure
|
|
-COPT = no-shared no-symlinks
|
|
+COPT = no-shared no-symlinks \
|
|
+ zlib sctp enable-camellia enable-seed enable-tlsext enable-rfc3779 \
|
|
+ enable-cms enable-md2 enable-rc5 \
|
|
+ no-mdc2 no-ec2m no-gost no-srp
|
|
|
|
ARCHS = aix-gcc aix64-gcc BSD-x86 BSD-x86_64 VC-WIN32 \
|
|
VC-WIN64A darwin64-x86_64-cc darwin-i386-cc linux-aarch64 \
|
|
linux-armv4 linux-elf linux-x32 linux-x86_64 linux-ppc \
|
|
linux-ppc64 linux32-s390x linux64-s390x solaris-x86-gcc \
|
|
diff --git a/deps/openssl/openssl.gypi b/deps/openssl/openssl.gypi
|
|
index 3620e45c41074647ef54f040a539c0d1c4f9b7d9..549e87348fb8c929f80ffd651df1bf6591b071d2 100644
|
|
--- a/deps/openssl/openssl.gypi
|
|
+++ b/deps/openssl/openssl.gypi
|
|
@@ -383,11 +383,10 @@
|
|
'openssl/crypto/evp/m_dss1.c',
|
|
'openssl/crypto/evp/m_ecdsa.c',
|
|
'openssl/crypto/evp/m_md2.c',
|
|
'openssl/crypto/evp/m_md4.c',
|
|
'openssl/crypto/evp/m_md5.c',
|
|
- 'openssl/crypto/evp/m_mdc2.c',
|
|
'openssl/crypto/evp/m_null.c',
|
|
'openssl/crypto/evp/m_ripemd.c',
|
|
'openssl/crypto/evp/m_sha.c',
|
|
'openssl/crypto/evp/m_sha1.c',
|
|
'openssl/crypto/evp/m_sigver.c',
|
|
@@ -420,12 +419,10 @@
|
|
'openssl/crypto/lhash/lhash.c',
|
|
'openssl/crypto/md4/md4_dgst.c',
|
|
'openssl/crypto/md4/md4_one.c',
|
|
'openssl/crypto/md5/md5_dgst.c',
|
|
'openssl/crypto/md5/md5_one.c',
|
|
- 'openssl/crypto/mdc2/mdc2_one.c',
|
|
- 'openssl/crypto/mdc2/mdc2dgst.c',
|
|
'openssl/crypto/mem.c',
|
|
'openssl/crypto/mem_dbg.c',
|
|
'openssl/crypto/modes/cbc128.c',
|
|
'openssl/crypto/modes/ccm128.c',
|
|
'openssl/crypto/modes/cfb128.c',
|
|
@@ -1261,10 +1258,16 @@
|
|
# Heartbeat is a TLS extension, that couldn't be turned off or
|
|
# asked to be not advertised. Unfortunately this is unacceptable for
|
|
# Microsoft's IIS, which seems to be ignoring whole ClientHello after
|
|
# seeing this extension.
|
|
'OPENSSL_NO_HEARTBEATS',
|
|
+
|
|
+ # Taken from Fedora package:
|
|
+ 'OPENSSL_NO_SRP',
|
|
+ 'OPENSSL_NO_GOST',
|
|
+ 'OPENSSL_NO_MDC2',
|
|
+ 'OPENSSL_NO_EC2M',
|
|
],
|
|
'openssl_default_defines_win': [
|
|
'MK1MF_BUILD',
|
|
'WIN32_LEAN_AND_MEAN',
|
|
'OPENSSL_SYSNAME_WIN32',
|
|
--
|
|
2.7.4
|
|
|