Update to 12.1.0

https://nodejs.org/en/blog/release/v12.1.0/

Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
Stephen Gallagher 2019-04-30 08:51:56 -04:00
parent bfa1e93cd6
commit a724e42805
No known key found for this signature in database
GPG key ID: 7A25556236BAA3A3
7 changed files with 20 additions and 21 deletions

View file

@ -1,4 +1,4 @@
From be67711060761dcb520dc538582bc497c978a211 Mon Sep 17 00:00:00 2001
From 716c544b0272c89458ed168f3459f873be2f3035 Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Thu, 27 Apr 2017 14:25:42 +0200
Subject: [PATCH 1/3] Disable running gyp on shared deps
@ -8,7 +8,7 @@ Subject: [PATCH 1/3] Disable running gyp on shared deps
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index d04aac3515a1812d120555297f2b340baaea58f8..a91651e22a9d6b7891255071b38217dc358781af 100644
index d41bf1601fb5990ae70e0e13fb105677ef8f9b86..4d9b363c7c0eeb83f34cedf2266e939d4ad140e7 100644
--- a/Makefile
+++ b/Makefile
@@ -114,11 +114,11 @@ with-code-cache:

View file

@ -1,4 +1,4 @@
From a3aeb06b2ed164e220d1ef1ff42256c3e7d0ad25 Mon Sep 17 00:00:00 2001
From f60c5f106a993adee0f66e44f70a1fee562108e0 Mon Sep 17 00:00:00 2001
From: Stephen Gallagher <sgallagh@redhat.com>
Date: Tue, 1 May 2018 08:05:30 -0400
Subject: [PATCH 2/3] Suppress NPM message to run global update

View file

@ -1,4 +1,4 @@
From 7e18c5370e11d7cecc1801756870c036cf26dd12 Mon Sep 17 00:00:00 2001
From 6be87e48c3b907dfb4c75b7f415b5107189799f0 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Tue, 19 Mar 2019 23:22:40 -0400
Subject: [PATCH 3/3] Install both binaries and use libdir.
@ -13,10 +13,10 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
2 files changed, 20 insertions(+), 16 deletions(-)
diff --git a/configure.py b/configure.py
index 1a0819e74113bc22a2e92eb08502b1fc33874343..caeb29d2868e0b88c98c3a5261dedd6305c5bc50 100755
index 1dd6da6d2b997a3fea602c7ad4ab6ce4197bfc18..b0ae741588fa91cb4a0f6bd483ae0c6469cbc114 100755
--- a/configure.py
+++ b/configure.py
@@ -529,10 +529,16 @@ parser.add_option('--shared',
@@ -534,10 +534,16 @@ parser.add_option('--shared',
action='store_true',
dest='shared',
help='compile shared library for embedding node in another project. ' +
@ -33,7 +33,7 @@ index 1a0819e74113bc22a2e92eb08502b1fc33874343..caeb29d2868e0b88c98c3a5261dedd63
dest='without_v8_platform',
default=False,
help='do not initialize v8 platform during node.js startup. ' +
@@ -1053,10 +1059,11 @@ def configure_node(o):
@@ -1065,10 +1071,11 @@ def configure_node(o):
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
# TODO(refack): fix this when implementing embedded code-cache when cross-compiling.
if o['variables']['want_separate_host_toolset'] == 0:

View file

@ -1,2 +0,0 @@
[koji]
targets = master f29

View file

@ -1,10 +1,12 @@
#!/bin/sh
version=$(rpm -q --specfile --qf='%{version}\n' nodejs.spec | head -n1)
rm -f node-v${version}.tar.gz
rm -f node-v${version}.tar.gz node-v${version}-stripped.tar.gz
wget http://nodejs.org/dist/v${version}/node-v${version}.tar.gz
tar -zxf node-v${version}.tar.gz
rm -rf node-v${version}/deps/openssl
tar -zcf node-v${version}-stripped.tar.gz node-v${version}
fedpkg new-sources node-v${version}-stripped.tar.gz
rm -f node-v${version}.tar.gz

View file

@ -12,13 +12,13 @@
# than a Fedora release lifecycle.
%global nodejs_epoch 1
%global nodejs_major 12
%global nodejs_minor 0
%global nodejs_minor 1
%global nodejs_patch 0
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
%global nodejs_soversion 72
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
%global nodejs_release 3
%global nodejs_release 1
# == Bundled Dependency Versions ==
# v8 - from deps/v8/include/v8-version.h
@ -64,19 +64,14 @@
%global nghttp2_version %{nghttp2_major}.%{nghttp2_minor}.%{nghttp2_patch}
# ICU - from tools/icu/current_ver.dep
%global icu_major 63
%global icu_minor 1
%global icu_major 64
%global icu_minor 2
%global icu_version %{icu_major}.%{icu_minor}
%global icu_flag small-icu
# OpenSSL minimum version
%global openssl_minimum 1:1.1.1
%if 0%{?fedora} >= 30
%global icu_flag system-icu
%else
%global icu_flag small-icu
%endif
# punycode - from lib/punycode.js
# Note: this was merged into the mainline since 0.6.x
# Note: this will be unmerged in an upcoming major release
@ -583,6 +578,10 @@ end
%{_pkgdocdir}/npm/doc
%changelog
* Tue Apr 30 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.1.0-1
- Update to 12.1.0
- https://nodejs.org/en/blog/release/v12.1.0/
* Wed Apr 24 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.0.0-3
- Fix upgrade bug for v8-devel (BZ #1702609)

View file

@ -1 +1 @@
SHA512 (node-v12.0.0-stripped.tar.gz) = 68bec09de987059f361a9a7fb25a66eab35bd848a8dd2e000000ac6cc0c6fa2e7ec901ed0cd12e609b3303ecb6b598a10054afc66764d3d43153c323e773cb86
SHA512 (node-v12.1.0-stripped.tar.gz) = 367111600786d57291725e0452f532d7c8c6bfe72259b654fc2518323cb7c49576fe8678de69b559b93cf7a03ae2a2fe4f116a43bba740b2d2e1df5e49582cae