mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-24 17:35:18 +00:00
208a9dd10d
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com> Conflicts: mesa.spec
44 lines
1.6 KiB
Diff
44 lines
1.6 KiB
Diff
From 34fa604acfa3d9d66524eacaa239c3251dc3237b Mon Sep 17 00:00:00 2001
|
|
From: Lubomir Rintel <lkundrak@v3.sk>
|
|
Date: Wed, 28 May 2014 08:56:12 +0200
|
|
Subject: [PATCH] i915: add a missing NULL pointer check
|
|
|
|
mesaVisual can be NULL with configless context since this commit:
|
|
|
|
commit 551d459af421a2eb937e9e16301bb64da4624f89
|
|
Author: Neil Roberts <neil@linux.intel.com>
|
|
Date: Fri Mar 7 18:05:47 2014 +0000
|
|
|
|
Add the EGL_MESA_configless_context extension
|
|
...
|
|
Previously the i965 and i915 drivers were explicitly creating a zeroed visual
|
|
whenever 0 is passed for the EGLConfig.
|
|
|
|
We attempt to dereference the visual in i915 and now we don't create a
|
|
zeroed-out one one it crashes, breaking at least weston in an i915. There's
|
|
no point in doing so as it would be zero anyway.
|
|
|
|
Signed-off-by: Lubomir Rintel <lkundrak@v3.sk>
|
|
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1100967
|
|
Cc: "10.2" <mesa-stable@lists.freedesktop.org>
|
|
Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
|
|
---
|
|
src/mesa/drivers/dri/i915/intel_context.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/mesa/drivers/dri/i915/intel_context.c b/src/mesa/drivers/dri/i915/intel_context.c
|
|
index a6057d3..09fe371 100644
|
|
--- a/src/mesa/drivers/dri/i915/intel_context.c
|
|
+++ b/src/mesa/drivers/dri/i915/intel_context.c
|
|
@@ -507,7 +507,7 @@ intelInitContext(struct intel_context *intel,
|
|
|
|
_mesa_meta_init(ctx);
|
|
|
|
- intel->hw_stencil = mesaVis->stencilBits && mesaVis->depthBits == 24;
|
|
+ intel->hw_stencil = mesaVis && mesaVis->stencilBits && mesaVis->depthBits == 24;
|
|
intel->hw_stipple = 1;
|
|
|
|
intel->RenderIndex = ~0;
|
|
--
|
|
1.9.3
|
|
|