mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-12-01 12:10:53 +00:00
- Update mesa to latest git snapshot - drop patches merged upstream
This commit is contained in:
parent
93054d764e
commit
f8d0402a0c
3 changed files with 49 additions and 50 deletions
|
@ -1 +1 @@
|
|||
mesa-20080415.tar.bz2
|
||||
mesa-20080612.tar.bz2
|
||||
|
|
|
@ -1,41 +1,6 @@
|
|||
diff -up mesa-20080331/src/mesa/x86/read_rgba_span_x86.S.jx mesa-20080331/src/mesa/x86/read_rgba_span_x86.S
|
||||
--- mesa-20080331/src/mesa/x86/read_rgba_span_x86.S.jx 2008-03-31 16:58:48.000000000 -0400
|
||||
+++ mesa-20080331/src/mesa/x86/read_rgba_span_x86.S 2008-04-10 12:11:31.000000000 -0400
|
||||
@@ -77,7 +77,6 @@
|
||||
*/
|
||||
|
||||
.globl _generic_read_RGBA_span_BGRA8888_REV_MMX
|
||||
-.hidden _generic_read_RGBA_span_BGRA8888_REV_MMX
|
||||
.type _generic_read_RGBA_span_BGRA8888_REV_MMX, @function
|
||||
_generic_read_RGBA_span_BGRA8888_REV_MMX:
|
||||
pushl %ebx
|
||||
@@ -172,7 +171,6 @@ _generic_read_RGBA_span_BGRA8888_REV_MMX
|
||||
*/
|
||||
|
||||
.globl _generic_read_RGBA_span_BGRA8888_REV_SSE
|
||||
-.hidden _generic_read_RGBA_span_BGRA8888_REV_SSE
|
||||
.type _generic_read_RGBA_span_BGRA8888_REV_SSE, @function
|
||||
_generic_read_RGBA_span_BGRA8888_REV_SSE:
|
||||
pushl %esi
|
||||
@@ -335,7 +333,6 @@ _generic_read_RGBA_span_BGRA8888_REV_SSE
|
||||
|
||||
.text
|
||||
.globl _generic_read_RGBA_span_BGRA8888_REV_SSE2
|
||||
-.hidden _generic_read_RGBA_span_BGRA8888_REV_SSE2
|
||||
.type _generic_read_RGBA_span_BGRA8888_REV_SSE2, @function
|
||||
_generic_read_RGBA_span_BGRA8888_REV_SSE2:
|
||||
pushl %esi
|
||||
@@ -492,7 +489,6 @@ _generic_read_RGBA_span_BGRA8888_REV_SSE
|
||||
|
||||
.text
|
||||
.globl _generic_read_RGBA_span_RGB565_MMX
|
||||
- .hidden _generic_read_RGBA_span_RGB565_MMX
|
||||
.type _generic_read_RGBA_span_RGB565_MMX, @function
|
||||
|
||||
_generic_read_RGBA_span_RGB565_MMX:
|
||||
diff -up mesa-20080331/src/mesa/drivers/dri/Makefile.jx mesa-20080331/src/mesa/drivers/dri/Makefile
|
||||
--- mesa-20080331/src/mesa/drivers/dri/Makefile.jx 2008-03-31 16:58:48.000000000 -0400
|
||||
+++ mesa-20080331/src/mesa/drivers/dri/Makefile 2008-04-10 12:02:30.000000000 -0400
|
||||
diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.dricore mesa-20080612/src/mesa/drivers/dri/Makefile
|
||||
--- mesa-20080612/src/mesa/drivers/dri/Makefile.dricore 2008-06-12 12:06:50.000000000 +1000
|
||||
+++ mesa-20080612/src/mesa/drivers/dri/Makefile 2008-06-12 13:25:58.000000000 +1000
|
||||
@@ -6,12 +6,17 @@ include $(TOP)/configs/current
|
||||
|
||||
|
||||
|
@ -67,19 +32,19 @@ diff -up mesa-20080331/src/mesa/drivers/dri/Makefile.jx mesa-20080331/src/mesa/d
|
|||
fi \
|
||||
done
|
||||
+ $(INSTALL) -d $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
||||
+ $(INSTALL) -m 755 $(TOP)/$(LIB_DIR)/libdricore.so $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
||||
$(TOP)/bin/minstall -d $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
||||
$(TOP)/bin/minstall -m 0644 $(TOP)/include/GL/internal/dri_interface.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
||||
$(TOP)/bin/minstall -m 0644 $(TOP)/include/GL/internal/dri_sarea.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
||||
+ $(INSTALL) -m 755 -d $(TOP)/$(LIB_DIR)/libdricore.so $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
||||
$(INSTALL) -d $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
||||
$(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_interface.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
||||
$(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_sarea.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
||||
@@ -38,4 +45,5 @@ clean:
|
||||
(cd $$dir && $(MAKE) clean) ; \
|
||||
fi \
|
||||
done
|
||||
+ -rm -f libdricore.so $(TOP)/$(LIB_DIR)/libdricore.so
|
||||
-rm -f common/*.o
|
||||
diff -up mesa-20080331/src/mesa/drivers/dri/Makefile.template.jx mesa-20080331/src/mesa/drivers/dri/Makefile.template
|
||||
--- mesa-20080331/src/mesa/drivers/dri/Makefile.template.jx 2008-03-31 16:58:48.000000000 -0400
|
||||
+++ mesa-20080331/src/mesa/drivers/dri/Makefile.template 2008-04-10 12:02:30.000000000 -0400
|
||||
diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.template.dricore mesa-20080612/src/mesa/drivers/dri/Makefile.template
|
||||
--- mesa-20080612/src/mesa/drivers/dri/Makefile.template.dricore 2008-06-12 12:06:50.000000000 +1000
|
||||
+++ mesa-20080612/src/mesa/drivers/dri/Makefile.template 2008-06-12 13:15:34.000000000 +1000
|
||||
@@ -1,6 +1,6 @@
|
||||
# -*-makefile-*-
|
||||
|
||||
|
@ -87,8 +52,8 @@ diff -up mesa-20080331/src/mesa/drivers/dri/Makefile.template.jx mesa-20080331/s
|
|||
+MESA_MODULES = $(TOP)/$(LIB_DIR)/libdricore.so
|
||||
|
||||
COMMON_SOURCES = \
|
||||
../../common/driverfuncs.c \
|
||||
@@ -70,7 +70,9 @@ default: symlinks depend $(LIBNAME) $(TO
|
||||
../common/utils.c \
|
||||
@@ -69,7 +69,9 @@ default: symlinks depend $(LIBNAME) $(TO
|
||||
|
||||
$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(WINOBJ) Makefile $(TOP)/src/mesa/drivers/dri/Makefile.template
|
||||
$(TOP)/bin/mklib -ldflags '$(LDFLAGS)' -noprefix -o $@ \
|
||||
|
@ -99,3 +64,38 @@ diff -up mesa-20080331/src/mesa/drivers/dri/Makefile.template.jx mesa-20080331/s
|
|||
|
||||
|
||||
$(TOP)/$(LIB_DIR)/$(LIBNAME): $(LIBNAME)
|
||||
diff -up mesa-20080612/src/mesa/x86/read_rgba_span_x86.S.dricore mesa-20080612/src/mesa/x86/read_rgba_span_x86.S
|
||||
--- mesa-20080612/src/mesa/x86/read_rgba_span_x86.S.dricore 2008-06-12 12:06:50.000000000 +1000
|
||||
+++ mesa-20080612/src/mesa/x86/read_rgba_span_x86.S 2008-06-12 13:15:34.000000000 +1000
|
||||
@@ -77,7 +77,6 @@
|
||||
*/
|
||||
|
||||
.globl _generic_read_RGBA_span_BGRA8888_REV_MMX
|
||||
-.hidden _generic_read_RGBA_span_BGRA8888_REV_MMX
|
||||
.type _generic_read_RGBA_span_BGRA8888_REV_MMX, @function
|
||||
_generic_read_RGBA_span_BGRA8888_REV_MMX:
|
||||
pushl %ebx
|
||||
@@ -172,7 +171,6 @@ _generic_read_RGBA_span_BGRA8888_REV_MMX
|
||||
*/
|
||||
|
||||
.globl _generic_read_RGBA_span_BGRA8888_REV_SSE
|
||||
-.hidden _generic_read_RGBA_span_BGRA8888_REV_SSE
|
||||
.type _generic_read_RGBA_span_BGRA8888_REV_SSE, @function
|
||||
_generic_read_RGBA_span_BGRA8888_REV_SSE:
|
||||
pushl %esi
|
||||
@@ -335,7 +333,6 @@ _generic_read_RGBA_span_BGRA8888_REV_SSE
|
||||
|
||||
.text
|
||||
.globl _generic_read_RGBA_span_BGRA8888_REV_SSE2
|
||||
-.hidden _generic_read_RGBA_span_BGRA8888_REV_SSE2
|
||||
.type _generic_read_RGBA_span_BGRA8888_REV_SSE2, @function
|
||||
_generic_read_RGBA_span_BGRA8888_REV_SSE2:
|
||||
pushl %esi
|
||||
@@ -494,7 +491,6 @@ _generic_read_RGBA_span_BGRA8888_REV_SSE
|
||||
|
||||
.text
|
||||
.globl _generic_read_RGBA_span_RGB565_MMX
|
||||
- .hidden _generic_read_RGBA_span_RGB565_MMX
|
||||
.type _generic_read_RGBA_span_RGB565_MMX, @function
|
||||
|
||||
_generic_read_RGBA_span_RGB565_MMX:
|
||||
|
|
3
sources
3
sources
|
@ -1,2 +1 @@
|
|||
4c32a78a28832fa34e0a5a04c6b9057c mesa-20080415.tar.bz2
|
||||
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
||||
cb23563c7ce33823de218351abfdc424 mesa-20080612.tar.bz2
|
||||
|
|
Loading…
Reference in a new issue