10.2.2 upstream release

Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
Igor Gnatenko 2014-06-25 20:14:40 +04:00
parent b9f23898bd
commit f002bb3166
5 changed files with 12 additions and 46 deletions

1
.gitignore vendored
View file

@ -75,3 +75,4 @@ mesa-20100720.tar.bz2
/mesa-20140524.tar.xz
/mesa-20140531.tar.xz
/mesa-20140608.tar.xz
/mesa-20140625.tar.xz

View file

@ -1,34 +0,0 @@
From 1fb986f3a722e8476af90b5ab512e495f0caf10f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Kristian=20H=C3=B8gsberg?= <krh@bitplanet.net>
Date: Thu, 6 Mar 2014 16:58:32 -0800
Subject: [PATCH] mesa: Don't optimize out glClear() if drawbuffer size is 0x0
The driver acquires buffer lazily and may not yet have buffers for
a newly current drawable. In that case the drawable size is 0x0 but
we still need to call into the driver and make it fetch buffers and get
the drawable size.
https://bugs.freedesktop.org/show_bug.cgi?id=75797
---
src/mesa/main/clear.c | 5 -----
1 file changed, 5 deletions(-)
diff --git a/src/mesa/main/clear.c b/src/mesa/main/clear.c
index 077c5fc..c3f7474 100644
--- a/src/mesa/main/clear.c
+++ b/src/mesa/main/clear.c
@@ -155,11 +155,6 @@ _mesa_Clear( GLbitfield mask )
return;
}
- if (ctx->DrawBuffer->Width == 0 || ctx->DrawBuffer->Height == 0 ||
- ctx->DrawBuffer->_Xmin >= ctx->DrawBuffer->_Xmax ||
- ctx->DrawBuffer->_Ymin >= ctx->DrawBuffer->_Ymax)
- return;
-
if (ctx->RasterDiscard)
return;
--
1.8.5.3

View file

@ -1,4 +1,4 @@
From 6da9f2a229a1b519e8cd1f794d6c2a63fedfa92e Mon Sep 17 00:00:00 2001
From 062e79e1cc1e2d22d5d9d7fe5d394b923372fe45 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 12 Jan 2014 02:09:16 +0400
Subject: [PATCH] opencl: use versioned .so in mesa.icd
@ -19,7 +19,7 @@ Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
create mode 100644 src/gallium/targets/opencl/mesa.icd.in
diff --git a/configure.ac b/configure.ac
index e77ed77..e363c03 100644
index 164b662..fe64a9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,8 @@ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
@ -31,7 +31,7 @@ index e77ed77..e363c03 100644
dnl Versions for external dependencies
LIBDRM_REQUIRED=2.4.38
@@ -2084,6 +2086,7 @@ AC_CONFIG_FILES([Makefile
@@ -2111,6 +2113,7 @@ AC_CONFIG_FILES([Makefile
src/gallium/targets/egl-static/Makefile
src/gallium/targets/gbm/Makefile
src/gallium/targets/opencl/Makefile
@ -67,5 +67,5 @@ index 0000000..1b77b4e
@@ -0,0 +1 @@
+lib@OPENCL_LIBNAME@.so.@OPENCL_VERSION@
--
1.9.0
2.0.0

View file

@ -53,13 +53,13 @@
%define _default_patch_fuzz 2
%define gitdate 20140608
%define gitdate 20140625
#% define snapshot
Summary: Mesa graphics libraries
Name: mesa
Version: 10.2.1
Release: 2.%{gitdate}%{?dist}
Version: 10.2.2
Release: 1.%{gitdate}%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -81,9 +81,6 @@ Patch12: mesa-8.0.1-fix-16bpp.patch
Patch15: mesa-9.2-hardware-float.patch
Patch20: mesa-10.2-evergreen-big-endian.patch
# https://bugs.freedesktop.org/show_bug.cgi?id=75797#c1
Patch21: 0001-mesa-Don-t-optimize-out-glClear-if-drawbuffer-size-i.patch
# https://bugs.freedesktop.org/show_bug.cgi?id=73512
Patch99: 0001-opencl-use-versioned-.so-in-mesa.icd.patch
@ -349,7 +346,6 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
%patch15 -p1 -b .hwfloat
%patch20 -p1 -b .egbe
%patch21 -p1 -b .clear
%if 0%{?with_opencl}
%patch99 -p1 -b .icd
@ -678,6 +674,9 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Wed Jun 25 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.2.2-1.20140625
- 10.2.2 upstream release
* Wed Jun 11 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.2.1-2.20140608
- drop radeonsi llvm hack

View file

@ -1 +1 @@
d13f9daee8988b3452d1a75cf00eed50 mesa-20140608.tar.xz
8a26f433b965314d18d765b83ef8de9e mesa-20140625.tar.xz