mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-24 09:32:42 +00:00
Update to 21.1.0
This commit is contained in:
parent
fc34e2dc2e
commit
dce194d3d5
4 changed files with 8 additions and 167 deletions
36
10440.patch
36
10440.patch
|
@ -1,36 +0,0 @@
|
|||
From 25fc9a4560221ccd4f6fb6e790650968531dea11 Mon Sep 17 00:00:00 2001
|
||||
From: Bas Nieuwenhuizen <bas@basnieuwenhuizen.nl>
|
||||
Date: Sat, 24 Apr 2021 16:23:43 +0200
|
||||
Subject: [PATCH] amd/common: Add missing line from backport for coherency.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
The line initializing the variable was missed.
|
||||
|
||||
Fixes: ccc4abdbf4b ("ac/gpu_info: fix more non-coherent RB and GL2 combinations")
|
||||
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/4691
|
||||
Reviewed-by: Marek Olšák <marek.olsak@amd.com>
|
||||
Reviewed-by: Pierre-Eric Pelloux-Prayer <pierre-eric.pelloux-prayer@amd.com>
|
||||
Reviewed-by: Samuel Pitoiset <samuel.pitoiset@gmail.com>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/10440>
|
||||
---
|
||||
src/amd/common/ac_gpu_info.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/amd/common/ac_gpu_info.c b/src/amd/common/ac_gpu_info.c
|
||||
index 47e6b8c332f..44728827197 100644
|
||||
--- a/src/amd/common/ac_gpu_info.c
|
||||
+++ b/src/amd/common/ac_gpu_info.c
|
||||
@@ -710,6 +710,8 @@ bool ac_query_gpu_info(int fd, void *dev_p, struct radeon_info *info,
|
||||
info->num_tcc_blocks = info->max_tcc_blocks;
|
||||
}
|
||||
|
||||
+ info->tcc_rb_non_coherent = !util_is_power_of_two_or_zero(info->num_tcc_blocks);
|
||||
+
|
||||
info->mc_arb_ramcfg = amdinfo->mc_arb_ramcfg;
|
||||
info->gb_addr_config = amdinfo->gb_addr_cfg;
|
||||
if (info->chip_class >= GFX9) {
|
||||
--
|
||||
GitLab
|
||||
|
|
@ -1,118 +0,0 @@
|
|||
From d1eab2b1eb1dec10197db7d25e27d97f6ca1a2ea Mon Sep 17 00:00:00 2001
|
||||
From: Karol Herbst <kherbst@redhat.com>
|
||||
Date: Wed, 24 Feb 2021 12:44:41 +0100
|
||||
Subject: [PATCH] clover: Fix build with llvm-12.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Fix build error after LLVM commit c495dfe0268b ("[clang][cli] NFC:
|
||||
Decrease the scope of ParseLangArgs parameters").
|
||||
|
||||
../src/gallium/frontends/clover/llvm/invocation.cpp: In function ‘std::unique_ptr<clang::CompilerInstance> {anonymous}::create_compiler_instance(const clover::device&, const string&, const std::vector<std::__cxx11::basic_string<char> >&, std::string&)’:
|
||||
../src/gallium/frontends/clover/llvm/invocation.cpp:252:55: error: cannot convert ‘clang::PreprocessorOptions’ to ‘std::vector<std::__cxx11::basic_string<char> >&’
|
||||
252 | c->getPreprocessorOpts(),
|
||||
| ~~~~~~~~~~~~~~~~~~~~~~^~
|
||||
| |
|
||||
| clang::PreprocessorOptions
|
||||
|
||||
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/4114
|
||||
Signed-off-by: Karol Herbst <kherbst@redhat.com>
|
||||
Reviewed-by: Francisco Jerez <currojerez@riseup.net>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/8543>
|
||||
---
|
||||
src/gallium/frontends/clover/llvm/compat.hpp | 22 +++++++++++++++----
|
||||
.../frontends/clover/llvm/invocation.cpp | 5 ++---
|
||||
2 files changed, 20 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/frontends/clover/llvm/compat.hpp b/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
index 78eb8c982a8..d537819f292 100644
|
||||
--- a/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
+++ b/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
@@ -38,14 +38,14 @@
|
||||
|
||||
#include <llvm/Config/llvm-config.h>
|
||||
|
||||
+#include <llvm/ADT/Triple.h>
|
||||
+#include <llvm/Analysis/TargetLibraryInfo.h>
|
||||
+#include <llvm/IR/LegacyPassManager.h>
|
||||
#include <llvm/IR/LLVMContext.h>
|
||||
#include <llvm/Linker/Linker.h>
|
||||
+#include <llvm/Target/TargetMachine.h>
|
||||
#include <llvm/Transforms/IPO.h>
|
||||
#include <llvm/Transforms/Utils/Cloning.h>
|
||||
-#include <llvm/Target/TargetMachine.h>
|
||||
-
|
||||
-#include <llvm/IR/LegacyPassManager.h>
|
||||
-#include <llvm/Analysis/TargetLibraryInfo.h>
|
||||
|
||||
#include <clang/Basic/TargetInfo.h>
|
||||
#include <clang/Frontend/CompilerInstance.h>
|
||||
@@ -88,6 +88,20 @@ namespace clover {
|
||||
cinv, copts.data(), copts.data() + copts.size(), diag);
|
||||
#endif
|
||||
}
|
||||
+
|
||||
+ static inline void
|
||||
+ compiler_set_lang_defaults(std::unique_ptr<clang::CompilerInstance> &c,
|
||||
+ clang::InputKind ik, const ::llvm::Triple& triple,
|
||||
+ clang::LangStandard::Kind d)
|
||||
+ {
|
||||
+ c->getInvocation().setLangDefaults(c->getLangOpts(), ik, triple,
|
||||
+#if LLVM_VERSION_MAJOR >= 12
|
||||
+ c->getPreprocessorOpts().Includes,
|
||||
+#else
|
||||
+ c->getPreprocessorOpts(),
|
||||
+#endif
|
||||
+ d);
|
||||
+ }
|
||||
}
|
||||
}
|
||||
}
|
||||
diff --git a/src/gallium/frontends/clover/llvm/invocation.cpp b/src/gallium/frontends/clover/llvm/invocation.cpp
|
||||
index 536e952b100..30592e4343b 100644
|
||||
--- a/src/gallium/frontends/clover/llvm/invocation.cpp
|
||||
+++ b/src/gallium/frontends/clover/llvm/invocation.cpp
|
||||
@@ -247,9 +247,8 @@ namespace {
|
||||
// http://www.llvm.org/bugs/show_bug.cgi?id=19735
|
||||
c->getDiagnosticOpts().ShowCarets = false;
|
||||
|
||||
- c->getInvocation().setLangDefaults(c->getLangOpts(),
|
||||
- compat::ik_opencl, ::llvm::Triple(target.triple),
|
||||
- c->getPreprocessorOpts(),
|
||||
+ compat::compiler_set_lang_defaults(c, compat::ik_opencl,
|
||||
+ ::llvm::Triple(target.triple),
|
||||
get_language_version(opts, device_clc_version));
|
||||
|
||||
c->createDiagnostics(new clang::TextDiagnosticPrinter(
|
||||
--
|
||||
GitLab
|
||||
|
||||
From f0dccd957879ff642cfd921dda6e8b04dd35fec4 Mon Sep 17 00:00:00 2001
|
||||
From: Karol Herbst <kherbst@redhat.com>
|
||||
Date: Tue, 2 Mar 2021 20:09:39 +0100
|
||||
Subject: [PATCH] clover: Add missing include for llvm-12 build fix
|
||||
|
||||
Fixes: d1eab2b1eb1 ("clover: Fix build with llvm-12.")
|
||||
Signed-off-by: Karol Herbst <kherbst@redhat.com>
|
||||
Reviewed-by: Francisco Jerez <currojerez@riseup.net>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/9372>
|
||||
---
|
||||
src/gallium/frontends/clover/llvm/compat.hpp | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/gallium/frontends/clover/llvm/compat.hpp b/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
index d537819f292..380d16a8346 100644
|
||||
--- a/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
+++ b/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
@@ -49,6 +49,7 @@
|
||||
|
||||
#include <clang/Basic/TargetInfo.h>
|
||||
#include <clang/Frontend/CompilerInstance.h>
|
||||
+#include <clang/Lex/PreprocessorOptions.h>
|
||||
|
||||
#if LLVM_VERSION_MAJOR >= 10
|
||||
#include <llvm/Support/CodeGen.h>
|
||||
--
|
||||
GitLab
|
||||
|
19
mesa.spec
19
mesa.spec
|
@ -56,9 +56,9 @@
|
|||
|
||||
Name: mesa
|
||||
Summary: Mesa graphics libraries
|
||||
%global ver 21.0.3
|
||||
%global ver 21.1.0
|
||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
URL: http://www.mesa3d.org
|
||||
|
||||
|
@ -68,12 +68,6 @@ Source0: https://mesa.freedesktop.org/archive/%{name}-%{ver}.tar.xz
|
|||
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
|
||||
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
||||
|
||||
# https://gitlab.freedesktop.org/mesa/mesa/-/issues/4442
|
||||
Patch0: mesa-llvm12.patch
|
||||
|
||||
# https://gitlab.freedesktop.org/mesa/mesa/-/issues/4691
|
||||
Patch1: 10440.patch
|
||||
|
||||
BuildRequires: meson >= 0.45
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
|
@ -135,6 +129,7 @@ BuildRequires: pkgconfig(valgrind)
|
|||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-mako
|
||||
BuildRequires: vulkan-headers
|
||||
BuildRequires: glslang
|
||||
%if 0%{?with_vulkan_hw}
|
||||
BuildRequires: pkgconfig(vulkan)
|
||||
%endif
|
||||
|
@ -349,7 +344,7 @@ cp %{SOURCE1} docs/
|
|||
-Dgallium-nine=%{?with_nine:true}%{!?with_nine:false} \
|
||||
-Dgallium-opencl=%{?with_opencl:icd}%{!?with_opencl:disabled} \
|
||||
-Dvulkan-drivers=%{?vulkan_drivers} \
|
||||
-Dvulkan-device-select-layer=true \
|
||||
-Dvulkan-layers=device-select \
|
||||
-Dshared-glapi=enabled \
|
||||
-Dgles1=disabled \
|
||||
-Dgles2=enabled \
|
||||
|
@ -610,11 +605,11 @@ popd
|
|||
%endif
|
||||
|
||||
%files vulkan-devel
|
||||
%ifarch %{ix86} x86_64
|
||||
%{_includedir}/vulkan/vulkan_intel.h
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed May 05 2021 Adam Jackson <ajax@redhat.com> - 21.1.0-1
|
||||
- Update to 21.1.0
|
||||
|
||||
* Thu Apr 29 2021 Kalev Lember <klember@redhat.com> - 21.0.3-2
|
||||
- Backport a fix for amdgpu graphics corruption regression
|
||||
|
||||
|
|
2
sources
2
sources
|
@ -1 +1 @@
|
|||
SHA512 (mesa-21.0.3.tar.xz) = 4a8aee48a8ea7f32e8aa3bbbd91db26c6053b9a43e62ff88256929e6bc147884f0fef988726b5a3d59d7008663f017c746a0352fd3fcc1c476b8190af4a2531f
|
||||
SHA512 (mesa-21.1.0.tar.xz) = 9d7617a6d5dd8ec1d93fdda8fe8b2f745695c02bc381d685f1257f7e7f08d5c06f3c57ae71c5f2dfaabb1742b8a88f47294a369bd3ac553f29835f24ce5dd350
|
||||
|
|
Loading…
Reference in a new issue