mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-24 17:35:18 +00:00
10.2.5 upstream release (RHBZ #1126223)
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
17dc7f453b
commit
c0c292399a
4 changed files with 7 additions and 49 deletions
1
.gitignore
vendored
1
.gitignore
vendored
|
@ -77,3 +77,4 @@ mesa-20100720.tar.bz2
|
|||
/mesa-20140608.tar.xz
|
||||
/mesa-20140625.tar.xz
|
||||
/mesa-20140711.tar.xz
|
||||
/mesa-20140806.tar.xz
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
From ea3ade19e2170bd67c3d5448fc38747b8e380d5a Mon Sep 17 00:00:00 2001
|
||||
From: Adel Gadllah <adel.gadllah@gmail.com>
|
||||
Date: Thu, 3 Jul 2014 22:13:53 +0200
|
||||
Subject: [PATCH] i915: Fix up intelInitScreen2 for DRI3
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Commit 442442026eb updated both i915 and i965 for DRI3 support,
|
||||
but one check in intelInitScreen2 was missed for i915 causing crashes
|
||||
when trying to use i915 with DRI3.
|
||||
|
||||
So fix that up.
|
||||
|
||||
Reported-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Tested-by: František Zatloukal <Zatloukal.Frantisek@gmail.com>
|
||||
Reference: https://bugzilla.redhat.com/show_bug.cgi?id=1115323
|
||||
Cc: "10.2" <mesa-stable@lists.freedesktop.org>
|
||||
Signed-off-by: Adel Gadllah <adel.gadllah@gmail.com>
|
||||
---
|
||||
src/mesa/drivers/dri/i915/intel_screen.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/mesa/drivers/dri/i915/intel_screen.c b/src/mesa/drivers/dri/i915/intel_screen.c
|
||||
index 9b4e490..4c9726c 100644
|
||||
--- a/src/mesa/drivers/dri/i915/intel_screen.c
|
||||
+++ b/src/mesa/drivers/dri/i915/intel_screen.c
|
||||
@@ -1152,7 +1152,8 @@ __DRIconfig **intelInitScreen2(__DRIscreen *psp)
|
||||
{
|
||||
struct intel_screen *intelScreen;
|
||||
|
||||
- if (psp->dri2.loader->base.version <= 2 ||
|
||||
+ if (psp->image.loader) {
|
||||
+ } else if (psp->dri2.loader->base.version <= 2 ||
|
||||
psp->dri2.loader->getBuffersWithFormat == NULL) {
|
||||
fprintf(stderr,
|
||||
"\nERROR! DRI2 loader with getBuffersWithFormat() "
|
||||
--
|
||||
2.0.0
|
||||
|
13
mesa.spec
13
mesa.spec
|
@ -47,12 +47,12 @@
|
|||
|
||||
%define _default_patch_fuzz 2
|
||||
|
||||
%define gitdate 20140711
|
||||
%define gitdate 20140806
|
||||
#% define snapshot
|
||||
|
||||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 10.2.3
|
||||
Version: 10.2.5
|
||||
Release: 1.%{gitdate}%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
|
@ -75,10 +75,6 @@ Patch12: mesa-8.0.1-fix-16bpp.patch
|
|||
Patch15: mesa-9.2-hardware-float.patch
|
||||
Patch20: mesa-10.2-evergreen-big-endian.patch
|
||||
|
||||
# http://lists.freedesktop.org/archives/mesa-dev/2014-July/062741.html
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1115323
|
||||
Patch31: 0001-i915-Fix-up-intelInitScreen2-for-DRI3.patch
|
||||
|
||||
# https://bugs.freedesktop.org/show_bug.cgi?id=73512
|
||||
Patch99: 0001-opencl-use-versioned-.so-in-mesa.icd.patch
|
||||
|
||||
|
@ -345,8 +341,6 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
|
|||
%patch15 -p1 -b .hwfloat
|
||||
%patch20 -p1 -b .egbe
|
||||
|
||||
%patch31 -p1 -b .dri3fix
|
||||
|
||||
%if 0%{?with_opencl}
|
||||
%patch99 -p1 -b .icd
|
||||
%endif
|
||||
|
@ -674,6 +668,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Aug 06 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.2.5-1.20140806
|
||||
- 10.2.5 upstream release (RHBZ #1126223)
|
||||
|
||||
* Fri Jul 11 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.2.3-1.20140711
|
||||
- 10.2.3 upstream release
|
||||
|
||||
|
|
2
sources
2
sources
|
@ -1 +1 @@
|
|||
74c4f5f50aca7006cd537f99c085ab1b mesa-20140711.tar.xz
|
||||
f03f73cc5541088276a6a63d0f48be10 mesa-20140806.tar.xz
|
||||
|
|
Loading…
Reference in a new issue