mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-24 17:35:18 +00:00
Add brw_meta_fast_clear crash workaround patch (#1259443, fdo#86281)
This commit is contained in:
parent
4c06ba3951
commit
bc39dedda6
2 changed files with 40 additions and 1 deletions
30
i965_Remove_early_release_of_DRI2_miptree.patch
Normal file
30
i965_Remove_early_release_of_DRI2_miptree.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
From e2a696a4cd93c2dbe445243de48ed478fbdb8009 Mon Sep 17 00:00:00 2001
|
||||
From: Chris Wilson <chris@chris-wilson.co.uk>
|
||||
Date: Fri, 10 Jul 2015 10:41:35 +0100
|
||||
Subject: i965: Remove early release of DRI2 miptree
|
||||
|
||||
intel_update_winsys_renderbuffer_miptree() will release the existing
|
||||
miptree when wrapping a new DRI2 buffer, so we can remove the early
|
||||
release and so prevent a NULL mt dereference should importing the new
|
||||
DRI2 name fail for any reason. (Reusing the old DRI2 name will result
|
||||
in the rendering going astray, to a stale buffer, and not shown on the
|
||||
screen, but it allows us to issue a warning and not crash much later in
|
||||
innocent code.)
|
||||
|
||||
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
|
||||
|
||||
diff --git a/src/mesa/drivers/dri/i965/brw_context.c b/src/mesa/drivers/dri/i965/brw_context.c
|
||||
index e8d1396..72f3897 100644
|
||||
--- a/src/mesa/drivers/dri/i965/brw_context.c
|
||||
+++ b/src/mesa/drivers/dri/i965/brw_context.c
|
||||
@@ -1388,7 +1388,6 @@ intel_process_dri2_buffer(struct brw_context *brw,
|
||||
buffer->cpp, buffer->pitch);
|
||||
}
|
||||
|
||||
- intel_miptree_release(&rb->mt);
|
||||
bo = drm_intel_bo_gem_create_from_name(brw->bufmgr, buffer_name,
|
||||
buffer->name);
|
||||
if (!bo) {
|
||||
--
|
||||
cgit v0.10.2
|
||||
|
11
mesa.spec
11
mesa.spec
|
@ -55,7 +55,7 @@
|
|||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 11.0.0
|
||||
Release: 0.rc2.1.%{git}%{?dist}
|
||||
Release: 0.rc2.2.%{git}%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
|
@ -70,6 +70,11 @@ Source3: vl_mpeg12_decoder.c
|
|||
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
|
||||
Source4: Mesa-MLAA-License-Clarification-Email.txt
|
||||
|
||||
# upstream workaround for recent intel crasher regression
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1259443
|
||||
# http://bugs.freedesktop.org/show_bug.cgi?id=86281
|
||||
Patch1: i965_Remove_early_release_of_DRI2_miptree.patch
|
||||
|
||||
Patch15: mesa-9.2-hardware-float.patch
|
||||
Patch20: mesa-10.2-evergreen-big-endian.patch
|
||||
Patch30: mesa-10.3-bigendian-assert.patch
|
||||
|
@ -344,6 +349,7 @@ Mesa Direct3D9 state tracker development package
|
|||
%setup -q -n mesa-%{git}
|
||||
grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
|
||||
|
||||
%patch1 -p1 -b .i965_Remove_early_release_of_DRI2_miptree
|
||||
%patch15 -p1 -b .hwfloat
|
||||
%patch20 -p1 -b .egbe
|
||||
%patch30 -p1 -b .beassert
|
||||
|
@ -675,6 +681,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Sep 10 2015 Rex Dieter <rdieter@fedoraproject.org> 11.0.0-0.rc2.2.20150902
|
||||
- - Add brw_meta_fast_clear crash workaround patch (#1259443, fdo#86281)
|
||||
|
||||
* Wed Sep 02 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 11.0.0-0.rc2.1.20150902
|
||||
- 11.0.0-rc2
|
||||
|
||||
|
|
Loading…
Reference in a new issue