mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-12-01 12:10:53 +00:00
- fix googleearth on Intel 965 (#443930)
- disable classic warning to avoid people reporting it.
This commit is contained in:
parent
869d45b951
commit
75c2c8ea2b
3 changed files with 61 additions and 1 deletions
14
mesa-7.1-disable-intel-classic-warn.patch
Normal file
14
mesa-7.1-disable-intel-classic-warn.patch
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
diff -up mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c.nowarn mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c
|
||||||
|
--- mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c.nowarn 2008-05-07 10:11:10.000000000 +1000
|
||||||
|
+++ mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c 2008-05-07 10:11:21.000000000 +1000
|
||||||
|
@@ -479,8 +479,8 @@ intel_init_bufmgr(struct intel_context *
|
||||||
|
if (ttm_disable) {
|
||||||
|
fprintf(stderr, "TTM buffer manager disabled. Using classic.\n");
|
||||||
|
} else {
|
||||||
|
- fprintf(stderr, "Failed to initialize TTM buffer manager. "
|
||||||
|
- "Falling back to classic.\n");
|
||||||
|
+ //fprintf(stderr, "Failed to initialize TTM buffer manager. "
|
||||||
|
+ // "Falling back to classic.\n");
|
||||||
|
}
|
||||||
|
|
||||||
|
if (intelScreen->tex.size == 0) {
|
38
mesa-7.1-fix-965-googleearth.patch
Normal file
38
mesa-7.1-fix-965-googleearth.patch
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
commit 17adf04e5c1da72a51815f3fdb9de2f3a8149c1a
|
||||||
|
Author: Dave Airlie <airlied@panoply-rh.(none)>
|
||||||
|
Date: Tue May 6 18:52:47 2008 +1000
|
||||||
|
|
||||||
|
i965: fix googleearth in classic mode.
|
||||||
|
|
||||||
|
In classic mode googleearth triggered a case where vbos weren't getting accounted properly.
|
||||||
|
|
||||||
|
diff --git a/src/mesa/drivers/dri/i965/brw_draw_upload.c b/src/mesa/drivers/dri/i965/brw_draw_upload.c
|
||||||
|
index aa985d6..2d99238 100644
|
||||||
|
--- a/src/mesa/drivers/dri/i965/brw_draw_upload.c
|
||||||
|
+++ b/src/mesa/drivers/dri/i965/brw_draw_upload.c
|
||||||
|
@@ -404,6 +404,7 @@ int brw_prepare_vertices( struct brw_context *brw,
|
||||||
|
*/
|
||||||
|
copy_array_to_vbo_array(brw, upload[0], interleave);
|
||||||
|
|
||||||
|
+ ret |= dri_bufmgr_check_aperture_space(upload[0]->bo);
|
||||||
|
for (i = 1; i < nr_uploads; i++) {
|
||||||
|
/* Then, just point upload[i] at upload[0]'s buffer. */
|
||||||
|
upload[i]->stride = interleave;
|
||||||
|
@@ -416,13 +417,13 @@ int brw_prepare_vertices( struct brw_context *brw,
|
||||||
|
else {
|
||||||
|
/* Upload non-interleaved arrays */
|
||||||
|
for (i = 0; i < nr_uploads; i++) {
|
||||||
|
- copy_array_to_vbo_array(brw, upload[i], upload[i]->element_size);
|
||||||
|
+ copy_array_to_vbo_array(brw, upload[i], upload[i]->element_size);
|
||||||
|
+ if (upload[i]->bo) {
|
||||||
|
+ ret |= dri_bufmgr_check_aperture_space(upload[i]->bo);
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (brw->vb.upload.bo) {
|
||||||
|
- ret |= dri_bufmgr_check_aperture_space(brw->vb.upload.bo);
|
||||||
|
- }
|
||||||
|
|
||||||
|
if (ret)
|
||||||
|
return 1;
|
10
mesa.spec
10
mesa.spec
|
@ -15,7 +15,7 @@
|
||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Version: 7.1
|
Version: 7.1
|
||||||
Release: 0.29%{?dist}
|
Release: 0.30%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
|
@ -39,6 +39,8 @@ Patch7: mesa-7.1-link-shared.patch
|
||||||
Patch8: mesa-7.1-sparc.patch
|
Patch8: mesa-7.1-sparc.patch
|
||||||
|
|
||||||
Patch10: mesa-7.1-f9-intel-and-radeon-fixes.patch
|
Patch10: mesa-7.1-f9-intel-and-radeon-fixes.patch
|
||||||
|
Patch11: mesa-7.1-fix-965-googleearth.patch
|
||||||
|
Patch12: mesa-7.1-disable-intel-classic-warn.patch
|
||||||
|
|
||||||
BuildRequires: pkgconfig autoconf automake
|
BuildRequires: pkgconfig autoconf automake
|
||||||
%if %{with_dri}
|
%if %{with_dri}
|
||||||
|
@ -168,6 +170,8 @@ This package provides some demo applications for testing Mesa.
|
||||||
%patch7 -p1 -b .dricore
|
%patch7 -p1 -b .dricore
|
||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
%patch10 -p1 -b .misc-fixes
|
%patch10 -p1 -b .misc-fixes
|
||||||
|
%patch11 -p1 -b .965-googleearth
|
||||||
|
%patch12 -p1 -b .intel-nowarn
|
||||||
|
|
||||||
# WARNING: The following files are copyright "Mark J. Kilgard" under the GLUT
|
# WARNING: The following files are copyright "Mark J. Kilgard" under the GLUT
|
||||||
# license and are not open source/free software, so we remove them.
|
# license and are not open source/free software, so we remove them.
|
||||||
|
@ -416,6 +420,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||||
%{_libdir}/mesa-demos-data
|
%{_libdir}/mesa-demos-data
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 07 2008 Dave Airlie <airlied@redhat.com> 7.1-0.30
|
||||||
|
- fix googleearth on Intel 965 (#443930)
|
||||||
|
- disable classic warning to avoid people reporting it.
|
||||||
|
|
||||||
* Mon May 05 2008 Dave Airlie <airlied@redhat.com> 7.1-0.29
|
* Mon May 05 2008 Dave Airlie <airlied@redhat.com> 7.1-0.29
|
||||||
- mesa-7.1-f9-intel-and-radeon-fixes.patch - Update mesa
|
- mesa-7.1-f9-intel-and-radeon-fixes.patch - Update mesa
|
||||||
package with cherrypicked fixes from master.
|
package with cherrypicked fixes from master.
|
||||||
|
|
Loading…
Reference in a new issue