mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-24 09:32:42 +00:00
Update to 21.0.0
This commit is contained in:
parent
de16407125
commit
7555c8cfbe
5 changed files with 6 additions and 111 deletions
|
@ -1,33 +0,0 @@
|
|||
From d2dfc356e26e607bf0808e1b5a747cc1a2699681 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Mon, 22 Feb 2021 15:57:01 +1000
|
||||
Subject: [PATCH] glx: proposed fix for setSwapInterval
|
||||
|
||||
When mesa gets a DRI2 1.1 connection (as experienced with
|
||||
vmwware DDX) we don't get a pointer for this.
|
||||
|
||||
Don't explode just keep going.
|
||||
|
||||
Fixes: 60ebeb4608a8 ("glx: Implement GLX_EXT_swap_control for DRI2 and DRI3")
|
||||
---
|
||||
src/glx/glxcmds.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/glx/glxcmds.c b/src/glx/glxcmds.c
|
||||
index 7882d606554..5d5d77d4f3d 100644
|
||||
--- a/src/glx/glxcmds.c
|
||||
+++ b/src/glx/glxcmds.c
|
||||
@@ -1863,8 +1863,8 @@ glXSwapIntervalEXT(Display *dpy, GLXDrawable drawable, int interval)
|
||||
__glXSendError(dpy, BadValue, interval, 0, True);
|
||||
return;
|
||||
}
|
||||
-
|
||||
- pdraw->psc->driScreen->setSwapInterval(pdraw, interval);
|
||||
+ if (pdraw->psc->driScreen->setSwapInterval)
|
||||
+ pdraw->psc->driScreen->setSwapInterval(pdraw, interval);
|
||||
#endif
|
||||
}
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
|
@ -1,38 +0,0 @@
|
|||
From a84c8ddb19beef7580d6a4b8c417bb188517412a Mon Sep 17 00:00:00 2001
|
||||
From: Karol Herbst <kherbst@redhat.com>
|
||||
Date: Thu, 4 Mar 2021 20:32:10 +0100
|
||||
Subject: [PATCH 1/2] tegra/context: fix regression in tegra_draw_vbo
|
||||
|
||||
We should only pass in a new indirect_info object if we actually set valid
|
||||
values in it.
|
||||
|
||||
Fixes: abe8ef862fe5 "gallium: make pipe_draw_indirect_info * a draw_vbo parameter"
|
||||
Signed-off-by: Karol Herbst <kherbst@redhat.com>
|
||||
Reviewed-by: Ilia Mirkin <imirkin@alum.mit.edu>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/9425>
|
||||
---
|
||||
src/gallium/drivers/tegra/tegra_context.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/gallium/drivers/tegra/tegra_context.c b/src/gallium/drivers/tegra/tegra_context.c
|
||||
index 1d976267aee..97b45ed1627 100644
|
||||
--- a/src/gallium/drivers/tegra/tegra_context.c
|
||||
+++ b/src/gallium/drivers/tegra/tegra_context.c
|
||||
@@ -75,13 +75,13 @@ tegra_draw_vbo(struct pipe_context *pcontext,
|
||||
if (pindirect && pindirect->buffer) {
|
||||
memcpy(&indirect, pindirect, sizeof(indirect));
|
||||
indirect.buffer = tegra_resource_unwrap(pindirect->buffer);
|
||||
+ pindirect = &indirect;
|
||||
}
|
||||
|
||||
if (pinfo->index_size && !pinfo->has_user_indices)
|
||||
info.index.resource = tegra_resource_unwrap(info.index.resource);
|
||||
|
||||
pinfo = &info;
|
||||
- pindirect = &indirect;
|
||||
}
|
||||
|
||||
context->gpu->draw_vbo(context->gpu, pinfo, pindirect, draws, num_draws);
|
||||
--
|
||||
2.30.1
|
||||
|
|
@ -1,28 +0,0 @@
|
|||
From 12f1e42ed34e9807484bdfbec535bc56950e2338 Mon Sep 17 00:00:00 2001
|
||||
From: Karol Herbst <kherbst@redhat.com>
|
||||
Date: Fri, 5 Mar 2021 10:46:48 +0100
|
||||
Subject: [PATCH 2/2] tegra/context: unwrap indirect_draw_count as well
|
||||
|
||||
Fixes: 22f6624ed318 "gallium: separate indirect stuff from pipe_draw_info - 80 -> 56 bytes"
|
||||
Signed-off-by: Karol Herbst <kherbst@redhat.com>
|
||||
Reviewed-by: Ilia Mirkin <imirkin@alum.mit.edu>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/9425>
|
||||
---
|
||||
src/gallium/drivers/tegra/tegra_context.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/gallium/drivers/tegra/tegra_context.c b/src/gallium/drivers/tegra/tegra_context.c
|
||||
index 97b45ed1627..10b04f969ad 100644
|
||||
--- a/src/gallium/drivers/tegra/tegra_context.c
|
||||
+++ b/src/gallium/drivers/tegra/tegra_context.c
|
||||
@@ -75,6 +75,7 @@ tegra_draw_vbo(struct pipe_context *pcontext,
|
||||
if (pindirect && pindirect->buffer) {
|
||||
memcpy(&indirect, pindirect, sizeof(indirect));
|
||||
indirect.buffer = tegra_resource_unwrap(pindirect->buffer);
|
||||
+ indirect.indirect_draw_count = tegra_resource_unwrap(pindirect->indirect_draw_count);
|
||||
pindirect = &indirect;
|
||||
}
|
||||
|
||||
--
|
||||
2.30.1
|
||||
|
16
mesa.spec
16
mesa.spec
|
@ -50,9 +50,9 @@
|
|||
|
||||
Name: mesa
|
||||
Summary: Mesa graphics libraries
|
||||
%global ver 21.0.0-rc5
|
||||
%global ver 21.0.0
|
||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
URL: http://www.mesa3d.org
|
||||
|
||||
|
@ -62,15 +62,6 @@ Source0: https://mesa.freedesktop.org/archive/%{name}-%{ver}.tar.xz
|
|||
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
|
||||
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
||||
|
||||
# fix glx regression with sddm
|
||||
Patch1: 0001-glx-proposed-fix-for-setSwapInterval.patch
|
||||
|
||||
# fix GNOME crash on Jetson Nano:
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1930977
|
||||
# https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/9425
|
||||
Patch2: 0001-tegra-context-fix-regression-in-tegra_draw_vbo.patch
|
||||
Patch3: 0002-tegra-context-unwrap-indirect_draw_count-as-well.patch
|
||||
|
||||
BuildRequires: meson >= 0.45
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
|
@ -604,6 +595,9 @@ popd
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Mar 12 2021 Pete Walter <pwalter@fedoraproject.org> - 21.0.0-1
|
||||
- Update to 21.0.0
|
||||
|
||||
* Mon Mar 08 2021 Adam Williamson <awilliam@redhat.com> - 21.0.0~rc5-3
|
||||
- Backport MR #9425 to fix GNOME Shell crash on Jetson Nano (#1930977)
|
||||
|
||||
|
|
2
sources
2
sources
|
@ -1 +1 @@
|
|||
SHA512 (mesa-21.0.0-rc5.tar.xz) = 89e212a7caf70320841551dbf937fe627e156896e9d11dc6654f91552c97800354562d5297b3a218c8c0f8261d2f32c62cb6e9445bace64f0b41eced829be7ed
|
||||
SHA512 (mesa-21.0.0.tar.xz) = 32f4a74fbc1456dac478fdc3a85e37cedb9ac1e1b7c5434706dc24930a70bc9e857ba6b5bf1e7e05798e259f8ff0b05bad5252c07253cb5d6a9707c7c2e147ad
|
||||
|
|
Loading…
Reference in a new issue