mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-24 17:35:18 +00:00
get latest 8.0.2 set of fixes
This commit is contained in:
parent
4b435c8c6e
commit
6d3385fa54
4 changed files with 63 additions and 6 deletions
1
.gitignore
vendored
1
.gitignore
vendored
|
@ -33,3 +33,4 @@ mesa-20100720.tar.bz2
|
|||
/mesa-20120126.tar.xz
|
||||
/MesaLib-8.0.tar.bz2
|
||||
/MesaLib-8.0.1.tar.bz2
|
||||
/MesaLib-8.0.2.tar.bz2
|
||||
|
|
52
0001-intel-fix-null-dereference-processing-HiZ-buffer.patch
Normal file
52
0001-intel-fix-null-dereference-processing-HiZ-buffer.patch
Normal file
|
@ -0,0 +1,52 @@
|
|||
From 89e796aef5ca1b35ca4ff6fce9231b4125e07037 Mon Sep 17 00:00:00 2001
|
||||
From: Dylan Noblesmith <nobled@dreamwidth.org>
|
||||
Date: Fri, 16 Mar 2012 18:38:49 +0000
|
||||
Subject: [PATCH] intel: fix null dereference processing HiZ buffer
|
||||
|
||||
Or technically, a near-null dereference.
|
||||
|
||||
https://bugs.freedesktop.org/show_bug.cgi?id=46303
|
||||
https://bugs.freedesktop.org/show_bug.cgi?id=46739
|
||||
|
||||
NOTE: This is a candidate for the 8.0 branch.
|
||||
|
||||
Reviewed-by: Chad Versace <chad.versace@linux.intel.com>
|
||||
(cherry picked from commit 8d9decb75f0df564abaf9888d9fc5c77de8059cd)
|
||||
---
|
||||
src/mesa/drivers/dri/intel/intel_context.c | 6 ++++++
|
||||
1 files changed, 6 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/src/mesa/drivers/dri/intel/intel_context.c b/src/mesa/drivers/dri/intel/intel_context.c
|
||||
index d3c0d70..9cdd804 100644
|
||||
--- a/src/mesa/drivers/dri/intel/intel_context.c
|
||||
+++ b/src/mesa/drivers/dri/intel/intel_context.c
|
||||
@@ -1225,6 +1225,10 @@ intel_process_dri2_buffer_with_separate_stencil(struct intel_context *intel,
|
||||
if (!rb)
|
||||
return;
|
||||
|
||||
+ /* Check if we failed to allocate the depth miptree earlier. */
|
||||
+ if (buffer->attachment == __DRI_BUFFER_HIZ && rb->mt == NULL)
|
||||
+ return;
|
||||
+
|
||||
/* If the renderbuffer's and DRIbuffer's regions match, then continue. */
|
||||
if ((buffer->attachment != __DRI_BUFFER_HIZ &&
|
||||
rb->mt &&
|
||||
@@ -1266,6 +1270,7 @@ intel_process_dri2_buffer_with_separate_stencil(struct intel_context *intel,
|
||||
* due to failure to allocate new storage.
|
||||
*/
|
||||
if (buffer->attachment == __DRI_BUFFER_HIZ) {
|
||||
+ assert(rb->mt);
|
||||
intel_miptree_release(&rb->mt->hiz_mt);
|
||||
} else {
|
||||
intel_miptree_release(&rb->mt);
|
||||
@@ -1291,6 +1296,7 @@ intel_process_dri2_buffer_with_separate_stencil(struct intel_context *intel,
|
||||
|
||||
/* Associate buffer with new storage. */
|
||||
if (buffer->attachment == __DRI_BUFFER_HIZ) {
|
||||
+ assert(rb->mt);
|
||||
rb->mt->hiz_mt = mt;
|
||||
} else {
|
||||
rb->mt = mt;
|
||||
--
|
||||
1.7.7.6
|
||||
|
14
mesa.spec
14
mesa.spec
|
@ -29,8 +29,8 @@
|
|||
|
||||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 8.0.1
|
||||
Release: 9%{?dist}
|
||||
Version: 8.0.2
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
|
@ -45,9 +45,10 @@ Source3: make-git-snapshot.sh
|
|||
#Patch7: mesa-7.1-link-shared.patch
|
||||
Patch8: mesa-7.10-llvmcore.patch
|
||||
Patch9: mesa-8.0-llvmpipe-shmget.patch
|
||||
Patch10: mesa-8.0.1-git.patch
|
||||
Patch10: 0001-intel-fix-null-dereference-processing-HiZ-buffer.patch
|
||||
Patch11: mesa-8.0-nouveau-tfp-blacklist.patch
|
||||
|
||||
|
||||
BuildRequires: pkgconfig autoconf automake libtool
|
||||
%if %{with_hardware}
|
||||
BuildRequires: kernel-headers
|
||||
|
@ -269,12 +270,12 @@ Requires(postun): /sbin/ldconfig
|
|||
Mesa shared glapi
|
||||
|
||||
%prep
|
||||
%setup -q -n Mesa-%{version}%{?snapshot} -b0 -b2
|
||||
%setup -q -n Mesa-%{version}%{?snapshot} -b2
|
||||
#setup -q -n mesa-%{gitdate} -b2
|
||||
#patch7 -p1 -b .dricore
|
||||
%patch8 -p1 -b .llvmcore
|
||||
%patch9 -p1 -b .shmget
|
||||
%patch10 -p1 -b .git
|
||||
%patch10 -p1 -b .intel-hiz-fix
|
||||
%patch11 -p1 -b .nouveau
|
||||
|
||||
%build
|
||||
|
@ -551,6 +552,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Mar 31 2012 Dave Airlie <airlied@redhat.com> 8.0.2-1
|
||||
- get latest 8.0.2 set of fixes
|
||||
|
||||
* Wed Mar 28 2012 Adam Jackson <ajax@redhat.com> 8.0.1-9
|
||||
- Subpackage libglapi instead of abusing -dri-drivers for it to keep minimal
|
||||
disk space minimal. (#807750)
|
||||
|
|
2
sources
2
sources
|
@ -1,2 +1,2 @@
|
|||
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
||||
24eeebf66971809d8f40775a379b36c9 MesaLib-8.0.1.tar.bz2
|
||||
a368104e5700707048dc3e8691a9a7a1 MesaLib-8.0.2.tar.bz2
|
||||
|
|
Loading…
Reference in a new issue