mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-30 19:58:19 +00:00
snapshot mesa: add some build hackarounds
This commit is contained in:
parent
5384165a1f
commit
59f011598d
4 changed files with 27 additions and 6 deletions
1
.gitignore
vendored
1
.gitignore
vendored
|
@ -36,3 +36,4 @@ mesa-20100720.tar.bz2
|
||||||
/MesaLib-8.0.2.tar.bz2
|
/MesaLib-8.0.2.tar.bz2
|
||||||
/mesa-20120424.tar.xz
|
/mesa-20120424.tar.xz
|
||||||
/mesa-20120603.tar.xz
|
/mesa-20120603.tar.xz
|
||||||
|
/mesa-20120716.tar.xz
|
||||||
|
|
14
mesa-8.1-fixglpc.patch
Normal file
14
mesa-8.1-fixglpc.patch
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
diff -up mesa-20120716/src/mesa/Makefile.am.dave mesa-20120716/src/mesa/Makefile.am
|
||||||
|
--- mesa-20120716/src/mesa/Makefile.am.dave 2012-07-17 02:16:46.923268668 -0400
|
||||||
|
+++ mesa-20120716/src/mesa/Makefile.am 2012-07-17 02:17:09.106991335 -0400
|
||||||
|
@@ -144,8 +144,7 @@ CLEANFILES += libmesa.a libmesagallium.a
|
||||||
|
|
||||||
|
pkgconfigdir = $(libdir)/pkgconfig
|
||||||
|
|
||||||
|
-if HAVE_OSMESA_DRIVER
|
||||||
|
-pkgconfig_DATA = osmesa.pc
|
||||||
|
-else
|
||||||
|
pkgconfig_DATA = gl.pc
|
||||||
|
+if HAVE_OSMESA_DRIVER
|
||||||
|
+pkgconfig_DATA += osmesa.pc
|
||||||
|
endif
|
16
mesa.spec
16
mesa.spec
|
@ -30,13 +30,13 @@
|
||||||
%define _default_patch_fuzz 2
|
%define _default_patch_fuzz 2
|
||||||
|
|
||||||
%define manpages gl-manpages-1.0.1
|
%define manpages gl-manpages-1.0.1
|
||||||
%define gitdate 20120603
|
%define gitdate 20120716
|
||||||
#% define snapshot
|
#% define snapshot
|
||||||
|
|
||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Version: 8.1
|
Version: 8.1
|
||||||
Release: 0.9%{?dist}
|
Release: 0.10%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
|
@ -52,13 +52,14 @@ Source3: make-git-snapshot.sh
|
||||||
Patch9: mesa-8.0-llvmpipe-shmget.patch
|
Patch9: mesa-8.0-llvmpipe-shmget.patch
|
||||||
Patch11: mesa-8.0-nouveau-tfp-blacklist.patch
|
Patch11: mesa-8.0-nouveau-tfp-blacklist.patch
|
||||||
Patch12: mesa-8.0.1-fix-16bpp.patch
|
Patch12: mesa-8.0.1-fix-16bpp.patch
|
||||||
|
Patch13: mesa-8.1-fixglpc.patch
|
||||||
|
|
||||||
BuildRequires: pkgconfig autoconf automake libtool
|
BuildRequires: pkgconfig autoconf automake libtool
|
||||||
%if %{with_hardware}
|
%if %{with_hardware}
|
||||||
BuildRequires: kernel-headers
|
BuildRequires: kernel-headers
|
||||||
BuildRequires: xorg-x11-server-devel
|
BuildRequires: xorg-x11-server-devel
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: libdrm-devel >= 2.4.27-1
|
BuildRequires: libdrm-devel >= 2.4.37
|
||||||
BuildRequires: libXxf86vm-devel
|
BuildRequires: libXxf86vm-devel
|
||||||
BuildRequires: expat-devel
|
BuildRequires: expat-devel
|
||||||
BuildRequires: xorg-x11-proto-devel
|
BuildRequires: xorg-x11-proto-devel
|
||||||
|
@ -274,6 +275,7 @@ Mesa shared glapi
|
||||||
%patch9 -p1 -b .shmget
|
%patch9 -p1 -b .shmget
|
||||||
%patch11 -p1 -b .nouveau
|
%patch11 -p1 -b .nouveau
|
||||||
%patch12 -p1 -b .16bpp
|
%patch12 -p1 -b .16bpp
|
||||||
|
%patch13 -p1 -b .fixglpc
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
|
@ -315,6 +317,8 @@ export CXXFLAGS="$RPM_OPT_FLAGS"
|
||||||
%endif
|
%endif
|
||||||
%{?dri_drivers}
|
%{?dri_drivers}
|
||||||
|
|
||||||
|
#ignore the man behind the curtain. - temp workaround mesa build bug
|
||||||
|
cd src/egl/wayland; make; cd -
|
||||||
make %{?_smp_mflags} MKDEP=/bin/true
|
make %{?_smp_mflags} MKDEP=/bin/true
|
||||||
|
|
||||||
pushd ../%{manpages}
|
pushd ../%{manpages}
|
||||||
|
@ -437,8 +441,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||||
%{_libdir}/dri/vmwgfx_dri.so
|
%{_libdir}/dri/vmwgfx_dri.so
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
%{_libdir}/dri/libdricore.so
|
%{_libdir}/libdricore*.so*
|
||||||
%{_libdir}/dri/libglsl.so
|
|
||||||
%{_libdir}/dri/swrast_dri.so
|
%{_libdir}/dri/swrast_dri.so
|
||||||
|
|
||||||
%files -n khrplatform-devel
|
%files -n khrplatform-devel
|
||||||
|
@ -561,6 +564,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 17 2012 Dave Airlie <airlied@redhat.com> 8.1-0.10
|
||||||
|
- snapshot mesa: add some build hackarounds
|
||||||
|
|
||||||
* Sat Jul 14 2012 Ville Skyttä <ville.skytta@iki.fi> - 8.1-0.9
|
* Sat Jul 14 2012 Ville Skyttä <ville.skytta@iki.fi> - 8.1-0.9
|
||||||
- Call ldconfig at -libglapi and -libxatracker post(un)install time.
|
- Call ldconfig at -libglapi and -libxatracker post(un)install time.
|
||||||
- Drop redundant ldconfig dependencies, let rpm auto-add them.
|
- Drop redundant ldconfig dependencies, let rpm auto-add them.
|
||||||
|
|
2
sources
2
sources
|
@ -1,2 +1,2 @@
|
||||||
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
||||||
fa6ccc097cd8b60715b23c3614a98c69 mesa-20120603.tar.xz
|
2c0d41631e7e12adbbe17246cd25b3a3 mesa-20120716.tar.xz
|
||||||
|
|
Loading…
Reference in a new issue