mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-28 11:06:25 +00:00
Update to 19.0.6
This commit is contained in:
parent
3ea3041de6
commit
4bc185a554
3 changed files with 6 additions and 42 deletions
|
@ -1,36 +0,0 @@
|
||||||
From 7fe5a8e874b2cae2b1ada3f6aab8ca6766753b1e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Dave Airlie <airlied@redhat.com>
|
|
||||||
Date: Mon, 27 May 2019 09:36:28 +1000
|
|
||||||
Subject: [PATCH] Revert "mesa: unreference current winsys buffers when
|
|
||||||
unbinding winsys buffers"
|
|
||||||
|
|
||||||
This reverts commit 12bf7cfecf52083c484602f971738475edfe497e.
|
|
||||||
|
|
||||||
This commits caused lots of problems:
|
|
||||||
https://bugs.freedesktop.org/show_bug.cgi?id=110721
|
|
||||||
https://bugs.freedesktop.org/show_bug.cgi?id=110761
|
|
||||||
|
|
||||||
Fixes: 12bf7cfecf52 ("mesa: unreference current winsys buffers when unbinding winsys buffers")
|
|
||||||
Pushing without review as we need to get it into next stable.
|
|
||||||
---
|
|
||||||
src/mesa/main/context.c | 4 ----
|
|
||||||
1 file changed, 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/mesa/main/context.c b/src/mesa/main/context.c
|
|
||||||
index 04ef4d500d8..34da16b88f4 100644
|
|
||||||
--- a/src/mesa/main/context.c
|
|
||||||
+++ b/src/mesa/main/context.c
|
|
||||||
@@ -1765,10 +1765,6 @@ _mesa_make_current( struct gl_context *newCtx,
|
|
||||||
|
|
||||||
check_init_viewport(newCtx, drawBuffer->Width, drawBuffer->Height);
|
|
||||||
}
|
|
||||||
- else {
|
|
||||||
- _mesa_reference_framebuffer(&newCtx->WinSysDrawBuffer, NULL);
|
|
||||||
- _mesa_reference_framebuffer(&newCtx->WinSysReadBuffer, NULL);
|
|
||||||
- }
|
|
||||||
|
|
||||||
if (newCtx->FirstTimeCurrent) {
|
|
||||||
handle_first_current(newCtx);
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
10
mesa.spec
10
mesa.spec
|
@ -46,9 +46,9 @@
|
||||||
|
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
%global ver 19.0.5
|
%global ver 19.0.6
|
||||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
|
|
||||||
|
@ -58,9 +58,6 @@ Source0: https://mesa.freedesktop.org/archive/%{name}-%{ver}.tar.xz
|
||||||
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
|
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
|
||||||
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
||||||
|
|
||||||
# Local revert for 19.0.5 issue
|
|
||||||
Patch0: 0001-Revert-mesa-unreference-current-winsys-buffers-when-.patch
|
|
||||||
|
|
||||||
Patch3: 0003-evergreen-big-endian.patch
|
Patch3: 0003-evergreen-big-endian.patch
|
||||||
|
|
||||||
# Disable rgb10 configs by default:
|
# Disable rgb10 configs by default:
|
||||||
|
@ -616,6 +613,9 @@ popd
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 07 2019 Pete Walter <pwalter@fedoraproject.org> - 19.0.6-1
|
||||||
|
- Update to 19.0.6
|
||||||
|
|
||||||
* Mon May 27 2019 Dave Airlie <airlied@redhat.com> - 19.0.5-2
|
* Mon May 27 2019 Dave Airlie <airlied@redhat.com> - 19.0.5-2
|
||||||
- Revert broken patch in 19.0.5
|
- Revert broken patch in 19.0.5
|
||||||
|
|
||||||
|
|
2
sources
2
sources
|
@ -1 +1 @@
|
||||||
SHA512 (mesa-19.0.5.tar.xz) = aecd5ee54ac0316d5e318dbea0abdc06f23e67d75d36eb82d6cf6a396c9e850e1ccf4fa8815f8c4097b6039ebb1524673189350cbfd4b766ce75ce17c26d9d8d
|
SHA512 (mesa-19.0.6.tar.xz) = 320fd6b12ccd5e4a40dfc93546354848a38da09d90e4d5a1dae5d100b8106942acfc25ac3f705a2d3ab3b355162c74c7dfadbdb99a46cf2e5e0761f8542bfeb1
|
||||||
|
|
Loading…
Reference in a new issue