mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-24 09:32:42 +00:00
Update to 23.0.0-rc4
This commit is contained in:
parent
d3875a0cf7
commit
4a6a053618
4 changed files with 3 additions and 143 deletions
35
20933.patch
35
20933.patch
|
@ -1,35 +0,0 @@
|
|||
From dd3730f8bdd7afdbc7fb0e9dd200951f9d713a34 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Corentin=20No=C3=ABl?= <corentin.noel@collabora.com>
|
||||
Date: Thu, 26 Jan 2023 13:25:57 +0100
|
||||
Subject: [PATCH] kopper: Do not free the given screen in initScreen
|
||||
implementation
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
The given screen is already freed by the caller in case a NULL-pointer is
|
||||
returned by the implementation.
|
||||
|
||||
Cc: mesa-stable
|
||||
Signed-off-by: Corentin Noël <corentin.noel@collabora.com>
|
||||
Reviewed-By: Mike Blumenkrantz <michael.blumenkrantz@gmail.com>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20933>
|
||||
---
|
||||
src/gallium/frontends/dri/kopper.c | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/src/gallium/frontends/dri/kopper.c b/src/gallium/frontends/dri/kopper.c
|
||||
index 8453585b8471..9e8056975150 100644
|
||||
--- a/src/gallium/frontends/dri/kopper.c
|
||||
+++ b/src/gallium/frontends/dri/kopper.c
|
||||
@@ -171,7 +171,6 @@ fail:
|
||||
dri_destroy_screen_helper(screen);
|
||||
if (screen->dev)
|
||||
pipe_loader_release(&screen->dev, 1);
|
||||
- FREE(screen);
|
||||
return NULL;
|
||||
}
|
||||
|
||||
--
|
||||
GitLab
|
||||
|
|
@ -1,99 +0,0 @@
|
|||
From 47bba327f44a801d41b9f52c900d75eb03dcb9f6 Mon Sep 17 00:00:00 2001
|
||||
From: Karol Herbst <kherbst@redhat.com>
|
||||
Date: Wed, 16 Nov 2022 11:50:51 +0100
|
||||
Subject: [PATCH] rusticl: fix build error with valgrind being enabled
|
||||
|
||||
This bumps the meson requierement to 1.0 because it requires
|
||||
https://github.com/mesonbuild/meson/pull/11024
|
||||
|
||||
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/7688
|
||||
Fixes: 20c90fed5a0 ("rusticl: added")
|
||||
Signed-off-by: Karol Herbst <kherbst@redhat.com>
|
||||
---
|
||||
.gitlab-ci/container/debian/x86_build-base.sh | 4 ++--
|
||||
.gitlab-ci/image-tags.yml | 2 +-
|
||||
docs/rusticl.rst | 2 +-
|
||||
meson.build | 4 ++--
|
||||
src/gallium/frontends/rusticl/meson.build | 4 ++++
|
||||
5 files changed, 10 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/.gitlab-ci/container/debian/x86_build-base.sh b/.gitlab-ci/container/debian/x86_build-base.sh
|
||||
index 215db4820d15..2332323fe1a6 100644
|
||||
--- a/.gitlab-ci/container/debian/x86_build-base.sh
|
||||
+++ b/.gitlab-ci/container/debian/x86_build-base.sh
|
||||
@@ -78,8 +78,8 @@ apt-get install -y --no-remove \
|
||||
# Needed for ci-fairy, this revision is able to upload files to MinIO
|
||||
pip3 install git+http://gitlab.freedesktop.org/freedesktop/ci-templates@ffe4d1b10aab7534489f0c4bbc4c5899df17d3f2
|
||||
|
||||
-# We need at least 0.61.4 for proper Rust; 0.62 for modern meson env2mfile
|
||||
-pip3 install meson==0.63.3
|
||||
+# We need at least 1.0.0 for proper Rust; 0.62 for modern meson env2mfile
|
||||
+pip3 install meson==1.0.0
|
||||
|
||||
. .gitlab-ci/container/build-rust.sh
|
||||
|
||||
diff --git a/.gitlab-ci/image-tags.yml b/.gitlab-ci/image-tags.yml
|
||||
index 1ecfa6ff23e6..eba9fa486562 100644
|
||||
--- a/.gitlab-ci/image-tags.yml
|
||||
+++ b/.gitlab-ci/image-tags.yml
|
||||
@@ -1,6 +1,6 @@
|
||||
variables:
|
||||
DEBIAN_X86_BUILD_BASE_IMAGE: "debian/x86_build-base"
|
||||
- DEBIAN_BASE_TAG: "2023-01-10-robust-wget"
|
||||
+ DEBIAN_BASE_TAG: "2023-01-25-rust-valgrind"
|
||||
|
||||
DEBIAN_X86_BUILD_IMAGE_PATH: "debian/x86_build"
|
||||
DEBIAN_BUILD_TAG: "2023-01-09-lavacli"
|
||||
diff --git a/docs/rusticl.rst b/docs/rusticl.rst
|
||||
index 45f99bcca3cb..9217fc766af7 100644
|
||||
--- a/docs/rusticl.rst
|
||||
+++ b/docs/rusticl.rst
|
||||
@@ -19,7 +19,7 @@ To build Rusticl you need to satisfy the following build dependencies:
|
||||
The minimum versions to build Rusticl are:
|
||||
|
||||
- Rust: 1.59
|
||||
-- Meson: 0.61.4
|
||||
+- Meson: 1.0.0
|
||||
- Bindgen: 0.58.0
|
||||
- LLVM: 11.0.0 (recommended: 15.0.0)
|
||||
- SPIRV-Tools: any version (recommended: v2022.3)
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 17669575dc2d..8a3a5b7045de 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -784,8 +784,8 @@ if with_gallium_rusticl
|
||||
error('rusticl requires at least one gallium driver.')
|
||||
endif
|
||||
|
||||
- if meson.version().version_compare('< 0.61.4')
|
||||
- error('rusticl requires meson 0.61.4 or newer')
|
||||
+ if meson.version().version_compare('< 1.0.0')
|
||||
+ error('rusticl requires meson 1.0.0 or newer')
|
||||
endif
|
||||
|
||||
add_languages('rust', required: true)
|
||||
diff --git a/src/gallium/frontends/rusticl/meson.build b/src/gallium/frontends/rusticl/meson.build
|
||||
index 5bfa6faf5af3..e53b50a9b8b8 100644
|
||||
--- a/src/gallium/frontends/rusticl/meson.build
|
||||
+++ b/src/gallium/frontends/rusticl/meson.build
|
||||
@@ -195,6 +195,7 @@ rusticl_mesa_bindings_inline_wrapper = static_library(
|
||||
],
|
||||
dependencies: [
|
||||
idep_nir_headers,
|
||||
+ dep_valgrind,
|
||||
],
|
||||
)
|
||||
|
||||
@@ -209,6 +210,9 @@ rusticl_mesa_bindings_rs = rust.bindgen(
|
||||
inc_nir,
|
||||
inc_src,
|
||||
],
|
||||
+ dependencies: [
|
||||
+ dep_valgrind,
|
||||
+ ],
|
||||
c_args : [
|
||||
rusticl_bindgen_c_args,
|
||||
pre_args,
|
||||
--
|
||||
GitLab
|
||||
|
10
mesa.spec
10
mesa.spec
|
@ -53,7 +53,7 @@
|
|||
|
||||
Name: mesa
|
||||
Summary: Mesa graphics libraries
|
||||
%global ver 23.0.0-rc3
|
||||
%global ver 23.0.0-rc4
|
||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||
Release: %autorelease
|
||||
License: MIT
|
||||
|
@ -66,14 +66,8 @@ Source0: https://archive.mesa3d.org/mesa-%{ver}.tar.xz
|
|||
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
||||
|
||||
Patch10: gnome-shell-glthread-disable.patch
|
||||
# https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19778
|
||||
Patch11: mesa-valgrind-build-fix.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2164667
|
||||
# https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20933
|
||||
Patch12: 20933.patch
|
||||
|
||||
BuildRequires: meson >= 0.61.4
|
||||
BuildRequires: meson >= 1.0.0
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gettext
|
||||
|
|
2
sources
2
sources
|
@ -1 +1 @@
|
|||
SHA512 (mesa-23.0.0-rc3.tar.xz) = adad86189ae27eb5cf89d7b6e0626a78f49f5a72cdea0f4eb59d76aae74c657251d07c3142c578e1e13edef73947d4807c25eebf9598b8a0e16a70c584916ce5
|
||||
SHA512 (mesa-23.0.0-rc4.tar.xz) = 463dad021bffd1b6cae8eb540ea0f51da8753e5f5295f5d1ab6398ed6eb140ccef7ba62b458c099cc19a26d6dcb4b620280893425572fae75fe7e880d8e3a403
|
||||
|
|
Loading…
Reference in a new issue