mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-24 17:35:18 +00:00
Revert "Add fix for "Broken X on hybrid graphics due to missing GL_OES_EGL_image OpenGL extension" (RHBZ #1265997)"
This reverts commit 5f03ecaef5
.
This commit is contained in:
parent
5f03ecaef5
commit
457b9d76bd
2 changed files with 1 additions and 22 deletions
|
@ -1,14 +0,0 @@
|
|||
diff --git a/src/mesa/main/extensions.c b/src/mesa/main/extensions.c
|
||||
index 767c50e..b2c88c3 100644
|
||||
--- a/src/mesa/main/extensions.c
|
||||
+++ b/src/mesa/main/extensions.c
|
||||
@@ -307,7 +307,8 @@ static const struct extension extension_table[] = {
|
||||
{ "GL_OES_depth_texture_cube_map", o(OES_depth_texture_cube_map), ES2, 2012 },
|
||||
{ "GL_OES_draw_texture", o(OES_draw_texture), ES1, 2004 },
|
||||
{ "GL_OES_EGL_sync", o(dummy_true), ES1 | ES2, 2010 },
|
||||
- { "GL_OES_EGL_image", o(OES_EGL_image), ES1 | ES2, 2006 },
|
||||
+ /* FIXME: Mesa expects GL_OES_EGL_image to be available in OpenGL contexts. */
|
||||
+ { "GL_OES_EGL_image", o(OES_EGL_image), GL | ES1 | ES2, 2006 },
|
||||
{ "GL_OES_EGL_image_external", o(OES_EGL_image_external), ES1 | ES2, 2010 },
|
||||
{ "GL_OES_element_index_uint", o(dummy_true), ES1 | ES2, 2005 },
|
||||
{ "GL_OES_fbo_render_mipmap", o(dummy_true), ES1 | ES2, 2005 },
|
|
@ -55,7 +55,7 @@
|
|||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 11.0.0
|
||||
Release: 3.%{git}%{?dist}
|
||||
Release: 2.%{git}%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
|
@ -79,8 +79,6 @@ Patch15: mesa-9.2-hardware-float.patch
|
|||
Patch20: mesa-10.2-evergreen-big-endian.patch
|
||||
Patch30: mesa-10.3-bigendian-assert.patch
|
||||
|
||||
Patch99: Mesa-dev-Revert-mesa-extensions-restrict-GL_OES_EGL_image-to-GLES.patch
|
||||
|
||||
# To have sha info in glxinfo
|
||||
BuildRequires: git-core
|
||||
|
||||
|
@ -356,8 +354,6 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
|
|||
%patch20 -p1 -b .egbe
|
||||
%patch30 -p1 -b .beassert
|
||||
|
||||
%patch99 -p1
|
||||
|
||||
%if 0%{with_private_llvm}
|
||||
sed -i 's/llvm-config/mesa-private-llvm-config-%{__isa_bits}/g' configure.ac
|
||||
sed -i 's/`$LLVM_CONFIG --version`/&-mesa/' configure.ac
|
||||
|
@ -685,9 +681,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Sep 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 11.0.0-3.20150913
|
||||
- Add fix for "Broken X on hybrid graphics due to missing GL_OES_EGL_image OpenGL extension" (RHBZ #1265997)
|
||||
|
||||
* Mon Sep 21 2015 Dave Airlie <airlied@redhat.com> 11.0.0-2.20150913
|
||||
- rebuild 11.0.0 against llvm 3.7
|
||||
|
||||
|
|
Loading…
Reference in a new issue