- Fix build on powerpc.

This commit is contained in:
Adam Jackson 2008-02-21 02:05:31 +00:00
parent f7341875f7
commit 3e8621714a
4 changed files with 27 additions and 2 deletions

View file

@ -1,2 +1,3 @@
gl-manpages-1.0.1.tar.bz2 gl-manpages-1.0.1.tar.bz2
mesa-20080215.tar.bz2 mesa-20080215.tar.bz2
mesa-20080218.tar.bz2

View file

@ -0,0 +1,19 @@
diff -up mesa-20080218/configure.ac.jx mesa-20080218/configure.ac
--- mesa-20080218/configure.ac.jx 2008-02-18 12:01:51.000000000 -0500
+++ mesa-20080218/configure.ac 2008-02-20 20:54:55.000000000 -0500
@@ -484,6 +484,7 @@ if test "$mesa_driver" = dri; then
DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 radeon \
savage tdfx unichrome"
fi
+ DRI_DIRS="`echo $DRI_DIRS | sed 's/i810//g'`"
;;
powerpc*)
# Build only the drivers for cards that exist on PowerPC.
@@ -491,6 +492,7 @@ if test "$mesa_driver" = dri; then
if test "x$DRI_DIRS" = x; then
DRI_DIRS="mach64 r128 r200 r300 radeon tdfx"
fi
+ DRI_DIRS="`echo $DRI_DIRS | sed 's/i... //g'`"
;;
esac
;;

View file

@ -15,7 +15,7 @@
Summary: Mesa graphics libraries Summary: Mesa graphics libraries
Name: mesa Name: mesa
Version: 7.1 Version: 7.1
Release: 0.15%{?dist} Release: 0.16%{?dist}
License: MIT License: MIT
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://www.mesa3d.org URL: http://www.mesa3d.org
@ -28,6 +28,7 @@ Source2: %{manpages}.tar.bz2
Source3: make-git-snapshot.sh Source3: make-git-snapshot.sh
Patch0: mesa-7.1pre-osmesa-version.patch Patch0: mesa-7.1pre-osmesa-version.patch
Patch1: mesa-7.1-dri-drivers.patch
BuildRequires: pkgconfig autoconf automake BuildRequires: pkgconfig autoconf automake
@ -298,6 +299,7 @@ rm -rf $RPM_BUILD_ROOT
%{_includedir}/GL/xmesa_xf86.h %{_includedir}/GL/xmesa_xf86.h
%dir %{_includedir}/GL/internal %dir %{_includedir}/GL/internal
%{_includedir}/GL/internal/dri_interface.h %{_includedir}/GL/internal/dri_interface.h
%{_includedir}/GL/internal/dri_sarea.h
%{_libdir}/libGL.so %{_libdir}/libGL.so
%{_libdir}/pkgconfig/gl.pc %{_libdir}/pkgconfig/gl.pc
%{_datadir}/man/man3/gl[^uX]*.3gl* %{_datadir}/man/man3/gl[^uX]*.3gl*
@ -396,6 +398,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/mesa-demos-data %{_libdir}/mesa-demos-data
%changelog %changelog
* Wed Feb 20 2008 Adam Jackson <ajax@redhat.com> 7.1-0.16
- Fix build on powerpc.
* Mon Feb 18 2008 Adam Jackson <ajax@redhat.com> 7.1-0.15 * Mon Feb 18 2008 Adam Jackson <ajax@redhat.com> 7.1-0.15
- Today's git snapshot, additional headers for DRI2 love. - Today's git snapshot, additional headers for DRI2 love.

View file

@ -1,2 +1,2 @@
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2 6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
fd86d11f88e1cb43057e87629ac36ab1 mesa-20080215.tar.bz2 0faf6afeee7f2ef78efeb681690c0c25 mesa-20080218.tar.bz2