mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-12-03 21:00:52 +00:00
drop previous patch (not needed for F20)
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
7878fa197e
commit
2b6cb81b32
2 changed files with 4 additions and 51 deletions
|
@ -1,44 +0,0 @@
|
|||
From 34fa604acfa3d9d66524eacaa239c3251dc3237b Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Wed, 28 May 2014 08:56:12 +0200
|
||||
Subject: [PATCH] i915: add a missing NULL pointer check
|
||||
|
||||
mesaVisual can be NULL with configless context since this commit:
|
||||
|
||||
commit 551d459af421a2eb937e9e16301bb64da4624f89
|
||||
Author: Neil Roberts <neil@linux.intel.com>
|
||||
Date: Fri Mar 7 18:05:47 2014 +0000
|
||||
|
||||
Add the EGL_MESA_configless_context extension
|
||||
...
|
||||
Previously the i965 and i915 drivers were explicitly creating a zeroed visual
|
||||
whenever 0 is passed for the EGLConfig.
|
||||
|
||||
We attempt to dereference the visual in i915 and now we don't create a
|
||||
zeroed-out one one it crashes, breaking at least weston in an i915. There's
|
||||
no point in doing so as it would be zero anyway.
|
||||
|
||||
Signed-off-by: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1100967
|
||||
Cc: "10.2" <mesa-stable@lists.freedesktop.org>
|
||||
Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
|
||||
---
|
||||
src/mesa/drivers/dri/i915/intel_context.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/mesa/drivers/dri/i915/intel_context.c b/src/mesa/drivers/dri/i915/intel_context.c
|
||||
index a6057d3..09fe371 100644
|
||||
--- a/src/mesa/drivers/dri/i915/intel_context.c
|
||||
+++ b/src/mesa/drivers/dri/i915/intel_context.c
|
||||
@@ -507,7 +507,7 @@ intelInitContext(struct intel_context *intel,
|
||||
|
||||
_mesa_meta_init(ctx);
|
||||
|
||||
- intel->hw_stencil = mesaVis->stencilBits && mesaVis->depthBits == 24;
|
||||
+ intel->hw_stencil = mesaVis && mesaVis->stencilBits && mesaVis->depthBits == 24;
|
||||
intel->hw_stipple = 1;
|
||||
|
||||
intel->RenderIndex = ~0;
|
||||
--
|
||||
1.9.3
|
||||
|
11
mesa.spec
11
mesa.spec
|
@ -55,7 +55,7 @@
|
|||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 10.1.4
|
||||
Release: 2.%{gitdate}%{?dist}
|
||||
Release: 3.%{gitdate}%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
|
@ -85,10 +85,6 @@ Patch99: 0001-opencl-use-versioned-.so-in-mesa.icd.patch
|
|||
|
||||
Patch100: radeonsi-llvm-version-hack.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1100967
|
||||
# http://lists.freedesktop.org/archives/mesa-dev/2014-May/060191.html
|
||||
Patch101: 0001-i915-add-a-missing-NULL-pointer-check.patch
|
||||
|
||||
BuildRequires: pkgconfig autoconf automake libtool
|
||||
%if %{with_hardware}
|
||||
BuildRequires: kernel-headers
|
||||
|
@ -346,8 +342,6 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
|
|||
|
||||
%patch100 -p1 -b .radeonsi
|
||||
|
||||
%patch101 -p1 -b .old_intelInitContext
|
||||
|
||||
%if 0%{with_private_llvm}
|
||||
sed -i 's/llvm-config/mesa-private-llvm-config-%{__isa_bits}/g' configure.ac
|
||||
sed -i 's/`$LLVM_CONFIG --version`/&-mesa/' configure.ac
|
||||
|
@ -651,6 +645,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu May 29 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.1.4-3.20140521
|
||||
- drop previous patch (not needed for F20)
|
||||
|
||||
* Wed May 28 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 10.1.4-2.20140521
|
||||
- i915: add a missing NULL pointer check (RHBZ #1100967)
|
||||
|
||||
|
|
Loading…
Reference in a new issue