mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-28 11:06:25 +00:00
drop merged opencl patch
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
97a957ad22
commit
215d161634
2 changed files with 0 additions and 78 deletions
|
@ -1,71 +0,0 @@
|
|||
From 69b30e8f48b24a28c7d27ba59b02776da10cc5a6 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Sun, 12 Jan 2014 02:09:16 +0400
|
||||
Subject: [PATCH] opencl: use versioned .so in mesa.icd
|
||||
|
||||
We must have versioned library in mesa.icd, because ICD loader would
|
||||
fail if the mesa-devel package wasn't installed.
|
||||
|
||||
Reported-by: Fabian Deutsch <fabian.deutsch@gmx.de>
|
||||
Reference: https://bugs.freedesktop.org/show_bug.cgi?id=73512
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
configure.ac | 3 +++
|
||||
src/gallium/targets/opencl/Makefile.am | 2 +-
|
||||
src/gallium/targets/opencl/mesa.icd | 1 -
|
||||
src/gallium/targets/opencl/mesa.icd.in | 1 +
|
||||
4 files changed, 5 insertions(+), 2 deletions(-)
|
||||
delete mode 100644 src/gallium/targets/opencl/mesa.icd
|
||||
create mode 100644 src/gallium/targets/opencl/mesa.icd.in
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 4646212..89a4f48 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -25,6 +25,8 @@ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
|
||||
dnl Set internal versions
|
||||
OSMESA_VERSION=8
|
||||
AC_SUBST([OSMESA_VERSION])
|
||||
+OPENCL_VERSION=1
|
||||
+AC_SUBST([OPENCL_VERSION])
|
||||
|
||||
dnl Versions for external dependencies
|
||||
LIBDRM_REQUIRED=2.4.38
|
||||
@@ -2215,6 +2217,7 @@ AC_CONFIG_FILES([Makefile
|
||||
src/gallium/targets/libgl-xlib/Makefile
|
||||
src/gallium/targets/omx/Makefile
|
||||
src/gallium/targets/opencl/Makefile
|
||||
+ src/gallium/targets/opencl/mesa.icd
|
||||
src/gallium/targets/osmesa/Makefile
|
||||
src/gallium/targets/osmesa/osmesa.pc
|
||||
src/gallium/targets/pipe-loader/Makefile
|
||||
diff --git a/src/gallium/targets/opencl/Makefile.am b/src/gallium/targets/opencl/Makefile.am
|
||||
index ca047f0..82e29a6 100644
|
||||
--- a/src/gallium/targets/opencl/Makefile.am
|
||||
+++ b/src/gallium/targets/opencl/Makefile.am
|
||||
@@ -7,7 +7,7 @@ lib_LTLIBRARIES = lib@OPENCL_LIBNAME@.la
|
||||
lib@OPENCL_LIBNAME@_la_LDFLAGS = \
|
||||
$(LLVM_LDFLAGS) \
|
||||
-no-undefined \
|
||||
- -version-number 1:0 \
|
||||
+ -version-number @OPENCL_VERSION@:0 \
|
||||
$(GC_SECTIONS) \
|
||||
$(LD_NO_UNDEFINED)
|
||||
|
||||
diff --git a/src/gallium/targets/opencl/mesa.icd b/src/gallium/targets/opencl/mesa.icd
|
||||
deleted file mode 100644
|
||||
index 6a6a870..0000000
|
||||
--- a/src/gallium/targets/opencl/mesa.icd
|
||||
+++ /dev/null
|
||||
@@ -1 +0,0 @@
|
||||
-libMesaOpenCL.so
|
||||
diff --git a/src/gallium/targets/opencl/mesa.icd.in b/src/gallium/targets/opencl/mesa.icd.in
|
||||
new file mode 100644
|
||||
index 0000000..1b77b4e
|
||||
--- /dev/null
|
||||
+++ b/src/gallium/targets/opencl/mesa.icd.in
|
||||
@@ -0,0 +1 @@
|
||||
+lib@OPENCL_LIBNAME@.so.@OPENCL_VERSION@
|
||||
--
|
||||
2.0.0
|
||||
|
|
@ -74,9 +74,6 @@ Patch15: mesa-9.2-hardware-float.patch
|
|||
Patch20: mesa-10.2-evergreen-big-endian.patch
|
||||
Patch30: mesa-10.3-bigendian-assert.patch
|
||||
|
||||
# https://bugs.freedesktop.org/show_bug.cgi?id=73512
|
||||
Patch99: 0001-opencl-use-versioned-.so-in-mesa.icd.patch
|
||||
|
||||
# To have sha info in glxinfo
|
||||
BuildRequires: git
|
||||
|
||||
|
@ -351,10 +348,6 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
|
|||
%patch20 -p1 -b .egbe
|
||||
%patch30 -p1 -b .beassert
|
||||
|
||||
%if 0%{?with_opencl}
|
||||
%patch99 -p1 -b .icd
|
||||
%endif
|
||||
|
||||
%if 0%{with_private_llvm}
|
||||
sed -i 's/llvm-config/mesa-private-llvm-config-%{__isa_bits}/g' configure.ac
|
||||
sed -i 's/`$LLVM_CONFIG --version`/&-mesa/' configure.ac
|
||||
|
|
Loading…
Reference in a new issue