mirror of
https://src.fedoraproject.org/rpms/mesa.git
synced 2024-11-24 09:32:42 +00:00
17.3.0-rc2
This commit is contained in:
parent
4c47ac4973
commit
028106f748
5 changed files with 14 additions and 2555 deletions
|
@ -12,15 +12,15 @@ diff --git a/configure.ac b/configure.ac
|
|||
index 5f75c60..d77f907 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2387,7 +2387,7 @@ if test "x$MESA_LLVM" != x0; then
|
||||
@@ -2645,7 +2645,7 @@
|
||||
dnl ourselves.
|
||||
dnl (See https://llvm.org/bugs/show_bug.cgi?id=6823)
|
||||
if test "x$enable_llvm_shared_libs" = xyes; then
|
||||
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
|
||||
- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
|
||||
+ LLVM_SO_NAME=LLVM
|
||||
AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes])
|
||||
dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
|
||||
- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
|
||||
+ LLVM_SO_NAME=LLVM
|
||||
AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes])
|
||||
|
||||
if test "x$llvm_have_one_so" = xyes; then
|
||||
if test "x$llvm_have_one_so" = xyes; then
|
||||
--
|
||||
2.7.4
|
||||
|
||||
|
|
File diff suppressed because it is too large
Load diff
13
mesa.spec
13
mesa.spec
|
@ -54,12 +54,12 @@
|
|||
|
||||
%global sanitize 1
|
||||
|
||||
#global rctag rc6
|
||||
%global rctag rc2
|
||||
|
||||
Name: mesa
|
||||
Summary: Mesa graphics libraries
|
||||
Version: 17.2.4
|
||||
Release: 1%{?rctag:.%{rctag}}%{?dist}
|
||||
Version: 17.3.0
|
||||
Release: 0.2%{?rctag:.%{rctag}}%{?dist}
|
||||
|
||||
License: MIT
|
||||
URL: http://www.mesa3d.org
|
||||
|
@ -71,14 +71,10 @@ Source2: vl_mpeg12_decoder.c
|
|||
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
|
||||
Source3: Mesa-MLAA-License-Clarification-Email.txt
|
||||
|
||||
# https://cgit.freedesktop.org/~ajax/mesa/log/?h=mesa-17.2-s3tc
|
||||
Patch0: 0001-mesa-Squash-merge-of-S3TC-support.patch
|
||||
|
||||
Patch1: 0001-llvm-SONAME-without-version.patch
|
||||
Patch2: 0002-hardware-gloat.patch
|
||||
Patch3: 0003-evergreen-big-endian.patch
|
||||
Patch4: 0004-bigendian-assert.patch
|
||||
Patch5: vc4-Don-t-advertise-tiled-dmabuf-modifiers-if-we-can-t-use-them.patch
|
||||
|
||||
# glvnd support patches
|
||||
# non-upstreamed ones
|
||||
|
@ -694,6 +690,9 @@ popd
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Oct 31 2017 Peter Robinson <pbrobinson@fedoraproject.org> 17.3.0-0.1.rc2
|
||||
- Update to 17.3.0-rc2
|
||||
|
||||
* Tue Oct 31 2017 Peter Robinson <pbrobinson@fedoraproject.org> 17.2.4-1
|
||||
- Update to 17.2.4 GA
|
||||
|
||||
|
|
2
sources
2
sources
|
@ -1 +1 @@
|
|||
SHA512 (mesa-17.2.4.tar.xz) = 665b63aab6af3f8f263f182d85d9ad71db7a23bcbaf67d62fe53c258cb0f600266ac82e72d681ec20cf7c66b47d4076aad5c3f553519f19110ee577da2707085
|
||||
SHA512 (mesa-17.3.0-rc2.tar.xz) = 749cca3e0875dbff7b6fab4d646974ecbcc7659ec82ad025bc386372d6e0e050d84d5e05fb68c5099e685557d85daf55c6a5db7bd89a7323778ae7e87e01215e
|
||||
|
|
|
@ -1,48 +0,0 @@
|
|||
diff --git a/src/gallium/drivers/vc4/vc4_screen.c b/src/gallium/drivers/vc4/vc4_screen.c
|
||||
index 5743e13045..b39cc744e6 100644
|
||||
--- a/src/gallium/drivers/vc4/vc4_screen.c
|
||||
+++ b/src/gallium/drivers/vc4/vc4_screen.c
|
||||
@@ -549,25 +549,30 @@ vc4_screen_query_dmabuf_modifiers(struct pipe_screen *pscreen,
|
||||
unsigned int *external_only,
|
||||
int *count)
|
||||
{
|
||||
+ int m, i;
|
||||
+ uint64_t available_modifiers[] = {
|
||||
+ DRM_FORMAT_MOD_BROADCOM_VC4_T_TILED,
|
||||
+ DRM_FORMAT_MOD_LINEAR,
|
||||
+ };
|
||||
+ struct vc4_screen *screen = vc4_screen(pscreen);
|
||||
+ int num_modifiers = screen->has_tiling_ioctl ? 2 : 1;
|
||||
+
|
||||
if (!modifiers) {
|
||||
- *count = 2;
|
||||
+ *count = num_modifiers;
|
||||
return;
|
||||
}
|
||||
|
||||
- *count = MIN2(max, 2);
|
||||
-
|
||||
+ *count = MIN2(max, num_modifiers);
|
||||
+ m = screen->has_tiling_ioctl ? 0 : 1;
|
||||
/* We support both modifiers (tiled and linear) for all sampler
|
||||
- * formats.
|
||||
+ * formats, but if we don't have the DRM_VC4_GET_TILING ioctl
|
||||
+ * we shouldn't advertise the tiled formats.
|
||||
*/
|
||||
- modifiers[0] = DRM_FORMAT_MOD_BROADCOM_VC4_T_TILED;
|
||||
- if (external_only)
|
||||
- external_only[0] = false;
|
||||
- if (max < 2)
|
||||
- return;
|
||||
-
|
||||
- modifiers[1] = DRM_FORMAT_MOD_LINEAR;
|
||||
- if (external_only)
|
||||
- external_only[1] = false;
|
||||
+ for (i = 0; i < *count; i++) {
|
||||
+ modifiers[i] = available_modifiers[m++];
|
||||
+ if (external_only)
|
||||
+ external_only[i] = false;
|
||||
+ }
|
||||
}
|
||||
|
||||
#define PTR_TO_UINT(x) ((unsigned)((intptr_t)(x)))
|
Loading…
Reference in a new issue