mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-24 17:34:47 +00:00
eb12c13273
* %check: export LD_LIBRARY_PATH because runtimes use external cmake projects that wouldn't find libclang++.so * %check: use LLVM's LIT_XFAIL to mark tests that are expected to fail and don't just delete them * clang: bring over *.patch files * clang: remove build requires tags from clang package that are already defined by main llvm package * clang: remove duplicates found in llvm globals and use %{pkg_datadir} instead of %{install_datadir} * clang: rename and use pkg_name -> pkg_name_clang * clang: use %{pkg_name_clang} instead of %{name} * compiler-rt and libomp: wrap in %if %{without compat_build} * libomp: also build libomp for s390x (See https://github.com/llvm/llvm-project/pull/66081) * libomp: exclude libomp-devel on s390x just like libomp itself * libomp: introduce pkg_name_libomp and cleanup the globals * libomp: remove gdb-plugin (NEED TO CONFIRM IF THIS IS REALLY TRUE) * libomp: filter out flaky libomp test: ompt/teams/distribute_dispatch.c * llvm: add BuildRequires: graphviz to llvm-doc * llvm: use %{pkg_name_llvm} instead of %{name} * make: added temporary Makefile so I can more easily run srpm or rpm builds locally * make: Added local-tmt-vm target (not really useful yet) * rpm: for non-RHEL add prefix like "Jan 05 16:17:06" to every log line This should help in finding out how long things take to build/install/... * rpm: fully specify %files for top-level packages * rpm: make all packages fully qualified * rpm: obsolete llvm-snapshot-builder * rpm: remove BuildRequires: python3-lit because we have it in-tree * rpm: remove BuildRequires: tags for clang and llvm specifics as we're building in-tree * rpm: rename %llvm_srcdir -> %srcdir_llvm * rpm: rename %pkg_name -> %pkg_name_llvm * rpm: use full qualified name in %description * rpm: use region comments in spec file to group by package. This allows editors to fold text to get a better overview * rpmlint: update rc file to reflect clang and compiler-rt (libomp has no rpmlint rc file) * use python-lit from within tree
39 lines
1.5 KiB
Diff
39 lines
1.5 KiB
Diff
From 3dc5722d5c7673a879f2b4680369d3ac8b6b64b6 Mon Sep 17 00:00:00 2001
|
|
From: Tom Stellard <tstellar@redhat.com>
|
|
Date: Wed, 4 Aug 2021 14:05:38 -0700
|
|
Subject: [PATCH] cmake: Allow shared libraries to customize the soname using
|
|
LLVM_ABI_REVISION
|
|
|
|
The LLVM_ABI_REVISION variable is intended to be used for release
|
|
candidates which introduce an ABI change to a shared library. This
|
|
variable can be specified per library, so there is not one global value
|
|
for all of LLVM.
|
|
|
|
For example, if we LLVM X.0.0-rc2 introduces an ABI change for a library
|
|
compared with LLVM X.0.0-rc1, then the LLVM_ABI_REVISION number for
|
|
library will be incremented by 1.
|
|
|
|
In the main branch, LLVM_ABI_REVISION should always be 0, it is only
|
|
meant to be used in the release branch.
|
|
|
|
Differential Revision: https://reviews.llvm.org/D105594
|
|
---
|
|
clang/tools/clang-shlib/CMakeLists.txt | 5 +++++
|
|
3 files changed, 19 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/clang/tools/clang-shlib/CMakeLists.txt b/clang/tools/clang-shlib/CMakeLists.txt
|
|
index 9c1f8ea452b3..4d785924e4bb 100644
|
|
--- a/clang/tools/clang-shlib/CMakeLists.txt
|
|
+++ b/clang/tools/clang-shlib/CMakeLists.txt
|
|
@@ -1,3 +1,8 @@
|
|
+# In the main branch, LLVM_ABI_REVISION should always be 0. In the release
|
|
+# branches, this should be incremented before each release candidate every
|
|
+# time the ABI of libclang-cpp.so changes.
|
|
+set(LLVM_ABI_REVISION 0)
|
|
+
|
|
# Building libclang-cpp.so fails if LLVM_ENABLE_PIC=Off
|
|
if (NOT LLVM_ENABLE_PIC)
|
|
return()
|
|
--
|
|
2.27.0
|
|
|