mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-25 01:35:17 +00:00
50 lines
1.8 KiB
Diff
50 lines
1.8 KiB
Diff
From fea6f0e31253ad0f335eea2e4718bacd5930d6d4 Mon Sep 17 00:00:00 2001
|
|
From: Nikita Popov <npopov@redhat.com>
|
|
Date: Fri, 19 Jul 2024 14:52:49 +0200
|
|
Subject: [PATCH] Add back support for Python 3.6
|
|
|
|
---
|
|
llvm/CMakeLists.txt | 2 +-
|
|
llvm/utils/update_test_body.py | 6 ++++--
|
|
2 files changed, 5 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/llvm/CMakeLists.txt b/llvm/CMakeLists.txt
|
|
index 12618966c4ad..9c4df0082a9a 100644
|
|
--- a/llvm/CMakeLists.txt
|
|
+++ b/llvm/CMakeLists.txt
|
|
@@ -932,7 +932,7 @@ set(LLVM_PROFDATA_FILE "" CACHE FILEPATH
|
|
|
|
if(LLVM_INCLUDE_TESTS)
|
|
# All LLVM Python files should be compatible down to this minimum version.
|
|
- set(LLVM_MINIMUM_PYTHON_VERSION 3.8)
|
|
+ set(LLVM_MINIMUM_PYTHON_VERSION 3.6)
|
|
else()
|
|
# FIXME: it is unknown if this is the actual minimum bound
|
|
set(LLVM_MINIMUM_PYTHON_VERSION 3.0)
|
|
diff --git a/llvm/utils/update_test_body.py b/llvm/utils/update_test_body.py
|
|
index 661b0270d783..152d0c5f8476 100755
|
|
--- a/llvm/utils/update_test_body.py
|
|
+++ b/llvm/utils/update_test_body.py
|
|
@@ -57,7 +57,8 @@ def process(args, path):
|
|
input="\n".join(
|
|
prolog[:-1] if prolog[-1].startswith(".endif") else prolog
|
|
).encode(),
|
|
- capture_output=True,
|
|
+ stdout=subprocess.PIPE,
|
|
+ stderr=subprocess.PIPE,
|
|
check=True,
|
|
)
|
|
except subprocess.CalledProcessError as ex:
|
|
@@ -71,7 +72,8 @@ def process(args, path):
|
|
|
|
sub = subprocess.run(
|
|
["sh", "-eu", "gen"],
|
|
- capture_output=True,
|
|
+ stdout=subprocess.PIPE,
|
|
+ stderr=subprocess.PIPE,
|
|
# Don't encode the directory information to the Clang output.
|
|
# Remove unneeded details (.ident) as well.
|
|
env=dict(
|
|
--
|
|
2.45.2
|
|
|