mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-24 17:34:47 +00:00
39 lines
1.4 KiB
Diff
39 lines
1.4 KiB
Diff
From fdda55bb968b2c39da76baa85a29114f53154944 Mon Sep 17 00:00:00 2001
|
|
From: Chris Bieneman <beanz@apple.com>
|
|
Date: Thu, 25 Aug 2016 20:53:00 +0000
|
|
Subject: [PATCH] cmake: Install CheckAtomic.cmake (needed by lldb)
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Summary:
|
|
Install CheckAtomic.cmake along with other LLVM modules, therefore making it possible for other projects to use it. This file is needed for LLDB to be built standalone, and installing it was suggested in https://reviews.llvm.org/D23881.
|
|
|
|
Patch by: Michał Górny
|
|
|
|
Reviewers: krytarowski, zturner, eugenis, jyknight, labath, beanz
|
|
|
|
Subscribers: beanz, llvm-commits
|
|
|
|
Differential Revision: https://reviews.llvm.org/D23887
|
|
|
|
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@279777 91177308-0d34-0410-b5e6-96231b3b80d8
|
|
---
|
|
cmake/modules/CMakeLists.txt | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/cmake/modules/CMakeLists.txt b/cmake/modules/CMakeLists.txt
|
|
index 826dd36..d2510b8 100644
|
|
--- a/cmake/modules/CMakeLists.txt
|
|
+++ b/cmake/modules/CMakeLists.txt
|
|
@@ -91,6 +91,5 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
|
|
PATTERN LLVMConfig.cmake EXCLUDE
|
|
PATTERN LLVMConfigVersion.cmake EXCLUDE
|
|
PATTERN LLVM-Config.cmake EXCLUDE
|
|
- PATTERN GetHostTriple.cmake EXCLUDE
|
|
- PATTERN CheckAtomic.cmake EXCLUDE)
|
|
+ PATTERN GetHostTriple.cmake EXCLUDE)
|
|
endif()
|
|
--
|
|
2.5.5
|
|
|