mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-25 01:35:17 +00:00
Remove patch applied upstream
This commit is contained in:
parent
12199f2b7b
commit
f71e71c65e
2 changed files with 0 additions and 34 deletions
|
@ -1,32 +0,0 @@
|
||||||
From 8cc3870f09d728d9017c72eba9520117a4283fee Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tom Stellard <tstellar@redhat.com>
|
|
||||||
Date: Thu, 17 Nov 2022 09:01:10 +0000
|
|
||||||
Subject: Add install targets for gtest
|
|
||||||
|
|
||||||
Stand-alone builds need an installed version of gtest in order to run
|
|
||||||
the unittests.
|
|
||||||
|
|
||||||
Differential Revision: https://reviews.llvm.org/D137890
|
|
||||||
---
|
|
||||||
llvm/CMakeLists.txt | 5 +++++
|
|
||||||
1 file changed, 5 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/llvm/CMakeLists.txt b/llvm/CMakeLists.txt
|
|
||||||
index 60e1f29620af..d91338532815 100644
|
|
||||||
--- a/llvm/CMakeLists.txt
|
|
||||||
+++ b/llvm/CMakeLists.txt
|
|
||||||
@@ -693,6 +693,11 @@ option(LLVM_BUILD_TESTS
|
|
||||||
"Build LLVM unit tests. If OFF, just generate build targets." OFF)
|
|
||||||
option(LLVM_INCLUDE_TESTS "Generate build targets for the LLVM unit tests." ON)
|
|
||||||
|
|
||||||
+option(LLVM_INSTALL_GTEST
|
|
||||||
+ "Install the llvm gtest library. This should be on if you want to do
|
|
||||||
+ stand-alone builds of the other projects and run their unit tests." OFF)
|
|
||||||
+
|
|
||||||
+
|
|
||||||
option(LLVM_BUILD_BENCHMARKS "Add LLVM benchmark targets to the list of default
|
|
||||||
targets. If OFF, benchmarks still could be built using Benchmarks target." OFF)
|
|
||||||
option(LLVM_INCLUDE_BENCHMARKS "Generate benchmark targets. If OFF, benchmarks can't be built." ON)
|
|
||||||
--
|
|
||||||
2.34.3
|
|
||||||
|
|
|
@ -113,8 +113,6 @@ Source5: run-lit-tests
|
||||||
Source6: lit.fedora.cfg.py
|
Source6: lit.fedora.cfg.py
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# See https://reviews.llvm.org/D137890 for the next two patches
|
|
||||||
Patch2: 0001-llvm-Add-install-targets-for-gtest.patch
|
|
||||||
# Patching third-party dir with a 200 offset in patch number
|
# Patching third-party dir with a 200 offset in patch number
|
||||||
Patch201: 0201-third-party-Add-install-targets-for-gtest.patch
|
Patch201: 0201-third-party-Add-install-targets-for-gtest.patch
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue