mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-24 09:32:42 +00:00
13.0.0-rc3 Release
This commit is contained in:
parent
20aa2e6b37
commit
efdfe5532f
4 changed files with 10 additions and 65 deletions
2
.gitignore
vendored
2
.gitignore
vendored
|
@ -110,3 +110,5 @@
|
|||
/llvm-12.0.1.src.tar.xz.sig
|
||||
/llvm-13.0.0rc1.src.tar.xz
|
||||
/llvm-13.0.0rc1.src.tar.xz.sig
|
||||
/llvm-13.0.0rc3.src.tar.xz
|
||||
/llvm-13.0.0rc3.src.tar.xz.sig
|
||||
|
|
|
@ -1,58 +0,0 @@
|
|||
From 93da37dc58e9d1d4a685bcb6a30a9d3ff78733f9 Mon Sep 17 00:00:00 2001
|
||||
From: Nathan Chancellor <nathan@kernel.org>
|
||||
Date: Wed, 28 Jul 2021 21:56:23 -0700
|
||||
Subject: [PATCH] [test] Fix tools/gold/X86/comdat-nodeduplicate.ll on non-X86
|
||||
hosts
|
||||
|
||||
When running this test on an aarch64 machine, it fails:
|
||||
|
||||
```
|
||||
/usr/bin/ld.gold: error: .../test/tools/gold/X86/Output/comdat-nodeduplicate.ll.tmp/ab.lto.o: incompatible target
|
||||
```
|
||||
|
||||
Specify the elf_x86_64 emulation as all of the other gold plugin tests
|
||||
do.
|
||||
|
||||
Reviewed By: MaskRay
|
||||
|
||||
Differential Revision: https://reviews.llvm.org/D107020
|
||||
|
||||
(cherry picked from commit 5060224d9eed8b8359ed5090bb7c577b8575e9e7)
|
||||
---
|
||||
llvm/test/tools/gold/X86/comdat-nodeduplicate.ll | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/llvm/test/tools/gold/X86/comdat-nodeduplicate.ll b/llvm/test/tools/gold/X86/comdat-nodeduplicate.ll
|
||||
index 11d04d2aab1f..c27d91a1d437 100644
|
||||
--- a/llvm/test/tools/gold/X86/comdat-nodeduplicate.ll
|
||||
+++ b/llvm/test/tools/gold/X86/comdat-nodeduplicate.ll
|
||||
@@ -8,7 +8,7 @@
|
||||
; RUN: llvm-as %t/b.ll -o %t/b.bc
|
||||
; RUN: llvm-as %t/c.ll -o %t/c.bc
|
||||
|
||||
-; RUN: %gold -plugin %llvmshlibdir/LLVMgold%shlibext --plugin-opt=save-temps \
|
||||
+; RUN: %gold -m elf_x86_64 -plugin %llvmshlibdir/LLVMgold%shlibext --plugin-opt=save-temps \
|
||||
; RUN: -u foo %t/a.bc --start-lib %t/b.bc --end-lib -o %t/ab
|
||||
|
||||
; RUN: FileCheck %s --check-prefix=RESOL_AB < %t/ab.resolution.txt
|
||||
@@ -20,7 +20,7 @@
|
||||
; DATA: 0x[[#%x,]] 01000000 00000000 ........
|
||||
|
||||
;; __profc_foo from c.bc is non-prevailing and thus discarded.
|
||||
-; RUN: %gold -plugin %llvmshlibdir/LLVMgold%shlibext --plugin-opt=save-temps \
|
||||
+; RUN: %gold -m elf_x86_64 -plugin %llvmshlibdir/LLVMgold%shlibext --plugin-opt=save-temps \
|
||||
; RUN: -u foo -u c %t/a.bc --start-lib %t/b.bc %t/c.bc --end-lib -o %t/abc
|
||||
; RUN: FileCheck %s --check-prefix=RESOL_ABC < %t/abc.resolution.txt
|
||||
; RUN: llvm-readelf -x .data %t/abc | FileCheck %s --check-prefix=DATA
|
||||
@@ -35,7 +35,7 @@
|
||||
; RUN: opt --module-summary %t/b.ll -o %t/b.bc
|
||||
; RUN: opt --module-summary %t/c.ll -o %t/c.bc
|
||||
|
||||
-; RUN: %gold -plugin %llvmshlibdir/LLVMgold%shlibext \
|
||||
+; RUN: %gold -m elf_x86_64 -plugin %llvmshlibdir/LLVMgold%shlibext \
|
||||
; RUN: -u foo %t/a.bc --start-lib %t/b.bc %t/c.bc --end-lib -o %t/abc
|
||||
; RUN: llvm-readelf -x .data %t/abc | FileCheck %s --check-prefix=DATA
|
||||
|
||||
--
|
||||
2.27.0
|
||||
|
11
llvm.spec
11
llvm.spec
|
@ -11,11 +11,11 @@
|
|||
|
||||
%global llvm_libdir %{_libdir}/%{name}
|
||||
%global build_llvm_libdir %{buildroot}%{llvm_libdir}
|
||||
%global rc_ver 1
|
||||
%global rc_ver 3
|
||||
%global maj_ver 13
|
||||
%global min_ver 0
|
||||
%global patch_ver 0
|
||||
%global abi_revision 0
|
||||
%global abi_revision 1
|
||||
%global llvm_srcdir llvm-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
%if %{with compat_build}
|
||||
|
@ -54,7 +54,7 @@
|
|||
|
||||
Name: %{pkg_name}
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: The Low Level Virtual Machine
|
||||
|
||||
License: NCSA
|
||||
|
@ -69,8 +69,6 @@ Source4: lit.fedora.cfg.py
|
|||
%endif
|
||||
|
||||
Patch0: 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
|
||||
# This has been backported to release/13.x and should be in 13.0.0-rc2
|
||||
Patch1: 0001-test-Fix-tools-gold-X86-comdat-nodeduplicate.ll-on-n.patch
|
||||
Patch2: 0001-XFAIL-missing-abstract-variable.ll-test-on-ppc64le.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
|
@ -537,6 +535,9 @@ fi
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Sep 17 2021 Tom Stellard <tstellar@redhta.com> - 13.0.0~rc3-1
|
||||
- 13.0.0-rc3 Release
|
||||
|
||||
* Mon Sep 13 2021 Tom Stellard <tstellar@redhat.com> - 13.0.0~rc1-3
|
||||
- Pass LLVM_DEFAULT_TARGET_TRIPLE to cmake
|
||||
|
||||
|
|
4
sources
4
sources
|
@ -1,2 +1,2 @@
|
|||
SHA512 (llvm-13.0.0rc1.src.tar.xz) = 307d8162f905b92e33f27c7a75f78d1020a63c24a13d4befa4dd7b6ed90607919183919df9a626f705935dfccce3d36c2b99b9575bfc6f23f8df115374fa6823
|
||||
SHA512 (llvm-13.0.0rc1.src.tar.xz.sig) = 6b49f7b96a5ee0634d328cfaa6d47820cf89ee3363553670b46c7d3c071c3f624ee10f663315f31c03965a43177baccaaa0e88a75b4cfadeb3783b1d83c850b3
|
||||
SHA512 (llvm-13.0.0rc3.src.tar.xz) = af2f237e8dbfe47ea21cd0d0463dccfc0585118c4773ffb3dc60b9bad582de33fe9e2f14d41c1332df911ce3234589fedccfb3db706f1d9720e98e8f406e80b6
|
||||
SHA512 (llvm-13.0.0rc3.src.tar.xz.sig) = aecafd70138da902338dd0f4c523ff22a3b43669c973de05a1aa775c9e65ce065086806e2009d354afe99337d9701d27968f980441144f0289735a15caec77b3
|
||||
|
|
Loading…
Reference in a new issue