mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-24 09:32:42 +00:00
Update to LLVM 17.0.0 RC3
This commit is contained in:
parent
bf19c70bc0
commit
de70be4496
3 changed files with 42 additions and 12 deletions
27
0001-Fix-regression-of-D157680.patch
Normal file
27
0001-Fix-regression-of-D157680.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
From b7cf9bbfde5e623e16fe8669e18aa34cbb3afafa Mon Sep 17 00:00:00 2001
|
||||
From: XinWang10 <xin10.wang@intel.com>
|
||||
Date: Fri, 18 Aug 2023 00:08:01 -0700
|
||||
Subject: [PATCH] Fix regression of D157680
|
||||
|
||||
Test cases in D157680 should be target specific, but miss some limit, add them back to make buildbot pass.
|
||||
|
||||
Reviewed By: skan, Hahnfeld
|
||||
|
||||
Differential Revision: https://reviews.llvm.org/D158252
|
||||
---
|
||||
diff --git a/llvm/test/CodeGen/X86/x86-prefer-no-gather-no-scatter.ll b/llvm/test/CodeGen/X86/x86-prefer-no-gather-no-scatter.ll
|
||||
index e3f3622f146d..33250b3495a0 100644
|
||||
--- a/llvm/test/CodeGen/X86/x86-prefer-no-gather-no-scatter.ll
|
||||
+++ b/llvm/test/CodeGen/X86/x86-prefer-no-gather-no-scatter.ll
|
||||
@@ -1,6 +1,6 @@
|
||||
; Check that if option prefer-no-gather/scatter can disable gather/scatter instructions.
|
||||
-; RUN: llc -mattr=+avx2,+fast-gather %s -o - | FileCheck %s --check-prefixes=GATHER
|
||||
-; RUN: llc -mattr=+avx2,+fast-gather,+prefer-no-gather %s -o - | FileCheck %s --check-prefixes=NO-GATHER
|
||||
+; RUN: llc -mtriple=x86_64-unknown-linux-gnu -mattr=+avx2,+fast-gather %s -o - | FileCheck %s --check-prefixes=GATHER
|
||||
+; RUN: llc -mtriple=x86_64-unknown-linux-gnu -mattr=+avx2,+fast-gather,+prefer-no-gather %s -o - | FileCheck %s --check-prefixes=NO-GATHER
|
||||
; RUN: llc -mtriple=x86_64-unknown-linux-gnu -mattr=+avx512vl,+avx512dq < %s | FileCheck %s --check-prefix=SCATTER
|
||||
; RUN: llc -mtriple=x86_64-unknown-linux-gnu -mattr=+avx512vl,+avx512dq,+prefer-no-gather < %s | FileCheck %s --check-prefix=SCATTER-NO-GATHER
|
||||
; RUN: llc -mtriple=x86_64-unknown-linux-gnu -mattr=+avx512vl,+avx512dq,+prefer-no-scatter < %s | FileCheck %s --check-prefix=GATHER-NO-SCATTER
|
||||
--
|
||||
2.41.0
|
||||
|
15
llvm.spec
15
llvm.spec
|
@ -37,7 +37,7 @@
|
|||
%global maj_ver 17
|
||||
%global min_ver 0
|
||||
%global patch_ver 0
|
||||
%global rc_ver 2
|
||||
%global rc_ver 3
|
||||
|
||||
%if %{with snapshot_build}
|
||||
%undefine rc_ver
|
||||
|
@ -100,7 +100,7 @@
|
|||
|
||||
Name: %{pkg_name}
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}%{?llvm_snapshot_version_suffix:~%{llvm_snapshot_version_suffix}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: The Low Level Virtual Machine
|
||||
|
||||
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
||||
|
@ -119,8 +119,8 @@ Source4: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ve
|
|||
Source5: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:-rc%{rc_ver}}/%{third_party_srcdir}.tar.xz.sig
|
||||
Source6: release-keys.asc
|
||||
|
||||
# Backport of https://reviews.llvm.org/D156379 from LLVM 18.
|
||||
Patch1: D156379.diff
|
||||
# Backport of https://reviews.llvm.org/D158252 from LLVM 18.
|
||||
Patch1: 0001-Fix-regression-of-D157680.patch
|
||||
%endif
|
||||
|
||||
# RHEL-specific patch to avoid unwanted recommonmark dep
|
||||
|
@ -616,11 +616,14 @@ fi
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
%{?llvm_snapshot_changelog_entry}
|
||||
|
||||
* Thu Aug 24 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 17.0.0~rc3-1
|
||||
- Update to LLVM 17.0.0 RC3
|
||||
|
||||
* Thu Aug 24 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 17.0.0~rc2-2
|
||||
- Temporarily disable a failing test on ppc64le
|
||||
|
||||
%{?llvm_snapshot_changelog_entry}
|
||||
|
||||
* Thu Aug 17 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 17.0.0~rc2-1
|
||||
- Update to LLVM 17.0.0 RC2
|
||||
|
||||
|
|
12
sources
12
sources
|
@ -1,6 +1,6 @@
|
|||
SHA512 (cmake-17.0.0rc2.src.tar.xz) = e609eb4262a75719169741313b82a3e300955bb9acdbb8a7c5433948f8c8a05ca3fdc4cdee2576917b85dc11929a05b1ccacc5e963b4de067b48759d06ed2c99
|
||||
SHA512 (cmake-17.0.0rc2.src.tar.xz.sig) = 3a6bd75d4f8b4f605af7e287cb43461e3f7d9c423f8549ad84e2d2f9a38e5f3d210c7fbeaa1bf9f609ff23cc4454420a21c02d73097d101c57cc8451226a7ae2
|
||||
SHA512 (llvm-17.0.0rc2.src.tar.xz) = 7c3f6f5f74a481cae1d7a96fecbadae9c9f84636c6783344994bdd9b905c11fa923339ee8223ae54ba0ebffd9bf95014429bd6be39e731e32f0c726a62f1e6c6
|
||||
SHA512 (llvm-17.0.0rc2.src.tar.xz.sig) = 80995b282d9e470e060265e73e80216f9a5e96f2a19585898d4b6b63bf7fca7d4970c72611750d3ea3f35b593ce51faae17873c0d5f4232251db3c98f73c77f0
|
||||
SHA512 (third-party-17.0.0rc2.src.tar.xz) = 878b14ed25c4c9660244e0a621f4e107b5f7ae8e60e2c9396b0bbbedaecd8bf596fa5081ef13243aa75f0ca73750f90387a327724ffcef72efb9c817b13284e8
|
||||
SHA512 (third-party-17.0.0rc2.src.tar.xz.sig) = c5c20e6d23c3355adddd0015df3122eae13c1b6612aa1158a1ef7cee639b6b7cda3d377f1004997d95787744df41b9a71fa4d845f378c2dd6c377233fcbed569
|
||||
SHA512 (cmake-17.0.0rc3.src.tar.xz) = 2ac07f705f09f4332ce91b9ce62e2fa0d50f52c32123b51f3668dc9e23a3f876b1f37a1924d2a88e6a2e8184f5538a9319f40e97500bb39fb159bb84d6bc31ab
|
||||
SHA512 (cmake-17.0.0rc3.src.tar.xz.sig) = 69b55839af4f1c6e0e538684b7e753b83076f88af87f524cd15766de05cad9fbf91db7de0710cf6343c43f25429415bd02a6728837f59af4134da4340e47bff0
|
||||
SHA512 (llvm-17.0.0rc3.src.tar.xz) = 2a16d34f82f74335dace530c3c17d4c52ebbd6ff07beae2182c6deb2c4569e9d914131cc8b842fafc7352a7c3f19af82cb69d955b12b28cde5e2e7bf398c75f3
|
||||
SHA512 (llvm-17.0.0rc3.src.tar.xz.sig) = c8d5c263d3fcaa79ffb55f3df68ca6488d3eb0435c756fdabac38873fffae1992b4a21f0057493d3eb55788fb8a2e06819dbf6d4c2ad06cbfa02ee5041fcbfdd
|
||||
SHA512 (third-party-17.0.0rc3.src.tar.xz) = f87ec068b36c6a76dc8590b36a96eb152abc320c1a13a6f7ebde22b5b52c9a1447ec83f8dc672b11edbe701bcb52c3da84aabcf4994f22a8ffeab87f78d0e452
|
||||
SHA512 (third-party-17.0.0rc3.src.tar.xz.sig) = 7d272e725fe265d14fec6c5b55ae304eb82f4c41d8e2bdaafe4c047f7ad319df0ef8749dedddf06172da3164abe5de4df4a87238b3e072e1cc7fad933195e736
|
||||
|
|
Loading…
Reference in a new issue