mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-24 09:32:42 +00:00
9.0.0-rc3 Release
This commit is contained in:
parent
5dee6b644a
commit
d62829b09a
2 changed files with 42 additions and 2 deletions
|
@ -0,0 +1,34 @@
|
||||||
|
From f0762684457a883b6813b48c98a1e94e377bc06b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tom Stellard <tstellar@redhat.com>
|
||||||
|
Date: Wed, 28 Aug 2019 19:31:21 -0700
|
||||||
|
Subject: [PATCH] Pass target to gold linker to avoid faliures on i686
|
||||||
|
|
||||||
|
---
|
||||||
|
llvm/test/tools/gold/X86/linkonce_odr_unnamed_addr.ll | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/llvm/test/tools/gold/X86/linkonce_odr_unnamed_addr.ll b/llvm/test/tools/gold/X86/linkonce_odr_unnamed_addr.ll
|
||||||
|
index 525bf2d..01291bd 100644
|
||||||
|
--- a/llvm/test/tools/gold/X86/linkonce_odr_unnamed_addr.ll
|
||||||
|
+++ b/llvm/test/tools/gold/X86/linkonce_odr_unnamed_addr.ll
|
||||||
|
@@ -3,7 +3,7 @@
|
||||||
|
|
||||||
|
; RUN: opt -module-summary %s -o %t.o
|
||||||
|
; RUN: opt -module-summary %p/Inputs/linkonce_odr_unnamed_addr.ll -o %t2.o
|
||||||
|
-; RUN: %gold -plugin %llvmshlibdir/LLVMgold%shlibext \
|
||||||
|
+; RUN: %gold -m elf_x86_64 -plugin %llvmshlibdir/LLVMgold%shlibext \
|
||||||
|
; RUN: --plugin-opt=save-temps \
|
||||||
|
; RUN: %t.o %t2.o -o %t3.o
|
||||||
|
; RUN: llvm-dis %t.o.1.promote.bc -o - | FileCheck %s
|
||||||
|
@@ -11,7 +11,7 @@
|
||||||
|
; Now test when one module is a native object. In that case we must be
|
||||||
|
; conservative and not auto hide.
|
||||||
|
; RUN: llc %p/Inputs/linkonce_odr_unnamed_addr.ll -o %t2native.o -filetype=obj
|
||||||
|
-; RUN: %gold -plugin %llvmshlibdir/LLVMgold%shlibext \
|
||||||
|
+; RUN: %gold -m elf_x86_64 -plugin %llvmshlibdir/LLVMgold%shlibext \
|
||||||
|
; RUN: --plugin-opt=save-temps \
|
||||||
|
; RUN: %t.o %t2native.o -o %t3.o
|
||||||
|
; RUN: llvm-dis %t.o.1.promote.bc -o - | FileCheck %s --check-prefix=NOSUMMARY
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
10
llvm.spec
10
llvm.spec
|
@ -13,8 +13,8 @@
|
||||||
%global maj_ver 9
|
%global maj_ver 9
|
||||||
%global min_ver 0
|
%global min_ver 0
|
||||||
%global patch_ver 0
|
%global patch_ver 0
|
||||||
%global rc_ver 2
|
%global rc_ver 3
|
||||||
%global baserelease 0.1
|
%global baserelease 0.2
|
||||||
|
|
||||||
|
|
||||||
%if %{with compat_build}
|
%if %{with compat_build}
|
||||||
|
@ -51,6 +51,9 @@ Source2: lit.fedora.cfg.py
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Patch0: 0001-Filter-out-cxxflags-not-supported-by-clang.patch
|
Patch0: 0001-Filter-out-cxxflags-not-supported-by-clang.patch
|
||||||
|
# TODO: I'm not sure why this is needed. Could be a change in newer version
|
||||||
|
# of gold.
|
||||||
|
Patch1: 0001-Pass-target-to-gold-linker-to-avoid-faliures-on-i686.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
|
@ -467,6 +470,9 @@ fi
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 30 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-0.2.rc3
|
||||||
|
- 9.0.0-rc3 Release
|
||||||
|
|
||||||
* Thu Aug 01 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-0.1.rc2
|
* Thu Aug 01 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-0.1.rc2
|
||||||
- 9.0.0-rc2 Release
|
- 9.0.0-rc2 Release
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue