mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-28 02:34:52 +00:00
Avoid recommonmark dependency in RHEL builds
python-recommonmark and its dependencies are unwanted in RHEL.
This commit is contained in:
parent
85d29458f2
commit
bcf7ece4a8
2 changed files with 34 additions and 2 deletions
25
0101-Deactivate-markdown-doc.patch
Normal file
25
0101-Deactivate-markdown-doc.patch
Normal file
|
@ -0,0 +1,25 @@
|
||||||
|
diff -Naur a/llvm/docs/conf.py b/llvm/docs/conf.py
|
||||||
|
--- a/llvm/docs/conf.py 2020-09-15 09:12:24.318287611 +0000
|
||||||
|
+++ b/llvm/docs/conf.py 2020-09-15 15:01:00.025893199 +0000
|
||||||
|
@@ -36,20 +36,7 @@
|
||||||
|
'.rst': 'restructuredtext',
|
||||||
|
}
|
||||||
|
|
||||||
|
-try:
|
||||||
|
- import recommonmark
|
||||||
|
-except ImportError:
|
||||||
|
- # manpages do not use any .md sources
|
||||||
|
- if not tags.has('builder-man'):
|
||||||
|
- raise
|
||||||
|
-else:
|
||||||
|
- import sphinx
|
||||||
|
- if sphinx.version_info >= (3, 0):
|
||||||
|
- # This requires 0.5 or later.
|
||||||
|
- extensions.append('recommonmark')
|
||||||
|
- else:
|
||||||
|
- source_parsers = {'.md': 'recommonmark.parser.CommonMarkParser'}
|
||||||
|
- source_suffix['.md'] = 'markdown'
|
||||||
|
+import sphinx
|
||||||
|
|
||||||
|
# The encoding of source files.
|
||||||
|
#source_encoding = 'utf-8-sig'
|
11
llvm.spec
11
llvm.spec
|
@ -75,7 +75,7 @@
|
||||||
|
|
||||||
Name: %{pkg_name}
|
Name: %{pkg_name}
|
||||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: The Low Level Virtual Machine
|
Summary: The Low Level Virtual Machine
|
||||||
|
|
||||||
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
||||||
|
@ -90,6 +90,8 @@ Source6: release-keys.asc
|
||||||
|
|
||||||
# See https://reviews.llvm.org/D137890 for the next two patches
|
# See https://reviews.llvm.org/D137890 for the next two patches
|
||||||
Patch2: 0001-llvm-Add-install-targets-for-gtest.patch
|
Patch2: 0001-llvm-Add-install-targets-for-gtest.patch
|
||||||
|
# RHEL-specific patch to avoid unwanted recommonmark dep
|
||||||
|
Patch101: 0101-Deactivate-markdown-doc.patch
|
||||||
# Patching third-party dir with a 200 offset in patch number
|
# Patching third-party dir with a 200 offset in patch number
|
||||||
Patch201: 0201-third-party-Add-install-targets-for-gtest.patch
|
Patch201: 0201-third-party-Add-install-targets-for-gtest.patch
|
||||||
|
|
||||||
|
@ -103,7 +105,9 @@ BuildRequires: libffi-devel
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
BuildRequires: python3-psutil
|
BuildRequires: python3-psutil
|
||||||
BuildRequires: python3-sphinx
|
BuildRequires: python3-sphinx
|
||||||
|
%if %{undefined rhel}
|
||||||
BuildRequires: python3-recommonmark
|
BuildRequires: python3-recommonmark
|
||||||
|
%endif
|
||||||
BuildRequires: multilib-rpm-config
|
BuildRequires: multilib-rpm-config
|
||||||
%if %{with gold}
|
%if %{with gold}
|
||||||
BuildRequires: binutils-devel
|
BuildRequires: binutils-devel
|
||||||
|
@ -218,7 +222,7 @@ cd ..
|
||||||
mv %{third_party_srcdir} third-party
|
mv %{third_party_srcdir} third-party
|
||||||
|
|
||||||
%setup -T -q -b 0 -n %{llvm_srcdir}
|
%setup -T -q -b 0 -n %{llvm_srcdir}
|
||||||
%autopatch -M200 -p2
|
%autopatch -M%{?!rhel:100}%{?rhel:200} -p2
|
||||||
|
|
||||||
%py3_shebang_fix \
|
%py3_shebang_fix \
|
||||||
test/BugPoint/compile-custom.ll.py \
|
test/BugPoint/compile-custom.ll.py \
|
||||||
|
@ -559,6 +563,9 @@ fi
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 19 2023 Yaakov Selkowitz <yselkowi@redhat.com> - 16.0.4-2
|
||||||
|
- Avoid recommonmark dependency in RHEL builds
|
||||||
|
|
||||||
* Thu May 18 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 16.0.4-1
|
* Thu May 18 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 16.0.4-1
|
||||||
- Update to LLVM 16.0.4
|
- Update to LLVM 16.0.4
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue