mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-24 09:32:42 +00:00
Update to LLVM 16.0.0 RC1
This commit is contained in:
parent
034719a43e
commit
a2100f44b7
4 changed files with 36 additions and 73 deletions
|
@ -1,28 +0,0 @@
|
|||
From 2e106d4cfc909e23e16104725706e4f9dda15974 Mon Sep 17 00:00:00 2001
|
||||
From: Nikita Popov <npopov@redhat.com>
|
||||
Date: Fri, 5 Aug 2022 08:57:18 +0200
|
||||
Subject: [PATCH] Install clang-tblgen
|
||||
|
||||
---
|
||||
llvm/cmake/modules/TableGen.cmake | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/llvm/cmake/modules/TableGen.cmake b/llvm/cmake/modules/TableGen.cmake
|
||||
index 4711456776c8..edcc9d0b607d 100644
|
||||
--- a/llvm/cmake/modules/TableGen.cmake
|
||||
+++ b/llvm/cmake/modules/TableGen.cmake
|
||||
@@ -186,7 +186,10 @@ macro(add_tablegen target project)
|
||||
endif()
|
||||
endif()
|
||||
|
||||
- if ((${project} STREQUAL LLVM OR ${project} STREQUAL MLIR) AND NOT LLVM_INSTALL_TOOLCHAIN_ONLY AND LLVM_BUILD_UTILS)
|
||||
+ # (llvm|mlir|clang)-tblgen may also be used outside the respective projects.
|
||||
+ if ((${project} STREQUAL LLVM OR ${project} STREQUAL MLIR OR
|
||||
+ ${project} STREQUAL CLANG) AND
|
||||
+ NOT LLVM_INSTALL_TOOLCHAIN_ONLY AND LLVM_BUILD_UTILS)
|
||||
set(export_to_llvmexports)
|
||||
if(${target} IN_LIST LLVM_DISTRIBUTION_COMPONENTS OR
|
||||
NOT LLVM_DISTRIBUTION_COMPONENTS)
|
||||
--
|
||||
2.37.1
|
||||
|
|
@ -1,33 +0,0 @@
|
|||
From 01529ba2c76be37e41713cf7f3eca8b61833e320 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Tue, 9 Nov 2021 15:05:07 +0100
|
||||
Subject: [PATCH] XFAIL missing-abstract-variable.ll test on ppc64le
|
||||
|
||||
It's seems the strategy with this test is to XFAIL it on all
|
||||
architectures that it fails on. I wonder if we should be passing
|
||||
it a specific triple? Also, from what I can tell, this tests only
|
||||
runs when llvm is configured with LLVM_DEFAULT_TARGET_TRIPLE set
|
||||
to a non-empty value, which is why it may not fail in every build
|
||||
configuration.
|
||||
|
||||
Differential Revision: https://reviews.llvm.org/D109806
|
||||
---
|
||||
llvm/test/DebugInfo/Generic/missing-abstract-variable.ll | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/llvm/test/DebugInfo/Generic/missing-abstract-variable.ll b/llvm/test/DebugInfo/Generic/missing-abstract-variable.ll
|
||||
index 8f8d404..07a8778 100644
|
||||
--- a/llvm/test/DebugInfo/Generic/missing-abstract-variable.ll
|
||||
+++ b/llvm/test/DebugInfo/Generic/missing-abstract-variable.ll
|
||||
@@ -4,7 +4,7 @@
|
||||
; powerpc64 (and on x86_64 at at least -O2). Presumably this is a SelectionDAG
|
||||
; issue.
|
||||
; FIXME: arm64 is an alias for aarch64 on macs, apparently?
|
||||
-; XFAIL: powerpc64, aarch64, arm64, hexagon, riscv, sparc
|
||||
+; XFAIL: powerpc64, aarch64, arm64, hexagon, riscv, sparc, ppc64le
|
||||
|
||||
; Build from the following source with clang -O2.
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
24
disable-exegesis-tests-s390x.patch
Normal file
24
disable-exegesis-tests-s390x.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
diff --git a/llvm/test/tools/llvm-exegesis/PowerPC/lit.local.cfg b/llvm/test/tools/llvm-exegesis/PowerPC/lit.local.cfg
|
||||
index 135f5796b583..20de4ec2cc66 100644
|
||||
--- a/llvm/test/tools/llvm-exegesis/PowerPC/lit.local.cfg
|
||||
+++ b/llvm/test/tools/llvm-exegesis/PowerPC/lit.local.cfg
|
||||
@@ -1,3 +1,7 @@
|
||||
+if 's390x' in config.root.host_triple:
|
||||
+ # These tests fail to run on s390x.
|
||||
+ config.unsupported = True
|
||||
+
|
||||
if not ('PowerPC' in config.root.targets):
|
||||
# We need support for PowerPC.
|
||||
config.unsupported = True
|
||||
diff --git a/llvm/test/tools/llvm-exegesis/X86/lit.local.cfg b/llvm/test/tools/llvm-exegesis/X86/lit.local.cfg
|
||||
index 7230f35fdb83..627bba4dc93d 100644
|
||||
--- a/llvm/test/tools/llvm-exegesis/X86/lit.local.cfg
|
||||
+++ b/llvm/test/tools/llvm-exegesis/X86/lit.local.cfg
|
||||
@@ -1,3 +1,7 @@
|
||||
+if 's390x' in config.root.host_triple:
|
||||
+ # These tests fail to run on s390x.
|
||||
+ config.unsupported = True
|
||||
+
|
||||
if not ('X86' in config.root.targets):
|
||||
# We need support for X86.
|
||||
config.unsupported = True
|
24
llvm.spec
24
llvm.spec
|
@ -17,10 +17,10 @@
|
|||
%bcond_with compat_build
|
||||
%bcond_without check
|
||||
|
||||
#global rc_ver 3
|
||||
%global maj_ver 15
|
||||
%global rc_ver 1
|
||||
%global maj_ver 16
|
||||
%global min_ver 0
|
||||
%global patch_ver 7
|
||||
%global patch_ver 0
|
||||
%global llvm_srcdir llvm-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global cmake_srcdir cmake-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global third_party_srcdir third-party-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
@ -75,7 +75,7 @@
|
|||
|
||||
Name: %{pkg_name}
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: The Low Level Virtual Machine
|
||||
|
||||
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
||||
|
@ -93,11 +93,7 @@ Source7: run-lit-tests
|
|||
Source8: lit.fedora.cfg.py
|
||||
%endif
|
||||
|
||||
Patch2: 0003-XFAIL-missing-abstract-variable.ll-test-on-ppc64le.patch
|
||||
|
||||
# Needed to export clang-tblgen during the clang build, needed by the flang docs build.
|
||||
# TODO: Can be dropped for LLVM 16, see https://reviews.llvm.org/D131282.
|
||||
Patch3: 0001-Install-clang-tblgen.patch
|
||||
Patch0: disable-exegesis-tests-s390x.patch
|
||||
|
||||
# See https://reviews.llvm.org/D137890 for the next two patches
|
||||
Patch2: 0001-llvm-Add-install-targets-for-gtest.patch
|
||||
|
@ -215,14 +211,15 @@ LLVM's modified googletest sources.
|
|||
%endif
|
||||
|
||||
%prep
|
||||
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE3}' --data='%{SOURCE2}'
|
||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE3}' --data='%{SOURCE2}'
|
||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE5}' --data='%{SOURCE4}'
|
||||
%setup -T -q -b 2 -n %{cmake_srcdir}
|
||||
# TODO: It would be more elegant to set -DLLVM_COMMON_CMAKE_UTILS=%{_builddir}/%{cmake_srcdir},
|
||||
# but this is not a CACHED variable, so we can't actually set it externally :(
|
||||
cd ..
|
||||
mv %{cmake_srcdir} cmake
|
||||
%setup -T -q -b 3 -n %{third_party_srcdir}
|
||||
%setup -T -q -b 4 -n %{third_party_srcdir}
|
||||
%autopatch -m200 -p2
|
||||
cd ..
|
||||
mv %{third_party_srcdir} third-party
|
||||
|
@ -573,6 +570,9 @@ fi
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Feb 01 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 16.0.0~rc1-1
|
||||
- Update to LLVM 16.0.0 RC1
|
||||
|
||||
* Thu Jan 19 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 15.0.7-3
|
||||
- Update license to SPDX identifiers.
|
||||
- Include the Apache license adopted in 2019.
|
||||
|
|
Loading…
Reference in a new issue