mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-24 17:34:47 +00:00
Fix docs-llvm-man target
This commit is contained in:
parent
4b6a509a38
commit
7a52d8c344
3 changed files with 124 additions and 1 deletions
|
@ -0,0 +1,42 @@
|
|||
From af79e4116c4476153869e1fd4aa30c87d4c7c21e Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Mon, 15 May 2017 09:34:23 +0000
|
||||
Subject: [PATCH] CMake: Fix docs-llvm-man target when clang+llvm is in the
|
||||
same source tree
|
||||
|
||||
Summary:
|
||||
This was broken by r302499. Configuring with -DLLVM_BUILD_DOCS=ON would
|
||||
cause the docs-llvm-man target not to be created.
|
||||
|
||||
Reviewers: anemet, beanz
|
||||
|
||||
Reviewed By: anemet
|
||||
|
||||
Subscribers: llvm-commits, mgorny
|
||||
|
||||
Differential Revision: https://reviews.llvm.org/D33146
|
||||
|
||||
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@303042 91177308-0d34-0410-b5e6-96231b3b80d8
|
||||
---
|
||||
cmake/modules/AddSphinxTarget.cmake | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/cmake/modules/AddSphinxTarget.cmake b/cmake/modules/AddSphinxTarget.cmake
|
||||
index c3a676d..4540c5c 100644
|
||||
--- a/cmake/modules/AddSphinxTarget.cmake
|
||||
+++ b/cmake/modules/AddSphinxTarget.cmake
|
||||
@@ -1,9 +1,9 @@
|
||||
|
||||
# Create sphinx target
|
||||
-if (LLVM_ENABLE_SPHINX AND NOT TARGET sphinx)
|
||||
+if (LLVM_ENABLE_SPHINX)
|
||||
message(STATUS "Sphinx enabled.")
|
||||
find_package(Sphinx REQUIRED)
|
||||
- if (LLVM_BUILD_DOCS)
|
||||
+ if (LLVM_BUILD_DOCS AND NOT TARGET sphinx)
|
||||
add_custom_target(sphinx ALL)
|
||||
endif()
|
||||
else()
|
||||
--
|
||||
1.8.3.1
|
||||
|
|
@ -0,0 +1,76 @@
|
|||
From 9c50cf0c6d8f0b11cd76a28cc4ef9bca6ef732e0 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Tue, 9 May 2017 01:41:28 +0000
|
||||
Subject: [PATCH] Revert "Revert "CMake: Move sphinx detection into
|
||||
AddSphinxTarget.cmake""
|
||||
|
||||
This reverts commit r302054.
|
||||
|
||||
Re-commit now that I have fixes for clang/lld.
|
||||
|
||||
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@302499 91177308-0d34-0410-b5e6-96231b3b80d8
|
||||
---
|
||||
cmake/config-ix.cmake | 10 ----------
|
||||
cmake/modules/AddSphinxTarget.cmake | 13 +++++++++++++
|
||||
docs/CMakeLists.txt | 2 +-
|
||||
3 files changed, 14 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/cmake/config-ix.cmake b/cmake/config-ix.cmake
|
||||
index 0331d0f..de8e9bf 100755
|
||||
--- a/cmake/config-ix.cmake
|
||||
+++ b/cmake/config-ix.cmake
|
||||
@@ -530,16 +530,6 @@ else()
|
||||
message(STATUS "Doxygen disabled.")
|
||||
endif()
|
||||
|
||||
-if (LLVM_ENABLE_SPHINX)
|
||||
- message(STATUS "Sphinx enabled.")
|
||||
- find_package(Sphinx REQUIRED)
|
||||
- if (LLVM_BUILD_DOCS)
|
||||
- add_custom_target(sphinx ALL)
|
||||
- endif()
|
||||
-else()
|
||||
- message(STATUS "Sphinx disabled.")
|
||||
-endif()
|
||||
-
|
||||
set(LLVM_BINDINGS "")
|
||||
if(WIN32)
|
||||
message(STATUS "Go bindings disabled.")
|
||||
diff --git a/cmake/modules/AddSphinxTarget.cmake b/cmake/modules/AddSphinxTarget.cmake
|
||||
index cfc7f38..c3a676d 100644
|
||||
--- a/cmake/modules/AddSphinxTarget.cmake
|
||||
+++ b/cmake/modules/AddSphinxTarget.cmake
|
||||
@@ -1,3 +1,16 @@
|
||||
+
|
||||
+# Create sphinx target
|
||||
+if (LLVM_ENABLE_SPHINX AND NOT TARGET sphinx)
|
||||
+ message(STATUS "Sphinx enabled.")
|
||||
+ find_package(Sphinx REQUIRED)
|
||||
+ if (LLVM_BUILD_DOCS)
|
||||
+ add_custom_target(sphinx ALL)
|
||||
+ endif()
|
||||
+else()
|
||||
+ message(STATUS "Sphinx disabled.")
|
||||
+endif()
|
||||
+
|
||||
+
|
||||
# Handy function for creating the different Sphinx targets.
|
||||
#
|
||||
# ``builder`` should be one of the supported builders used by
|
||||
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
|
||||
index 6dff219..4437610 100644
|
||||
--- a/docs/CMakeLists.txt
|
||||
+++ b/docs/CMakeLists.txt
|
||||
@@ -103,8 +103,8 @@ endif()
|
||||
endif()
|
||||
|
||||
if (LLVM_ENABLE_SPHINX)
|
||||
+ include(AddSphinxTarget)
|
||||
if (SPHINX_FOUND)
|
||||
- include(AddSphinxTarget)
|
||||
if (${SPHINX_OUTPUT_HTML})
|
||||
add_sphinx_target(html llvm)
|
||||
endif()
|
||||
--
|
||||
1.8.3.1
|
||||
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
Name: llvm
|
||||
Version: 4.0.0
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: The Low Level Virtual Machine
|
||||
|
||||
License: NCSA
|
||||
|
@ -19,6 +19,8 @@ Patch0: llvm-3.7.1-cmake-s390.patch
|
|||
Patch1: 0001-CMake-Fix-pthread-handling-for-out-of-tree-builds.patch
|
||||
Patch2: rust-lang-llvm-pr67.patch
|
||||
Patch3: 0001-CMake-Split-static-library-exports-into-their-own-ex.patch
|
||||
Patch4: 0001-Revert-Revert-CMake-Move-sphinx-detection-into-AddSp.patch
|
||||
Patch5: 0001-CMake-Fix-docs-llvm-man-target-when-clang-llvm-is-in.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: zlib-devel
|
||||
|
@ -198,6 +200,9 @@ fi
|
|||
%{_libdir}/cmake/llvm/LLVMStaticExports.cmake
|
||||
|
||||
%changelog
|
||||
* Thu Jun 08 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-5
|
||||
- Fix docs-llvm-man target
|
||||
|
||||
* Mon May 01 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-4
|
||||
- Make cmake files no longer depend on static libs (rhbz 1388200)
|
||||
|
||||
|
|
Loading…
Reference in a new issue