mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-28 18:36:50 +00:00
Merge remote-tracking branch 'origin/rawhide' into upstream-snapshot
By Nikita Popov (5) and others Via Nikita Popov * origin/rawhide: Update to LLVM 15.0.7 Omit frame pointers when building Remove workaround for rbhz#2048440 Enable LTO builds on s390x again Update to LLVM 15.0.6 Install cmake modules for compat builds Copy CFLAGS to ASMFLAGs to enable CET in asm files Update to LLVM 15.0.4
This commit is contained in:
commit
680d93692f
4 changed files with 43 additions and 55 deletions
12
.gitignore
vendored
12
.gitignore
vendored
|
@ -134,3 +134,15 @@
|
|||
/llvm-15.0.0.src.tar.xz.sig
|
||||
/cmake-15.0.0.src.tar.xz
|
||||
/cmake-15.0.0.src.tar.xz.sig
|
||||
/llvm-15.0.4.src.tar.xz
|
||||
/llvm-15.0.4.src.tar.xz.sig
|
||||
/cmake-15.0.4.src.tar.xz
|
||||
/cmake-15.0.4.src.tar.xz.sig
|
||||
/llvm-15.0.6.src.tar.xz
|
||||
/llvm-15.0.6.src.tar.xz.sig
|
||||
/cmake-15.0.6.src.tar.xz
|
||||
/cmake-15.0.6.src.tar.xz.sig
|
||||
/llvm-15.0.7.src.tar.xz
|
||||
/llvm-15.0.7.src.tar.xz.sig
|
||||
/cmake-15.0.7.src.tar.xz
|
||||
/cmake-15.0.7.src.tar.xz.sig
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
From e9e9e7b76d4f22e7c598c42fd4d41fca778c93f1 Mon Sep 17 00:00:00 2001
|
||||
From: Nikita Popov <npopov@redhat.com>
|
||||
Date: Mon, 31 Jan 2022 10:33:27 +0100
|
||||
Subject: [PATCH] Disable CrashRecoveryTest.DumpStackCleanup test on aarch64
|
||||
|
||||
Produces a non-reproducible failure on aarch64:
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=2048440
|
||||
---
|
||||
llvm/unittests/Support/CrashRecoveryTest.cpp | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/llvm/unittests/Support/CrashRecoveryTest.cpp b/llvm/unittests/Support/CrashRecoveryTest.cpp
|
||||
index 9a1f868019ee..266e9159f361 100644
|
||||
--- a/llvm/unittests/Support/CrashRecoveryTest.cpp
|
||||
+++ b/llvm/unittests/Support/CrashRecoveryTest.cpp
|
||||
@@ -76,6 +76,7 @@ TEST(CrashRecoveryTest, Cleanup) {
|
||||
llvm::CrashRecoveryContext::Disable();
|
||||
}
|
||||
|
||||
+#ifndef __aarch64__
|
||||
TEST(CrashRecoveryTest, DumpStackCleanup) {
|
||||
SmallString<128> Filename;
|
||||
std::error_code EC = sys::fs::createTemporaryFile("crash", "test", Filename);
|
||||
@@ -101,6 +102,7 @@ TEST(CrashRecoveryTest, DumpStackCleanup) {
|
||||
EXPECT_EQ(GlobalInt, 1);
|
||||
llvm::CrashRecoveryContext::Disable();
|
||||
}
|
||||
+#endif
|
||||
|
||||
TEST(CrashRecoveryTest, LimitedStackTrace) {
|
||||
// FIXME: Handle "Depth" parameter in PrintStackTrace() function
|
||||
--
|
||||
2.34.3
|
||||
|
44
llvm.spec
44
llvm.spec
|
@ -9,6 +9,10 @@
|
|||
# See https://docs.fedoraproject.org/en-US/packaging-guidelines/#_compiler_macros
|
||||
%global toolchain clang
|
||||
|
||||
# Opt out of https://fedoraproject.org/wiki/Changes/fno-omit-frame-pointer
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2158587
|
||||
%undefine _include_frame_pointers
|
||||
|
||||
# Components enabled if supported by target architecture:
|
||||
%define gold_arches %{ix86} x86_64 %{arm} aarch64 %{power64} s390x
|
||||
%ifarch %{gold_arches}
|
||||
|
@ -23,7 +27,7 @@
|
|||
#global rc_ver 3
|
||||
%global maj_ver 15
|
||||
%global min_ver 0
|
||||
%global patch_ver 4
|
||||
%global patch_ver 7
|
||||
|
||||
%if %{with snapshot_build}
|
||||
%undefine rc_ver
|
||||
|
@ -35,7 +39,7 @@
|
|||
%global llvm_srcdir llvm-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global cmake_srcdir cmake-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global third_party_srcdir third-party-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
%global _lto_cflags -flto=thin
|
||||
|
||||
%if %{with compat_build}
|
||||
%global pkg_name llvm%{maj_ver}
|
||||
|
@ -109,12 +113,10 @@ Source5: run-lit-tests
|
|||
Source6: lit.fedora.cfg.py
|
||||
%endif
|
||||
|
||||
Patch1: 0001-Disable-CrashRecoveryTest.DumpStackCleanup-test-on-a.patch
|
||||
|
||||
# See https://reviews.llvm.org/D137890 for the next two patches
|
||||
Patch2: 0001-llvm-Add-install-targets-for-gtest.patch
|
||||
# Patch2: 0001-llvm-Add-install-targets-for-gtest.patch
|
||||
# Patching third-party dir with a 200 offset in patch number
|
||||
Patch201: 0201-third-party-Add-install-targets-for-gtest.patch
|
||||
# Patch201: 0201-third-party-Add-install-targets-for-gtest.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
|
@ -251,18 +253,14 @@ mv %{third_party_srcdir} third-party
|
|||
|
||||
%build
|
||||
|
||||
%ifarch s390 s390x
|
||||
# Fails with "exceeded PCRE's backtracking limit"
|
||||
%global _lto_cflags %nil
|
||||
%else
|
||||
%global _lto_cflags -flto=thin
|
||||
%endif
|
||||
|
||||
%ifarch s390 s390x %{arm} %ix86
|
||||
# Decrease debuginfo verbosity to reduce memory consumption during final library linking
|
||||
%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
|
||||
%endif
|
||||
|
||||
# Copy CFLAGS into ASMFLAGS, so -fcf-protection is used when compiling assembly files.
|
||||
export ASMFLAGS=$CFLAGS
|
||||
|
||||
# force off shared libs as cmake macros turns it on.
|
||||
%cmake -G Ninja \
|
||||
-DBUILD_SHARED_LIBS:BOOL=OFF \
|
||||
|
@ -450,10 +448,7 @@ rm %{buildroot}%{_bindir}/llvm-config%{exec_suffix}
|
|||
# ghost presence
|
||||
touch %{buildroot}%{_bindir}/llvm-config%{exec_suffix}
|
||||
|
||||
%if %{without compat_build}
|
||||
cp -Rv ../cmake/Modules/* %{buildroot}%{_libdir}/cmake/llvm
|
||||
%endif
|
||||
|
||||
cp -Rv ../cmake/Modules/* %{buildroot}%{pkg_libdir}/cmake/llvm
|
||||
|
||||
%check
|
||||
# Disable check section on arm due to some kind of memory related failure.
|
||||
|
@ -594,6 +589,21 @@ fi
|
|||
%changelog
|
||||
%{?llvm_snapshot_changelog_entry}
|
||||
|
||||
* Thu Jan 12 2023 Nikita Popov <npopov@redhat.com> - 15.0.7-1
|
||||
- Update to LLVM 15.0.7
|
||||
|
||||
* Mon Jan 09 2023 Tom Stellard <tstellar@redhat.com> - 15.0.6-3
|
||||
- Omit frame pointers when building
|
||||
|
||||
* Mon Dec 19 2022 Nikita Popov <npopov@redhat.com> - 15.0.6-2
|
||||
- Remove workaround for rbhz#2048440
|
||||
|
||||
* Mon Dec 05 2022 Nikita Popov <npopov@redhat.com> - 15.0.6-1
|
||||
- Update to LLVM 15.0.6
|
||||
|
||||
* Fri Nov 11 2022 Nikita Popov <npopov@redhat.com> - 15.0.4-2
|
||||
- Copy CFLAGS to ASMFLAGs to enable CET in asm files
|
||||
|
||||
* Wed Nov 02 2022 Nikita Popov <npopov@redhat.com> - 15.0.4-1
|
||||
- Update to LLVM 15.0.4
|
||||
|
||||
|
|
8
sources
8
sources
|
@ -1,4 +1,4 @@
|
|||
SHA512 (llvm-15.0.0.src.tar.xz) = 323e6a7940f47dee11dae7b80ea25451080f2d84a6c4ca47d5a20d796efc6dbaec2036b968fdef34f1167fbeb10825d06ec7eb366854bf925f89a2ac13a05aa4
|
||||
SHA512 (llvm-15.0.0.src.tar.xz.sig) = bb2ea08b94fca1b6fde6b6d95db97cf41ada674e3044b3de395d3e249b602dde1b8f9b75aa1c6f5c32e87e0ea6645d51eeeae1febff99cb8c6c44ba6c88e5655
|
||||
SHA512 (cmake-15.0.0.src.tar.xz) = e8bcc349ff8311f7d5530b2654434b66560a85cad7c46b707b8a484963cba44894a5565adbaa4b892225a03b74b63b5f54491c11489975db5bcdeac5eea12841
|
||||
SHA512 (cmake-15.0.0.src.tar.xz.sig) = f2f0a60deb01c4555ef6bbcfdd712d5478cbbc3a6b96c0d306042451110dbac799ac780229fc46de2faef069ebccdda47d635a4e17290c29b9d8616fcbc11c98
|
||||
SHA512 (llvm-15.0.7.src.tar.xz) = ed8d565515b1bc6164e4ff06d3388ba92e332850305496fd65db9adf1ec87bd9dd1bfde49dd41be5d5216289efc72bfd287cd7392f2bba80b740d4c314c749e5
|
||||
SHA512 (llvm-15.0.7.src.tar.xz.sig) = 79fc82dfabe397f7df4c139f75fa9a0a34c92b77d603543a4eb3e579e253a9d84d0e8314f7356ed77326977d6190997b42f074a6c910d0f932e6b21d09374bde
|
||||
SHA512 (cmake-15.0.7.src.tar.xz) = 85097a6eaee0df004567905f7e5ce8ca02e3b46c6fc66fa552fe99734642e6ee61685de4e5e6e8b505963334d7b91d98ecd9c5870e6bdd3f0018ee5b963ffa96
|
||||
SHA512 (cmake-15.0.7.src.tar.xz.sig) = 61d53c602bcb099426b8828a239628ba2fca9616afcdf67ce3c8c887146dce99a649ddb625df096e3d8aa9ede1ea9bb6933f88f3adec0192fd68faeca2488a1a
|
||||
|
|
Loading…
Reference in a new issue