mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-24 09:32:42 +00:00
11.1.0-rc1 release
This commit is contained in:
parent
11cea8ec0d
commit
4799046978
4 changed files with 40 additions and 10 deletions
2
.gitignore
vendored
2
.gitignore
vendored
|
@ -86,3 +86,5 @@
|
|||
/llvm-11.0.1rc2.src.tar.xz
|
||||
/llvm-11.0.1.src.tar.xz
|
||||
/llvm-11.0.1.src.tar.xz.sig
|
||||
/llvm-11.1.0rc1.src.tar.xz.sig
|
||||
/llvm-11.1.0rc1.src.tar.xz
|
||||
|
|
25
builtin_mul_overflow.patch
Normal file
25
builtin_mul_overflow.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
diff --git a/llvm/lib/Transforms/Scalar/LoopStrengthReduce.cpp b/llvm/lib/Transforms/Scalar/LoopStrengthReduce.cpp
|
||||
index cf02ef1e83f3..e370f8c34809 100644
|
||||
--- a/llvm/lib/Transforms/Scalar/LoopStrengthReduce.cpp
|
||||
+++ b/llvm/lib/Transforms/Scalar/LoopStrengthReduce.cpp
|
||||
@@ -3885,8 +3885,8 @@ void LSRInstance::GenerateICmpZeroScales(LSRUse &LU, unsigned LUIdx,
|
||||
// Check that the multiplication doesn't overflow.
|
||||
if (Base.BaseOffset == std::numeric_limits<int64_t>::min() && Factor == -1)
|
||||
continue;
|
||||
- int64_t NewBaseOffset = (uint64_t)Base.BaseOffset * Factor;
|
||||
- if (NewBaseOffset / Factor != Base.BaseOffset)
|
||||
+ int64_t NewBaseOffset;
|
||||
+ if(__builtin_mul_overflow(Base.BaseOffset, Factor, &NewBaseOffset))
|
||||
continue;
|
||||
// If the offset will be truncated at this use, check that it is in bounds.
|
||||
if (!IntTy->isPointerTy() &&
|
||||
@@ -3897,8 +3897,7 @@ void LSRInstance::GenerateICmpZeroScales(LSRUse &LU, unsigned LUIdx,
|
||||
int64_t Offset = LU.MinOffset;
|
||||
if (Offset == std::numeric_limits<int64_t>::min() && Factor == -1)
|
||||
continue;
|
||||
- Offset = (uint64_t)Offset * Factor;
|
||||
- if (Offset / Factor != LU.MinOffset)
|
||||
+ if(__builtin_mul_overflow(Offset, Factor, &Offset))
|
||||
continue;
|
||||
// If the offset will be truncated at this use, check that it is in bounds.
|
||||
if (!IntTy->isPointerTy() &&
|
19
llvm.spec
19
llvm.spec
|
@ -10,12 +10,12 @@
|
|||
|
||||
%global llvm_libdir %{_libdir}/%{name}
|
||||
%global build_llvm_libdir %{buildroot}%{llvm_libdir}
|
||||
#%%global rc_ver 2
|
||||
%global baserelease 4
|
||||
%global rc_ver 1
|
||||
%global baserelease 1
|
||||
%global llvm_srcdir llvm-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global maj_ver 11
|
||||
%global min_ver 0
|
||||
%global patch_ver 1
|
||||
%global min_ver 1
|
||||
%global patch_ver 0
|
||||
|
||||
%if %{with compat_build}
|
||||
%global pkg_name llvm%{maj_ver}.%{min_ver}
|
||||
|
@ -39,7 +39,7 @@
|
|||
|
||||
Name: %{pkg_name}
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||
Release: %{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||
Release: %{?rc_ver:0.}%{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||
Summary: The Low Level Virtual Machine
|
||||
|
||||
License: NCSA
|
||||
|
@ -56,7 +56,10 @@ Source4: lit.fedora.cfg.py
|
|||
# Fix coreos-installer test crash on s390x (rhbz#1883457), https://reviews.llvm.org/D89034
|
||||
Patch1: 0001-SystemZ-Use-LA-instead-of-AGR-in-eliminateFrameIndex.patch
|
||||
|
||||
Patch2: 0001-gcc11.patch
|
||||
Patch2: 0001-gcc11.patch
|
||||
|
||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=1916576
|
||||
Patch3: builtin_mul_overflow.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
|
@ -539,8 +542,8 @@ fi
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jan 06 2021 Serge Guelton - 11.0.1-4
|
||||
- LLVM 11.0.1 final
|
||||
* Thu Jan 14 2021 Serge Guelton - 11.1.0-0.1.rc1
|
||||
- 11.1.0-rc1 release
|
||||
|
||||
* Tue Jan 05 2021 Serge Guelton - 11.0.1-3.rc2
|
||||
- Waive extra test case
|
||||
|
|
4
sources
4
sources
|
@ -1,2 +1,2 @@
|
|||
SHA512 (llvm-11.0.1.src.tar.xz) = b42c67ef88e09dd94171f85cdf49a421a15cfc82ff715c7ce6de22f98cefbe6c7cdf6bf4af7ca017d56ecf6aa3e36df3d823a78cf2dd5312de4301b54b43dbe8
|
||||
SHA512 (llvm-11.0.1.src.tar.xz.sig) = f61797b7d666c99f2f233c73b7c1913aaf863dc25aaa74edf82f7ac56479be67a86739a089d542b8b05fa7a836cd1a4165699fefabb392b396be477d498d34b0
|
||||
SHA512 (llvm-11.1.0rc1.src.tar.xz.sig) = 6151f7562129ba25247dcf7276774e42e10e528103650bc3c161881231a3465bbb93d1ccfe588c6eb6e11adb0f313c78a4f98665f09491e1d1d0b2a1098e3681
|
||||
SHA512 (llvm-11.1.0rc1.src.tar.xz) = 104d4e72d9422dab9e5da02ca3d8e3761c71d20a222db2966448c3c5190d2325fc1e46f44db970d513e86857f6d7805306ecf29fd394d7171043f8adf7a389f7
|
||||
|
|
Loading…
Reference in a new issue