mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-24 17:34:47 +00:00
Backport r351577 from trunk to fix ninja check failures
This commit is contained in:
parent
d7ccaa55e9
commit
216e1c9691
2 changed files with 41 additions and 2 deletions
29
0001-Fix-the-buildbot-issue-introduced-by-r351421.patch
Normal file
29
0001-Fix-the-buildbot-issue-introduced-by-r351421.patch
Normal file
|
@ -0,0 +1,29 @@
|
|||
From eaa421d1f9c3748c550e2a91fcb134a3d2a8ebff Mon Sep 17 00:00:00 2001
|
||||
From: Sanjin Sijaric <ssijaric@codeaurora.org>
|
||||
Date: Fri, 18 Jan 2019 19:34:20 +0000
|
||||
Subject: [PATCH] Fix the buildbot issue introduced by r351421
|
||||
|
||||
The EXPENSIVE_CHECK x86_64 Windows buildbot is failing due to this change. Fix
|
||||
the map access.
|
||||
|
||||
llvm-svn: 351577
|
||||
---
|
||||
lib/MC/MCWin64EH.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/MC/MCWin64EH.cpp b/lib/MC/MCWin64EH.cpp
|
||||
index 8bc1f08..3ef1514 100644
|
||||
--- a/lib/MC/MCWin64EH.cpp
|
||||
+++ b/lib/MC/MCWin64EH.cpp
|
||||
@@ -522,7 +522,7 @@ static void ARM64EmitUnwindInfo(MCStreamer &streamer, WinEH::FrameInfo *info) {
|
||||
if (MatchingEpilog) {
|
||||
assert(EpilogInfo.find(MatchingEpilog) != EpilogInfo.end() &&
|
||||
"Duplicate epilog not found");
|
||||
- EpilogInfo[EpilogStart] = EpilogInfo[MatchingEpilog];
|
||||
+ EpilogInfo[EpilogStart] = EpilogInfo.lookup(MatchingEpilog);
|
||||
// Clear the unwind codes in the EpilogMap, so that they don't get output
|
||||
// in the logic below.
|
||||
EpilogInstrs.clear();
|
||||
--
|
||||
1.8.3.1
|
||||
|
14
llvm.spec
14
llvm.spec
|
@ -40,7 +40,7 @@
|
|||
|
||||
Name: %{pkg_name}
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||
Release: 3%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||
Release: 4%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||
Summary: The Low Level Virtual Machine
|
||||
|
||||
License: NCSA
|
||||
|
@ -51,6 +51,7 @@ Source2: lit.fedora.cfg.py
|
|||
|
||||
Patch5: 0001-PATCH-llvm-config.patch
|
||||
Patch7: 0001-PATCH-Filter-out-cxxflags-not-supported-by-clang.patch
|
||||
Patch8: 0001-Fix-the-buildbot-issue-introduced-by-r351421.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
|
@ -340,8 +341,14 @@ rm -Rf %{build_install_prefix}/share/opt-viewer
|
|||
%check
|
||||
# We have disabled rpath, so we need to add the build's library directory
|
||||
# to LD_LIBRARY_PATH.
|
||||
# TODO: Fix test failures on arm
|
||||
LD_LIBRARY_PATH=`pwd`/_build/%{_lib}:$LD_LIBRARY_PATH \
|
||||
ninja check-all -C _build || :
|
||||
ninja check-all -C _build || \
|
||||
%ifarch %{arm}
|
||||
:
|
||||
%else
|
||||
false
|
||||
%endif
|
||||
|
||||
%ldconfig_scriptlets libs
|
||||
|
||||
|
@ -454,6 +461,9 @@ fi
|
|||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Mar 27 2019 Tom Stellard <tstellar@redhat.com> - 8.0.0-4
|
||||
- Backport r351577 from trunk to fix ninja check failures
|
||||
|
||||
* Tue Mar 26 2019 Tom Stellard <tstellar@redhat.com> - 8.0.0-3
|
||||
- Fix ninja check
|
||||
|
||||
|
|
Loading…
Reference in a new issue