Patch renewal from rebased llvm-project pagure/streamline branch

This commit is contained in:
Konrad Kleine 2022-09-06 11:55:02 +02:00 committed by Timm Bäder
parent ac7a6d72a5
commit 2112e4bb81
2 changed files with 81 additions and 5 deletions

View file

@ -1,8 +1,8 @@
From 7242925230776388c70b5bdf7e80aba92a9002c3 Mon Sep 17 00:00:00 2001 From 03802b450aee4465471835e745086a126822bdf3 Mon Sep 17 00:00:00 2001
From: Konrad Kleine <kkleine@redhat.com> From: Konrad Kleine <kkleine@redhat.com>
Date: Tue, 27 Apr 2021 14:41:57 +0200 Date: Tue, 27 Apr 2021 14:41:57 +0200
Subject: [PATCH] Make source-interleave-prefix test case compatible with Subject: [PATCH 1/4] [PATCH] Make source-interleave-prefix test case
llvm-test compatible with llvm-test
llvm-test runs test from a directory that's not the upstream one, and that leads llvm-test runs test from a directory that's not the upstream one, and that leads
to some false positive. Workaround this by forcing the current working to some false positive. Workaround this by forcing the current working
@ -12,7 +12,7 @@ directory.
1 file changed, 1 insertion(+), 1 deletion(-) 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/llvm/test/tools/llvm-objdump/X86/source-interleave-prefix.test b/llvm/test/tools/llvm-objdump/X86/source-interleave-prefix.test diff --git a/llvm/test/tools/llvm-objdump/X86/source-interleave-prefix.test b/llvm/test/tools/llvm-objdump/X86/source-interleave-prefix.test
index 746add22..8b28b87 100644 index 746add22f96e..8b28b877e372 100644
--- a/llvm/test/tools/llvm-objdump/X86/source-interleave-prefix.test --- a/llvm/test/tools/llvm-objdump/X86/source-interleave-prefix.test
+++ b/llvm/test/tools/llvm-objdump/X86/source-interleave-prefix.test +++ b/llvm/test/tools/llvm-objdump/X86/source-interleave-prefix.test
@@ -11,7 +11,7 @@ @@ -11,7 +11,7 @@
@ -25,5 +25,5 @@ index 746add22..8b28b87 100644
; CHECK-BROKEN-PREFIX: warning: '[[FILE]]': failed to find source [[PREFIX]][[COMPDIR]]{{[/\\]}}source-interleave-x86_64.c ; CHECK-BROKEN-PREFIX: warning: '[[FILE]]': failed to find source [[PREFIX]][[COMPDIR]]{{[/\\]}}source-interleave-x86_64.c
-- --
1.8.3.1 2.37.1

View file

@ -0,0 +1,76 @@
From 1ac2fb3bc5bc471e9c3af0abbba4a0942ca14948 Mon Sep 17 00:00:00 2001
From: Konrad Kleine <kkleine@redhat.com>
Date: Wed, 16 Feb 2022 22:03:40 +0100
Subject: [PATCH 4/4] [PATCH] Revert "cmake: Don't install plugins used for
examples or tests"
This reverts commit d0a767608773cfa3d8644c27796b63ff40962806.
By reverting this we fix these errors:
CMake Error at /usr/lib64/cmake/llvm/AddLLVM.cmake:1821 (add_dependencies):
The dependency target "LLVMHello" of target "check-all" does not exist.
Call Stack (most recent call first):
CMakeLists.txt:578 (add_lit_target)
CMake Error at /usr/lib64/cmake/llvm/AddLLVM.cmake:1821 (add_dependencies):
The dependency target "LLVMHello" of target "check-clang-tools" does not
exist.
Call Stack (most recent call first):
/usr/lib64/cmake/llvm/AddLLVM.cmake:1842 (add_lit_target)
/builddir/build/BUILD/clang-tools-extra-15.0.0.src/test/CMakeLists.txt:110 (add_lit_testsuite)
CMake Error at /usr/lib64/cmake/llvm/AddLLVM.cmake:1821 (add_dependencies):
The dependency target "LLVMHello" of target "check-clang-extra-unit" does
not exist.
Call Stack (most recent call first):
/usr/lib64/cmake/llvm/AddLLVM.cmake:1877 (add_lit_target)
/builddir/build/BUILD/clang-tools-extra-15.0.0.src/test/CMakeLists.txt:118 (add_lit_testsuites)
---
llvm/lib/Transforms/Hello/CMakeLists.txt | 2 +-
llvm/tools/bugpoint-passes/CMakeLists.txt | 2 +-
llvm/unittests/Passes/CMakeLists.txt | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/llvm/lib/Transforms/Hello/CMakeLists.txt b/llvm/lib/Transforms/Hello/CMakeLists.txt
index c4f10247c1a6..d9cd33a4938e 100644
--- a/llvm/lib/Transforms/Hello/CMakeLists.txt
+++ b/llvm/lib/Transforms/Hello/CMakeLists.txt
@@ -10,7 +10,7 @@ if(WIN32 OR CYGWIN)
set(LLVM_LINK_COMPONENTS Core Support)
endif()
-add_llvm_library( LLVMHello MODULE BUILDTREE_ONLY
+add_llvm_library( LLVMHello MODULE
Hello.cpp
DEPENDS
diff --git a/llvm/tools/bugpoint-passes/CMakeLists.txt b/llvm/tools/bugpoint-passes/CMakeLists.txt
index eea3e239b808..56a7eacebf1a 100644
--- a/llvm/tools/bugpoint-passes/CMakeLists.txt
+++ b/llvm/tools/bugpoint-passes/CMakeLists.txt
@@ -14,7 +14,7 @@ if(WIN32 OR CYGWIN)
set(LLVM_LINK_COMPONENTS Core)
endif()
-add_llvm_library( BugpointPasses MODULE BUILDTREE_ONLY
+add_llvm_library( BugpointPasses MODULE
TestPasses.cpp
DEPENDS
diff --git a/llvm/unittests/Passes/CMakeLists.txt b/llvm/unittests/Passes/CMakeLists.txt
index a5683cd3741f..82553a3a6e56 100644
--- a/llvm/unittests/Passes/CMakeLists.txt
+++ b/llvm/unittests/Passes/CMakeLists.txt
@@ -26,7 +26,7 @@ if (NOT WIN32)
set(LLVM_LINK_COMPONENTS)
foreach(PLUGIN TestPlugin DoublerPlugin)
- add_llvm_library(${PLUGIN} MODULE BUILDTREE_ONLY ${PLUGIN}.cpp)
+ add_llvm_library(${PLUGIN} MODULE ${PLUGIN}.cpp)
# Put PLUGIN next to the unit test executable.
set_output_directory(${PLUGIN}
--
2.37.1