mirror of
https://src.fedoraproject.org/rpms/llvm.git
synced 2024-11-24 09:32:42 +00:00
parent
6a92d8567c
commit
0b3c1fca1c
2 changed files with 19 additions and 0 deletions
16
lldb-python-module-symlink.patch
Normal file
16
lldb-python-module-symlink.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
Fix broken symlink to Python's lldb module
|
||||
|
||||
Resolves: #1177143
|
||||
|
||||
diff -rupN lldb-3.5.0.src/scripts/Python/finish-swig-Python-LLDB.sh lldb-3.5.0.src-new/scripts/Python/finish-swig-Python-LLDB.sh
|
||||
--- lldb-3.5.0.src/scripts/Python/finish-swig-Python-LLDB.sh 2014-07-01 19:57:19.000000000 +0200
|
||||
+++ lldb-3.5.0.src-new/scripts/Python/finish-swig-Python-LLDB.sh 2014-12-24 14:18:10.068604693 +0100
|
||||
@@ -158,7 +158,7 @@ then
|
||||
then
|
||||
ln -s "../../../LLDB" _lldb.so
|
||||
else
|
||||
- ln -s "../../../liblldb${SOEXT}" _lldb.so
|
||||
+ ln -s "../../../llvm/liblldb${SOEXT}" _lldb.so
|
||||
fi
|
||||
else
|
||||
if [ $Debug -eq 1 ]
|
|
@ -75,6 +75,7 @@ Patch100: clang-fake-gcc43.patch
|
|||
|
||||
Patch200: lldb-python.patch
|
||||
Patch201: lldb-fix-expression-parser.patch
|
||||
Patch202: lldb-python-module-symlink.patch
|
||||
|
||||
BuildRequires: bison
|
||||
BuildRequires: chrpath
|
||||
|
@ -335,6 +336,7 @@ pushd tools/lldb
|
|||
# careful when recreating this patch...
|
||||
%patch200 -p1 -b .python
|
||||
%patch201 -p2
|
||||
%patch202 -p1
|
||||
sed -i s/@lib@/%{_lib}/g scripts/Python/modules/readline/Makefile
|
||||
popd
|
||||
%endif
|
||||
|
@ -696,6 +698,7 @@ exit 0
|
|||
%changelog
|
||||
* Thu Dec 25 2014 Jan Vcelak <jvcelak@fedoraproject.org> 3.5.0-6
|
||||
- lldb: fix broken expression parser
|
||||
- lldb, python module: fix symlink to lldb.so (#1177143)
|
||||
|
||||
* Thu Dec 18 2014 Dan Horák <dan[at]danny.cz> - 3.5.0-5
|
||||
- use the common workaround for OOM during linking on s390
|
||||
|
|
Loading…
Reference in a new issue