mirror of
https://src.fedoraproject.org/rpms/libomp.git
synced 2024-12-01 10:10:01 +00:00
Merge remote-tracking branch 'origin/rawhide' into upstream-snapshot
By Nikita Popov (10) and others Via Tulio Magno Quites Machado Filho * origin/rawhide: (21 commits) Mention the Apache 2.0 license Omit frame pointers when building Fix build against GCC 13 Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild Update to LLVM 15.0.7 Update to LLVM 15.0.6 Update to LLVM 15.0.4 Migrate tests to tests/libomp repo Re-enable LTO build Add explicit requires from libomp-devel to libomp Update to LLVM 15.0.0 Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild Update to 14.0.5 tests: add llvm-toolset-14.0 requirements to tests and plans Upload new sources Update to 14.0.0 Fix rpmlint warnings Update to LLVM 13.0.1 final Update to LLVM 13.0.1rc3 - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild ...
This commit is contained in:
commit
1504fdbdf9
9 changed files with 257 additions and 71 deletions
18
.gitignore
vendored
18
.gitignore
vendored
|
@ -81,3 +81,21 @@
|
|||
/openmp-13.0.0.src.tar.xz.sig
|
||||
/openmp-13.0.1rc1.src.tar.xz
|
||||
/openmp-13.0.1rc1.src.tar.xz.sig
|
||||
/openmp-13.0.1rc2.src.tar.xz
|
||||
/openmp-13.0.1rc2.src.tar.xz.sig
|
||||
/openmp-13.0.1rc3.src.tar.xz
|
||||
/openmp-13.0.1rc3.src.tar.xz.sig
|
||||
/openmp-13.0.1.src.tar.xz
|
||||
/openmp-13.0.1.src.tar.xz.sig
|
||||
/openmp-14.0.0.src.tar.xz
|
||||
/openmp-14.0.0.src.tar.xz.sig
|
||||
/openmp-14.0.5.src.tar.xz
|
||||
/openmp-14.0.5.src.tar.xz.sig
|
||||
/openmp-15.0.0.src.tar.xz
|
||||
/openmp-15.0.0.src.tar.xz.sig
|
||||
/openmp-15.0.4.src.tar.xz
|
||||
/openmp-15.0.4.src.tar.xz.sig
|
||||
/openmp-15.0.6.src.tar.xz
|
||||
/openmp-15.0.6.src.tar.xz.sig
|
||||
/openmp-15.0.7.src.tar.xz
|
||||
/openmp-15.0.7.src.tar.xz.sig
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
From ea1d061830e371a917b9bcfa87e9b3a8296bf366 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Tue, 16 May 2017 11:52:19 -0400
|
||||
Subject: [PATCH][openmp] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a cache
|
||||
variable when bulding standalone
|
||||
|
||||
This way it can be overriden on the command line.
|
||||
---
|
||||
openmp/runtime/src/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt
|
||||
index 27e748c4d6dc..6d5bcb6376d2 100644
|
||||
--- a/openmp/runtime/src/CMakeLists.txt
|
||||
+++ b/openmp/runtime/src/CMakeLists.txt
|
||||
@@ -346,7 +346,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
||||
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
|
||||
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
|
||||
if(${OPENMP_STANDALONE_BUILD})
|
||||
- set(LIBOMP_HEADERS_INSTALL_PATH "${CMAKE_INSTALL_INCLUDEDIR}")
|
||||
+ set(LIBOMP_HEADERS_INSTALL_PATH "${CMAKE_INSTALL_INCLUDEDIR}" CACHE PATH "Install path for OpenMP headers")
|
||||
else()
|
||||
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
|
||||
set(LIBOMP_HEADERS_INSTALL_PATH "${OPENMP_INSTALL_LIBDIR}/clang/${CLANG_VERSION}/include")
|
||||
--
|
||||
2.33.1
|
||||
|
26
0001-libomp-Explicitly-include-string-header-NFC.patch
Normal file
26
0001-libomp-Explicitly-include-string-header-NFC.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From f2ddf903f588021507faefec15d360edb1e425e5 Mon Sep 17 00:00:00 2001
|
||||
From: Nikita Popov <npopov@redhat.com>
|
||||
Date: Fri, 20 Jan 2023 10:11:01 +0100
|
||||
Subject: [PATCH] [libomp] Explicitly include <string> header (NFC)
|
||||
|
||||
This is required to build against libstdc++ 13. Debug.h uses
|
||||
std::stoi() from <string> without explicitly including it.
|
||||
---
|
||||
openmp/libomptarget/include/Debug.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/openmp/libomptarget/include/Debug.h b/openmp/libomptarget/include/Debug.h
|
||||
index 4e7da8b7d53f..387dfe50659e 100644
|
||||
--- a/openmp/libomptarget/include/Debug.h
|
||||
+++ b/openmp/libomptarget/include/Debug.h
|
||||
@@ -39,6 +39,7 @@
|
||||
|
||||
#include <atomic>
|
||||
#include <mutex>
|
||||
+#include <string>
|
||||
|
||||
/// 32-Bit field data attributes controlling information presented to the user.
|
||||
enum OpenMPInfoType : uint32_t {
|
||||
--
|
||||
2.39.0
|
||||
|
131
libomp.spec
131
libomp.spec
|
@ -2,23 +2,26 @@
|
|||
|
||||
%if %{with snapshot_build}
|
||||
# Unlock LLVM Snapshot LUA functions
|
||||
%{llvm_sb_verbose}
|
||||
%{llvm_sb}
|
||||
%endif
|
||||
|
||||
%global libomp_version 13.0.1
|
||||
%global rc_ver 1
|
||||
%global libomp_srcdir openmp-%{libomp_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
%if %{with snapshot_build}
|
||||
%undefine rc_ver
|
||||
%global libomp_srcdir openmp-%{llvm_snapshot_version_major}.%{llvm_snapshot_version_minor}.%{llvm_snapshot_version_patch}.src
|
||||
%global maj_ver %{llvm_snapshot_version_major}
|
||||
%global min_ver %{llvm_snapshot_version_minor}
|
||||
%global patch_ver %{llvm_snapshot_version_patch}
|
||||
%global libomp_version %{llvm_snapshot_version_major}.%{llvm_snapshot_version_minor}.%{llvm_snapshot_version_patch}
|
||||
%global libomp_version %{llvm_snapshot_version}
|
||||
%else
|
||||
%global maj_ver 15
|
||||
%global libomp_version %{maj_ver}.0.7
|
||||
#global rc_ver 3
|
||||
%endif
|
||||
|
||||
%global toolchain clang
|
||||
|
||||
# Opt out of https://fedoraproject.org/wiki/Changes/fno-omit-frame-pointer
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2158587
|
||||
%undefine _include_frame_pointers
|
||||
|
||||
%global libomp_srcdir openmp-%{libomp_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
%ifarch ppc64le
|
||||
%global libomp_arch ppc64
|
||||
%else
|
||||
|
@ -30,7 +33,7 @@ Version: %{libomp_version}%{?rc_ver:~rc%{rc_ver}}%{?llvm_snapshot_version_suffix
|
|||
Release: 1%{?dist}
|
||||
Summary: OpenMP runtime for clang
|
||||
|
||||
License: NCSA
|
||||
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
||||
URL: http://openmp.llvm.org
|
||||
%if %{with snapshot_build}
|
||||
Source0: %{llvm_snapshot_source_prefix}openmp-%{llvm_snapshot_yyyymmdd}.src.tar.xz
|
||||
|
@ -39,15 +42,16 @@ Source0: %{llvm_snapshot_source_prefix}openmp-%{llvm_snapshot_yyyymmdd}.src.tar.
|
|||
%if %{without snapshot_build}
|
||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{libomp_version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz
|
||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{libomp_version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz.sig
|
||||
Source2: tstellar-gpg-key.asc
|
||||
%endif
|
||||
Source2: release-keys.asc
|
||||
Source3: run-lit-tests
|
||||
Source4: lit.fedora.cfg.py
|
||||
|
||||
Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
|
||||
# TODO: Not needed with LLVM 16.
|
||||
Patch1: 0001-libomp-Explicitly-include-string-header-NFC.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: clang
|
||||
# For clang-offload-packager
|
||||
BuildRequires: clang-tools-extra
|
||||
BuildRequires: cmake
|
||||
BuildRequires: ninja-build
|
||||
BuildRequires: elfutils-libelf-devel
|
||||
|
@ -59,10 +63,6 @@ BuildRequires: libffi-devel
|
|||
# For gpg source verification
|
||||
BuildRequires: gnupg2
|
||||
|
||||
# The AMDGCN device RTL requires clang and llvm-link to build
|
||||
BuildRequires: clang
|
||||
BuildRequires: llvm
|
||||
|
||||
# libomptarget needs the llvm cmake files
|
||||
BuildRequires: llvm-devel
|
||||
|
||||
|
@ -76,6 +76,7 @@ OpenMP runtime for clang.
|
|||
|
||||
%package devel
|
||||
Summary: OpenMP header files
|
||||
Requires: %{name}%{?isa} = %{version}-%{release}
|
||||
Requires: clang-resource-filesystem%{?isa} = %{version}
|
||||
|
||||
%description devel
|
||||
|
@ -87,8 +88,6 @@ Requires: %{name}%{?isa} = %{version}-%{release}
|
|||
Requires: %{name}-devel%{?isa} = %{version}-%{release}
|
||||
Requires: clang
|
||||
Requires: llvm
|
||||
Requires: gcc
|
||||
Requires: gcc-c++
|
||||
Requires: python3-lit
|
||||
|
||||
%description test
|
||||
|
@ -101,18 +100,12 @@ OpenMP regression tests
|
|||
%autosetup -n %{libomp_srcdir} -p2
|
||||
|
||||
%build
|
||||
# LTO causes build failures in this package. Disable LTO for now
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1988155
|
||||
%define _lto_cflags %{nil}
|
||||
|
||||
# Test if we can default DWARF4 instead of 5
|
||||
%global optflags %(echo %{optflags} " -gdwarf-4 ")
|
||||
|
||||
|
||||
%cmake -GNinja \
|
||||
%cmake -GNinja \
|
||||
-DLIBOMP_INSTALL_ALIASES=OFF \
|
||||
-DCMAKE_MODULE_PATH=%{_libdir}/cmake/llvm \
|
||||
-DLLVM_DIR=%{_libdir}/cmake/llvm \
|
||||
-DLIBOMP_HEADERS_INSTALL_PATH:PATH=%{_libdir}/clang/%{libomp_version}/include \
|
||||
-DCMAKE_INSTALL_INCLUDEDIR=%{_libdir}/clang/%{libomp_version}/include \
|
||||
%if 0%{?__isa_bits} == 64
|
||||
-DOPENMP_LIBDIR_SUFFIX=64 \
|
||||
%else
|
||||
|
@ -173,11 +166,11 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
|||
%{_libdir}/libomptarget-nvptx-*.bc
|
||||
%endif
|
||||
%ifnarch %{ix86} %{arm}
|
||||
%{_libdir}/libomptarget.rtl.amdgpu.so
|
||||
%{_libdir}/libomptarget.rtl.cuda.so
|
||||
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so
|
||||
%{_libdir}/libomptarget.rtl.amdgpu.so.%{maj_ver}
|
||||
%{_libdir}/libomptarget.rtl.cuda.so.%{maj_ver}
|
||||
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so.%{maj_ver}
|
||||
%endif
|
||||
%{_libdir}/libomptarget.so
|
||||
%{_libdir}/libomptarget.so.%{maj_ver}
|
||||
|
||||
%files devel
|
||||
%{_libdir}/clang/%{libomp_version}/include/omp.h
|
||||
|
@ -185,10 +178,17 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
|||
%ifnarch %{arm}
|
||||
%{_libdir}/clang/%{libomp_version}/include/omp-tools.h
|
||||
%{_libdir}/clang/%{libomp_version}/include/ompt.h
|
||||
# FIXME: This is probably wrong. Seems like LIBOMP_HEADERS_INSTALL may
|
||||
# not be respected.
|
||||
%{_includedir}/ompt-multiplex.h
|
||||
%{_libdir}/clang/%{libomp_version}/include/ompt-multiplex.h
|
||||
%endif
|
||||
%ifnarch %{ix86} %{arm}
|
||||
%{_libdir}/libomptarget.rtl.amdgpu.so
|
||||
%{_libdir}/libomptarget.rtl.cuda.so
|
||||
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so
|
||||
%{_libdir}/libomptarget.devicertl.a
|
||||
%{_libdir}/libomptarget-amdgpu-*.bc
|
||||
%{_libdir}/libomptarget-nvptx-*.bc
|
||||
%endif
|
||||
%{_libdir}/libomptarget.so
|
||||
|
||||
%files test
|
||||
%{_datadir}/libomp
|
||||
|
@ -197,6 +197,57 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
|||
%changelog
|
||||
%{?llvm_snapshot_changelog_entry}
|
||||
|
||||
* Tue Jan 31 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 15.0.7-5
|
||||
- Include the Apache license adopted in 2019.
|
||||
|
||||
* Fri Jan 20 2023 Tom Stellard <tstellar@redhat.com> - 15.0.7-4
|
||||
- Omit frame pointers when building
|
||||
|
||||
* Fri Jan 20 2023 Nikita Popov <npopov@redhat.com> - 15.0.7-3
|
||||
- Fix build against GCC 13
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 15.0.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2023 Nikita Popov <npopov@redhat.com> - 15.0.7-1
|
||||
- Update to LLVM 15.0.7
|
||||
|
||||
* Tue Dec 06 2022 Nikita Popov <npopov@redhat.com> - 15.0.6-1
|
||||
- Update to LLVM 15.0.6
|
||||
|
||||
* Mon Nov 07 2022 Nikita Popov <npopov@redhat.com> - 15.0.4-1
|
||||
- Update to LLVM 15.0.4
|
||||
|
||||
* Mon Sep 12 2022 Nikita Popov <npopov@redhat.com> - 15.0.0-3
|
||||
- Re-enable LTO build
|
||||
|
||||
* Mon Sep 12 2022 Nikita Popov <npopov@redhat.com> - 15.0.0-2
|
||||
- Add explicit requires from libomp-devel to libomp
|
||||
|
||||
* Tue Sep 06 2022 Nikita Popov <npopov@redhat.com> - 15.0.0-1
|
||||
- Update to LLVM 15.0.0
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 14.0.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Mon Jun 20 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.5-1
|
||||
- 14.0.5 Release
|
||||
|
||||
* Thu Mar 24 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-1
|
||||
- 14.0.0 Release
|
||||
|
||||
* Thu Feb 03 2022 Nikita Popov <npopov@redhat.com> - 13.0.1-1
|
||||
- Update to LLVM 13.0.1 final
|
||||
|
||||
* Tue Jan 25 2022 Nikita Popov <npopov@redhat.com> - 13.0.1~rc3-2
|
||||
- Update to LLVM 13.0.1rc3
|
||||
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 13.0.1~rc2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Thu Jan 13 2022 Nikita Popov <npopov@redhat.com> - 13.0.1~rc2-1
|
||||
- Update to LLVM 13.0.1rc2
|
||||
|
||||
* Mon Jan 10 2022 Nikita Popov <npopov@redhat.com> - 13.0.1~rc1-1
|
||||
- Update to LLVM 13.0.1rc1
|
||||
|
||||
|
@ -315,12 +366,12 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
|||
- Use gnupg verify
|
||||
|
||||
* Tue Jun 16 2020 sguelton@redhat.com - 10.0.0-3
|
||||
- Add Requires: libomp = %{version}-%{release} to libomp-test to avoid
|
||||
- Add Requires: libomp = %%{version}-%%{release} to libomp-test to avoid
|
||||
the need to test interoperability between the various combinations of old
|
||||
and new subpackages.
|
||||
|
||||
* Mon Jun 01 2020 sguelton@redhat.com - 10.0.0-2
|
||||
- Add Requires: libomp-devel = %{version}-%{release} to libomp-test to avoid
|
||||
- Add Requires: libomp-devel = %%{version}-%%{release} to libomp-test to avoid
|
||||
the need to test interoperability between the various combinations of old
|
||||
and new subpackages.
|
||||
|
||||
|
|
104
release-keys.asc
Normal file
104
release-keys.asc
Normal file
|
@ -0,0 +1,104 @@
|
|||
-----BEGIN PGP PUBLIC KEY BLOCK-----
|
||||
|
||||
mQGNBGLtemUBDADClvDIromq0Y4TX+wyRyYCq5WusPQheQuY8dVCXd9KhMpYAv8U
|
||||
X15E5boH/quGpJ0ZlVkWcf+1WUHIrQWlbzQdIx514CDM7DBgO92CXsnn86kIMDW+
|
||||
9S+Hkn8upbizT1fWritlHwzD9osz7ZQRq7ac03PPgw27tqeIizHGuG4VNLyhbbjA
|
||||
w+0VLFSu3r219eevS+lzBIvR5U9W720jFxWxts4UvaGuD6XW1ErcsTvuhgyCKrrs
|
||||
gxO5Ma/V7r0+lqRL688ZPr4HxthwsON1YCfpNiMZ6sgxT8rOE0qL/d07ItbnXxz6
|
||||
KdcNWIXamTJKJgag6Tl0gYX4KIuUCcivXaRdJtUcFFsveCorkdHkdGNos403XR89
|
||||
5u9gq7Ef10Zahsv5GjE2DV5oFCEhXvfIWxvyeJa65iBkJafElb2stgUjkIut2a2u
|
||||
+XmpKpwpGSFklce1ABLrmazlLjhsYiJVrz5l5ktoT9moE4GaF7Q5LD6JgsxzLE0U
|
||||
Tzo9/AQPd8qG2REAEQEAAbQeVG9iaWFzIEhpZXRhIDx0b2JpYXNAaGlldGEuc2U+
|
||||
iQHUBBMBCAA+FiEE1XS9XR0OmIleO/kARPJIXkXVkEIFAmLtemUCGwMFCRLMAwAF
|
||||
CwkIBwIGFQoJCAsCBBYCAwECHgECF4AACgkQRPJIXkXVkEKoNwv+MEMVzdnzJarx
|
||||
ZJ0OzHrGJJG8/chkuoejTjCLG73li9yWQigy5KmvynB5yW0fk0PAQ90vvp2wr/Hd
|
||||
mUh0Zda3CwF6sWlO3N6DEDjVA3lZUuofTtvMn/tdGvvOOXYXAP9N+SZfp/7q8dxX
|
||||
zn5SA1AO87nXq5lrwVzlVzUCdwOeqDlJ+2U9VEqvukP/FdkgaR2bEb8Wm/h+encW
|
||||
UIQEqPDE+qOyJ9dRaiL0CUI4x+1wXeXB3OA7VybF2LvaZDbMlocdy+vs825iUWfa
|
||||
n8g3mE2TpV8jkc9UHgGGopzxqNquvkkIB7ZFZm/PSW40W3OeHKhYsZZbHrz9403t
|
||||
3R4SAzA3ApmMP/P8ue9irsbe24g3rzYMvck1w4C1a4Uy9buT0OCfA+dA16IRAPgV
|
||||
5SJEIS62cFbUxkw8el3rUK9V+6kwoq4k8Fs8f1U7DEnOKS/v8BJJCNEc1cvimZai
|
||||
Y5/3r5BeneEmuZFKX4iIIfcn5PmLSDB4aw+gKAIAAus+E2DxBqE+uQGNBGLtemUB
|
||||
DADBCNyvUdv0OV//6pQ/0YC2bYXL/ElF0rOjFFl4H7O3TRxgIz2C4nQJHUOrXSmo
|
||||
iL7ldfUjoAMgebcoWDpgE8S2Vjw2Gd+UJBQXj+3J6dPKLBUCjj9CLyb5hwOHITMV
|
||||
b9UC/E+iwpn4vgTbI6K1O847brkBC+GuDT4g9D3O3sRbja0GjN0n2yZiS8NtRQm1
|
||||
MXAVy1IffeXKpGLookAhoUArSN88koMe+4Nx6Qun4/aUcwz0P2QUr5MA5jUzFLy1
|
||||
R3M5p1nctX15oLOU33nwCWuyjvqkxAeAfJMlkKDKYX25u1R2RmQ4ju2kAbw0PiiZ
|
||||
yYft8fGlrwT4/PB3AqfKeSpx8l9Vs15ePvcuJITauo3fhBjJ6Y4WCKlTG1FbDYUl
|
||||
KvPhyGO8yLhtZJg3+LbA5M/CEHsDmUh7YEQVxM0RTQMTxNBVBF5IG/4y8v/+19DZ
|
||||
89VdpsQF3ThoPV0yh57YMemTBeIxpF9Swp5N7kUWct4872kBnXOmbp/jhU4MpLj6
|
||||
iLEAEQEAAYkBvAQYAQgAJhYhBNV0vV0dDpiJXjv5AETySF5F1ZBCBQJi7XplAhsM
|
||||
BQkSzAMAAAoJEETySF5F1ZBCdPwL/3Ox6MwrKFzYJNz3NpQFpKFdDrkwhf25D/Qw
|
||||
vu5e8Lql/q62NIhEKH3jxXXgoFYas2G7r8CSCRehraDqvXygbaiWUIkxSU0xuDTl
|
||||
lNqHSkCRqIxhi/yxNm1Pk84NVGTLXWW0+CwT9cRwWn5foIPJhoDdZ732zJ7rcY3R
|
||||
g71SJTe3R6MnGBzIF1LzT7Znwkh7YfcmeTfInareIWXpeNaeKy8KrQmr/0+5AIer
|
||||
Ax1gu03o8GD5LFDUuGbESgDJU6nVtVyht7C6AlJWqSX6QS3+lPCw5BOCKbxakYNR
|
||||
/oBNauzyDISdbUwzHM2d+XGCjBsXKRA0Tft2NlG6EC83/PuY2J9MSA2gg3iPHsiN
|
||||
J5iipbdZNpZ3XL0l8/t/7T60nM7UZDqt3twLMA0eRFRlCnhMjvFE5Zgj5DE7BsJh
|
||||
w2nCoGWkAcfeuih+jfyEjN24NK+sE/bM+krwVv430ewJwm1bVUqKrbOb9aa6V9gP
|
||||
9RmlwZlOTFGcWBYl/cfRONn9qi9a6w==
|
||||
=Lvw+
|
||||
-----END PGP PUBLIC KEY BLOCK-----
|
||||
-----BEGIN PGP PUBLIC KEY BLOCK-----
|
||||
|
||||
mQINBFrqgT0BEAC7xo0WH+eNrLlU5LrCk59KmImn1abFcmWNd8kYr5XfqmJKyVqo
|
||||
EY7A/yRjf+Yn1621EDkpKPjbql7q7MlZMpqKVdOWKWgmhvz08IOKJxaIABd/iIRT
|
||||
FwhIvB68YjtmzcoOJRi1wLnwuG55fJ9E69HyZ33jgAlRaWV3bE/YyszoTlZriUOE
|
||||
RbzC5WzX004cE9evlrr+YLt5Y6z7tntOdSXPLyGOFAO5LYMsHsEdi2JBYWrjlslG
|
||||
6iJr5iEt9v442PrJ79YYbu5QWe/6APRWtI3AtKBp7y250oon2lbj+bIVD7U9fOBB
|
||||
n/Frqx54UN22sJycET63hgYW4pIjIi5zq+FF15aU+ZqBdtNltoX4hEN7wlDpuNc0
|
||||
ezVu2Z8hdt8thpjiFUioTQ1t3RmsN6N548VwxmHdoYpAmiZqPIYBYvm85JB7S/3h
|
||||
RLuoeGxufBhXGCpnG8ghTOGtbbdanuLB/UROFXTdyZbTCBN5S6jvwkPSaHG7H35Z
|
||||
3fazMriTXwL1RGAbKITSWhDe5dXy/yOInWe8emJx+35vwQYCB2L4S8wRyQyRw6x4
|
||||
YoXCscW041DUMBX2CC7SjMCcmAC39UX1c3GbTpS3rkJR9cmXt50nviMnKpIwlIPd
|
||||
ZYhmxKifwTJ70+c4GVK2o0MG9bTYvpYhLnYxv6iJCfgmT40E+qkDSzSoZwARAQAB
|
||||
tCJUb20gU3RlbGxhcmQgPHRzdGVsbGFyQHJlZGhhdC5jb20+iQI/BBMBAgApBQJa
|
||||
6oE9AhsDBQkB4TOABwsJCAcDAgEGFQgCCQoLBBYCAwECHgECF4AACgkQoseUqYZB
|
||||
nYp8Gg//RmX6Nup/Dv05jTL7dKRBSD08MF400tRtTmRhIuAgGv27qO2hbqzprKVu
|
||||
vd20vKBB9CNZpXC2oY8k9VhGv2PZNi/X7iuULIYmzjeFMbJ5CjU6XvuUBmNasITH
|
||||
6K/0KLhGebPs5h/DNtd7lbzDm86dLcjxgl6LXUULaSyYvTAKn6YB6mAv5J3qJs2X
|
||||
lfTmenNh9p7TPFTfcMHcS70ywjqKXlDiH0q9bRKJnSX7xUFlTHjKkNnAcRjlPaGf
|
||||
wUUhIPrnpDboqfwfcmScLrHANW9nwFWSFkNAJu1HQUEuF+An/RZUHDxFbLPKKAIp
|
||||
hwZ0aORTfBVZ80AjehDMYCbmp1DJeTyLjC1/94un6mlxPIKnPPPM8rMxr83xnrvP
|
||||
+Y1+pJaDUL7ZvKnmt2LrGRa9GvsNiYKpCNCORfiwZTeSxxXb+LgaodnbCHvGBnk7
|
||||
nlbLdMY08vNlxSx8LNyG0krFxJw/rq260+73yc+qjENeG68fozTEy/4jSVrF4t3m
|
||||
8AAUu5r6i/Aomo7Q27TjU928bbCVunpvDpserfDqr3zsA96LO9k8T6THR6zC9i+R
|
||||
LiN9Vjl+Rr2YuU26DjFYkCNEA2kNflYCWPJi5I0eodTPZrIPBWJ+H0YTRX31bMH9
|
||||
X88FnWJuCwaqAMN3rWlX/lXNCouWDdCuPWseZApISAMnVDE2mM+JAlYEEwEIAEAC
|
||||
GwMHCwkIBwMCAQYVCAIJCgsEFgIDAQIeAQIXgBYhBEdOIjFqv0eFqIxujqLHlKmG
|
||||
QZ2KBQJgkytfBQkJaxEiAAoJEKLHlKmGQZ2Kv8YP/jNPjcMAP0ZTpUcYV46mGKwf
|
||||
aQ0g5FUMSfxP7uJHtctj2dUckPGpA9SAH+ApiJutVgTQpWqNJKPd2vVxOiu5sywN
|
||||
iDKCOMlKug5m6lgLX5h3zBvSN90Hpn4I0qHRA3rgENLoPs/UYBxohvFPIhOOjPqO
|
||||
HIUuSPhAIuIZawxtqlADswHiKPy38Ao5GnWRb60zKfrB+N+ZiOtg7ITrlTGYm2tX
|
||||
0W9iWUG32gIA/RX2qmFPoLrDFqsk66Eir0Ghk5gppRrmpEl/M1lqA8bxlqWto/8w
|
||||
V8yDbSEu5fmM3WN3OUcSA23lYJi4j656Q4hS5PU+IWuZbBhcpYwDGexV5+m/ySZb
|
||||
wtHZMIb4Au+dgJHCvRiSqHgplyfiamxX5CfA0DJVHoGXpBOw8a2geRT0+DrjSbOS
|
||||
+CDDnlfmQLfHgjEuyQPU8V0Wlb0tJEvnPPqNPmAv0Rv7MC4qmD/zDrgwuddpfr1x
|
||||
H+nWus2plR8E6p/x9uvPLb3plJ94ri1XjXiJPyPvqzBAwA40Zeg0rE7sTVwCC3E9
|
||||
RZa7dHh17exkcZdOIS/vRQ1G/VNaOVUwrcC/vIMgZSe37bCLeOKViMtacAiBJDjo
|
||||
INC1QJ2F3CYVwktrcgmuz9S8e2WrqdTWwijjConB80EwfHQllz5sp/jU6Bgv297X
|
||||
UXkgpk1y+ibQ9/syRQpFuQINBFrqgT0BEADB2vDHMuexkaUm3rPi6SvyMGcsHWle
|
||||
feAWm+UjROKIaV77rHwo0/8ncKbtoQx4ZZjDXdI77M2bXB7tPgyEML90bWDMMGN/
|
||||
gnpwWSsiDRWpFIV/+hD6B+l9UaEi4UvEstUbIchOkGrZgPZ4Qism4FSVosEK+FE7
|
||||
EKCT4PSS+LiBKSxJZB8/g2uX+3pJvVxYurvcVpTmiNlXvUyll4KMpzy5e0KKa/0y
|
||||
w9h7SAre5399cSM8E7PDQZQDb1EwbyVyO2yDLgs+p3yzPtRJAydaqRPmT1JbSCYf
|
||||
hcihTrViMA4EDN5GRjH2EElI37+2HMpgLs4rc6Abz1F4FUVFhqWJXCKUcAIrG17w
|
||||
A7YUlYg38S6Xws2Xj1VfZ/WP7/qIMJZidYTHZbN9WWCaifCPfLlE5VDNsa8y6Mxm
|
||||
uFMBAB4PpB1gmmP9pPZsOzV9SmeYt8h2P8cVKDW2f56azpBZvZX6NFn8e0+ZDXS4
|
||||
8BQz31G2Xdfa3uOEV0J3JxPXcEbfuPzDHb7OMYP+2Ypjox1TozT1e9zr46SQl9OF
|
||||
MglOBnwLZJ9baA/IqZkqLq5iu5Oqda44EIVNAntQ3gebi3+q3YG1SvNUseIy2+8y
|
||||
cNWtdDuWv366Af0okCdrKAdap8+KbREer9uXhamtvxc49RCoWwuKoKfBz0RdVvMv
|
||||
R/Py2xV8A7PaIQARAQABiQIlBBgBAgAPBQJa6oE9AhsMBQkB4TOAAAoJEKLHlKmG
|
||||
QZ2KAaMQALHif2E0PBLVt09vlr4i8jAsQvDrzRajmVPd2B9RpfNU6HJe/y93SZd2
|
||||
udr9vzgmfd2o5u12vbegKNiMRgp1VyHQDmYlce27jrH5aPuKmos78+o5/p5yPWCv
|
||||
Rj8zxGKh7le7UPO+7UveKu+bgb3zwTj6bEuHX7fVI+WjGmEH3bbjDGamWxXrpfGc
|
||||
7+Jr8TN4ZO2OwYBcFOS9U2ZQ6TxrPaCSIm6+j8f+a9HPOuuDc62mMuV/EWQZy0i7
|
||||
DhDqU2PNpVjQDWQNpHA8oLDrjNFAoJS8gbHABVsFM1VnwBNT2MKcZQmm05dlQ+ll
|
||||
S6meHNCvTniKIKC+Giz1Yd5JVGDACZWWPxEz6VhpQW/twkxRqwlUdpFt7UgDquTL
|
||||
M1beQUCZRt81yJTNdrggbhQ2POxOdIO0CPiQv7U1IzndZp6baedeBw4a7FCbj6GY
|
||||
cQeHxQCrWpQrwigiseG5uhhS9aiaVFEHja9baSLfXlZu/vsR4MdDG5/iEpier/Xw
|
||||
h1qnpTSY+r31Uw3lTUlPHzlg47PMgPslaIhCzfVggxh9bTqxcDbuYJ7NuoMho3tN
|
||||
yWfeofTJ7PhKzoXM2Y/rRFoM5gNh1RVA19ngLT5Jwiof8fPZvHJ/9ZkHn+O7eMNm
|
||||
m5++gYza3pnn2/PoGpGGAKok+sfJiq5Tb7RUefyJTeZiyTZ/XJrA
|
||||
=tMzl
|
||||
-----END PGP PUBLIC KEY BLOCK-----
|
4
sources
4
sources
|
@ -1,2 +1,2 @@
|
|||
SHA512 (openmp-13.0.1rc1.src.tar.xz) = c5f25d3ecaac1bcda842aefc2d62b1b9a92b35cddba8775de3932395525920a9f855662ac89be97175f20227687d21d8b82115159ec668c0c45139ad0c89e211
|
||||
SHA512 (openmp-13.0.1rc1.src.tar.xz.sig) = 708c9d4540eef39716294a7947b69d7489c6dc61e4d41c003e73a0a22ad58194e85a3931e0141dc9107b4461479b22386b991d29890059cc37f1c5180be5a3f4
|
||||
SHA512 (openmp-15.0.7.src.tar.xz) = b4f6399e33821776d9f58c8fb82ad2f3f266b2a38cf9ba1881fdac175c5a27e6d48e3c5e06bc8d42fb3a7dc350ec2e01b5d215ab851a27cb67c397ecfaebca89
|
||||
SHA512 (openmp-15.0.7.src.tar.xz.sig) = 732a48656f58eadd005517255c656449d60e255900eb75df41d5cee4b1bbae66eac92428808bccafafeba77dead3c0247cd9eb9194ac3d0f5478e64f628a0106
|
||||
|
|
6
tests/README.md
Normal file
6
tests/README.md
Normal file
|
@ -0,0 +1,6 @@
|
|||
# Gating testplans for libomp
|
||||
|
||||
The tests for libomp are in a separate repo: https://src.fedoraproject.org/tests/libomp
|
||||
This directory should contain only fmf plans (such as build-gating.fmf) which import
|
||||
the tests from the tests repo. This can be done using the "url" parameter of the
|
||||
plan's "discover" step. Reference: https://tmt.readthedocs.io/en/stable/spec/plans.html#fmf
|
|
@ -23,12 +23,20 @@ adjust:
|
|||
environment+:
|
||||
WITH_SCL: "scl enable llvm-toolset-13.0 rust-toolset-1.58"
|
||||
when: "collection == llvm-toolset-13.0"
|
||||
- because: "When testing SCL-ized LLVM, the collection must be enabled first"
|
||||
environment+:
|
||||
WITH_SCL: "scl enable llvm-toolset-14.0"
|
||||
when: "collection == llvm-toolset-14.0"
|
||||
|
||||
discover:
|
||||
- name: libomp-tests
|
||||
how: fmf
|
||||
url: https://src.fedoraproject.org/tests/libomp.git
|
||||
ref: main
|
||||
- name: upstream-llvm-integration-testsuite
|
||||
how: fmf
|
||||
url: https://src.fedoraproject.org/rpms/llvm.git
|
||||
ref: rawhide
|
||||
url: https://src.fedoraproject.org/tests/llvm.git
|
||||
ref: main
|
||||
test: integration-test-suite
|
||||
execute:
|
||||
how: tmt
|
||||
|
|
Binary file not shown.
Loading…
Reference in a new issue