mirror of
https://src.fedoraproject.org/rpms/libomp.git
synced 2024-11-28 09:14:55 +00:00
11.0.0-rc1 Release
This commit is contained in:
parent
dc120ec4cd
commit
0a5a288e1f
2 changed files with 11 additions and 43 deletions
|
@ -1,39 +0,0 @@
|
|||
diff --git a/runtime/test/lit.cfg b/runtime/test/lit.cfg
|
||||
index 8ff668a..8e15a38 100644
|
||||
--- a/runtime/test/lit.cfg
|
||||
+++ b/runtime/test/lit.cfg
|
||||
@@ -100,6 +100,13 @@ if config.operating_system == 'NetBSD':
|
||||
if config.operating_system in ['Linux', 'Windows']:
|
||||
config.available_features.add('affinity')
|
||||
|
||||
+import multiprocessing
|
||||
+try:
|
||||
+ if multiprocessing.cpu_count() > 1:
|
||||
+ config.available_features.add('multicpu')
|
||||
+except NotImplementedError:
|
||||
+ pass
|
||||
+
|
||||
# to run with icc INTEL_LICENSE_FILE must be set
|
||||
if 'INTEL_LICENSE_FILE' in os.environ:
|
||||
config.environment['INTEL_LICENSE_FILE'] = os.environ['INTEL_LICENSE_FILE']
|
||||
diff --git a/runtime/test/ompt/teams/parallel_team.c b/runtime/test/ompt/teams/parallel_team.c
|
||||
index 15d9b6c..96ce0d5 100644
|
||||
--- a/runtime/test/ompt/teams/parallel_team.c
|
||||
+++ b/runtime/test/ompt/teams/parallel_team.c
|
||||
@@ -1,5 +1,5 @@
|
||||
// RUN: %libomp-compile-and-run | %sort-threads | FileCheck %s
|
||||
-// REQUIRES: ompt
|
||||
+// REQUIRES: ompt, multicpu
|
||||
// UNSUPPORTED: gcc
|
||||
#include "callback.h"
|
||||
|
||||
diff --git a/runtime/test/ompt/teams/serial_teams.c b/runtime/test/ompt/teams/serial_teams.c
|
||||
index 64d0c89..abd3db5 100644
|
||||
--- a/runtime/test/ompt/teams/serial_teams.c
|
||||
+++ b/runtime/test/ompt/teams/serial_teams.c
|
||||
@@ -1,5 +1,5 @@
|
||||
// RUN: %libomp-compile-and-run | %sort-threads | FileCheck %s
|
||||
-// REQUIRES: ompt
|
||||
+// REQUIRES: ompt, multicpu
|
||||
// UNSUPPORTED: gcc
|
||||
#include "callback.h"
|
15
libomp.spec
15
libomp.spec
|
@ -1,5 +1,5 @@
|
|||
#%%global rc_ver 6
|
||||
%global baserelease 8
|
||||
%global rc_ver 1
|
||||
%global baserelease 0.1
|
||||
%global libomp_srcdir openmp-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
|
||||
|
@ -10,7 +10,7 @@
|
|||
%endif
|
||||
|
||||
Name: libomp
|
||||
Version: 10.0.0
|
||||
Version: 11.0.0
|
||||
Release: %{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||
Summary: OpenMP runtime for clang
|
||||
|
||||
|
@ -28,7 +28,6 @@ Source2: lit.fedora.cfg.py
|
|||
Source4: https://prereleases.llvm.org/%{version}/hans-gpg-key.asc
|
||||
|
||||
Patch0: 0001-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-a-cache-varia.patch
|
||||
Patch1: 99b03c1c18.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
|
@ -121,6 +120,8 @@ install -m 0755 %{SOURCE1} %{buildroot}%{_libexecdir}/tests/libomp
|
|||
# Remove static libraries with equivalent shared libraries
|
||||
rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
||||
|
||||
%check
|
||||
%cmake_build --target check-openmp
|
||||
|
||||
%files
|
||||
%license LICENSE.txt
|
||||
|
@ -138,6 +139,9 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
|||
%ifnarch %{arm}
|
||||
%{_libdir}/clang/%{version}/include/omp-tools.h
|
||||
%{_libdir}/clang/%{version}/include/ompt.h
|
||||
# FIXME: This is probably wrong. Seems like LIBOMP_HEADERS_INSTALL may
|
||||
# not be respected.
|
||||
%{_includedir}/ompt-multiplex.h
|
||||
%endif
|
||||
|
||||
%files test
|
||||
|
@ -145,6 +149,9 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
|||
%{_libexecdir}/tests/libomp/
|
||||
|
||||
%changelog
|
||||
* Mon Aug 10 2020 Tom Stellard <tstellar@redhat.com> - 11.0.0-0.1.rc1
|
||||
- 11.0.0-rc1 Release
|
||||
|
||||
* Mon Aug 10 2020 sguelton@redhat.com - 10.0.0-8
|
||||
- Make gcc dependency explicit, see https://fedoraproject.org/wiki/Packaging:C_and_C%2B%2B#BuildRequires_and_Requires
|
||||
- use %%license macro
|
||||
|
|
Loading…
Reference in a new issue