mirror of
https://src.fedoraproject.org/rpms/grub2.git
synced 2024-11-24 06:22:43 +00:00
Update to 2.00~beta4
- Make fonts work so we can do graphics reasonably
This commit is contained in:
parent
81e64b5742
commit
f06903e4a1
4 changed files with 68 additions and 29 deletions
1
.gitignore
vendored
1
.gitignore
vendored
|
@ -1 +1,2 @@
|
||||||
grub-*.tar.?z
|
grub-*.tar.?z
|
||||||
|
/unifont-5.1.20080820.pcf.gz
|
||||||
|
|
29
grub-2.00-beta4-wronly.patch
Normal file
29
grub-2.00-beta4-wronly.patch
Normal file
|
@ -0,0 +1,29 @@
|
||||||
|
From 8e4aea82c6aba6b8b5ca68d74abafa3fe9486c36 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Jones <pjones@redhat.com>
|
||||||
|
Date: Thu, 19 Apr 2012 14:17:38 -0400
|
||||||
|
Subject: [PATCH] Open device O_WRONLY in grub_util_biosdisk_write.
|
||||||
|
|
||||||
|
revision 4225 introduced an error wherein the device we intend
|
||||||
|
to write to from e.g. grub2-bios-setup is opened read-only. The
|
||||||
|
immediate following write(2) call then fails with -EBADF.
|
||||||
|
|
||||||
|
---
|
||||||
|
grub-core/kern/emu/hostdisk.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/grub-core/kern/emu/hostdisk.c b/grub-core/kern/emu/hostdisk.c
|
||||||
|
index ea7eb3d..19748df 100644
|
||||||
|
--- a/grub-core/kern/emu/hostdisk.c
|
||||||
|
+++ b/grub-core/kern/emu/hostdisk.c
|
||||||
|
@@ -1081,7 +1081,7 @@ grub_util_biosdisk_write (grub_disk_t disk, grub_disk_addr_t sector,
|
||||||
|
{
|
||||||
|
int fd;
|
||||||
|
grub_disk_addr_t max = ~0ULL;
|
||||||
|
- fd = open_device (disk, sector, O_RDONLY, &max);
|
||||||
|
+ fd = open_device (disk, sector, O_WRONLY, &max);
|
||||||
|
if (fd < 0)
|
||||||
|
return grub_errno;
|
||||||
|
|
||||||
|
--
|
||||||
|
1.7.10
|
||||||
|
|
65
grub2.spec
65
grub2.spec
|
@ -16,13 +16,13 @@
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%global tarversion 2.00~beta2
|
%global tarversion 2.00~beta4
|
||||||
%undefine _missing_build_ids_terminate_build
|
%undefine _missing_build_ids_terminate_build
|
||||||
|
|
||||||
Name: grub2
|
Name: grub2
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.0
|
Version: 2.0
|
||||||
Release: 0.22%{?dist}
|
Release: 0.23%{?dist}
|
||||||
Summary: Bootloader with support for Linux, Multiboot and more
|
Summary: Bootloader with support for Linux, Multiboot and more
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
|
@ -33,13 +33,14 @@ Source0: ftp://alpha.gnu.org/gnu/grub/grub-%{tarversion}.tar.xz
|
||||||
Source1: 90_persistent
|
Source1: 90_persistent
|
||||||
Source2: grub.default
|
Source2: grub.default
|
||||||
Source3: README.Fedora
|
Source3: README.Fedora
|
||||||
|
Source4: http://unifoundry.com/unifont-5.1.20080820.pcf.gz
|
||||||
Patch0: grub-1.99-handle-fwrite-return.patch
|
Patch0: grub-1.99-handle-fwrite-return.patch
|
||||||
Patch1: grub-1.99-grub_test_assert_printf.patch
|
Patch1: grub-1.99-grub_test_assert_printf.patch
|
||||||
Patch2: grub-1.99-just-say-linux.patch
|
Patch2: grub-1.99-just-say-linux.patch
|
||||||
Patch3: grub2-handle-initramfs-on-xen.patch
|
Patch3: grub2-handle-initramfs-on-xen.patch
|
||||||
Patch9: grub-1.99-gcc-4.7.0.patch
|
Patch4: grub-1.99-Fix-tests-of-zeroed-partition.patch
|
||||||
Patch10: grub-1.99-Fix-tests-of-zeroed-partition.patch
|
Patch5: grub-1.99-ppc-terminfo.patch
|
||||||
Patch11: grub-1.99-ppc-terminfo.patch
|
Patch6: grub-2.00-beta4-wronly.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
@ -87,6 +88,8 @@ echo foo
|
||||||
echo bar
|
echo bar
|
||||||
cd grub-%{tarversion}
|
cd grub-%{tarversion}
|
||||||
cp %{SOURCE3} .
|
cp %{SOURCE3} .
|
||||||
|
# place unifont in the '.' from which configure is run
|
||||||
|
cp %{SOURCE4} unifont.pcf.gz
|
||||||
git init
|
git init
|
||||||
git config user.email "pjones@fedoraproject.org"
|
git config user.email "pjones@fedoraproject.org"
|
||||||
git config user.name "Fedora Ninjas"
|
git config user.name "Fedora Ninjas"
|
||||||
|
@ -99,6 +102,8 @@ mv grub-%{tarversion} grub-efi-%{tarversion}
|
||||||
%setup -D -q -T -a 0 -n grub-%{tarversion}
|
%setup -D -q -T -a 0 -n grub-%{tarversion}
|
||||||
cd grub-%{tarversion}
|
cd grub-%{tarversion}
|
||||||
cp %{SOURCE3} .
|
cp %{SOURCE3} .
|
||||||
|
# place unifont in the '.' from which configure is run
|
||||||
|
cp %{SOURCE4} unifont.pcf.gz
|
||||||
git init
|
git init
|
||||||
git config user.email "pjones@fedoraproject.org"
|
git config user.email "pjones@fedoraproject.org"
|
||||||
git config user.name "Fedora Ninjas"
|
git config user.name "Fedora Ninjas"
|
||||||
|
@ -123,8 +128,7 @@ cd grub-efi-%{tarversion}
|
||||||
--with-platform=efi \
|
--with-platform=efi \
|
||||||
--with-grubdir=grub2 \
|
--with-grubdir=grub2 \
|
||||||
--program-transform-name=s,grub,%{name}-efi, \
|
--program-transform-name=s,grub,%{name}-efi, \
|
||||||
--disable-werror \
|
--disable-werror
|
||||||
--sbindir=/sbin
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
%ifarch %{ix86}
|
%ifarch %{ix86}
|
||||||
%define grubefiarch i386-efi
|
%define grubefiarch i386-efi
|
||||||
|
@ -159,8 +163,7 @@ cd grub-%{tarversion}
|
||||||
--with-platform=%{platform} \
|
--with-platform=%{platform} \
|
||||||
--with-grubdir=grub2 \
|
--with-grubdir=grub2 \
|
||||||
--program-transform-name=s,grub,%{name}, \
|
--program-transform-name=s,grub,%{name}, \
|
||||||
--disable-werror \
|
--disable-werror
|
||||||
--sbindir=/sbin
|
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
@ -288,15 +291,15 @@ fi
|
||||||
/etc/bash_completion.d/grub
|
/etc/bash_completion.d/grub
|
||||||
%{_libdir}/grub/*-%{platform}/
|
%{_libdir}/grub/*-%{platform}/
|
||||||
%{_datarootdir}/grub/grub-mkconfig_lib
|
%{_datarootdir}/grub/grub-mkconfig_lib
|
||||||
/sbin/%{name}-mkconfig
|
%{_sbindir}/%{name}-mkconfig
|
||||||
/sbin/%{name}-mknetdir
|
%{_sbindir}/%{name}-mknetdir
|
||||||
/sbin/%{name}-install
|
%{_sbindir}/%{name}-install
|
||||||
/sbin/%{name}-probe
|
%{_sbindir}/%{name}-probe
|
||||||
/sbin/%{name}-reboot
|
%{_sbindir}/%{name}-reboot
|
||||||
/sbin/%{name}-set-default
|
%{_sbindir}/%{name}-set-default
|
||||||
/sbin/%{name}-bios-setup
|
%{_sbindir}/%{name}-bios-setup
|
||||||
/sbin/%{name}-ofpathname
|
%{_sbindir}/%{name}-ofpathname
|
||||||
/sbin/%{name}-sparc64-setup
|
%{_sbindir}/%{name}-sparc64-setup
|
||||||
%{_bindir}/%{name}-mkstandalone
|
%{_bindir}/%{name}-mkstandalone
|
||||||
%{_bindir}/%{name}-editenv
|
%{_bindir}/%{name}-editenv
|
||||||
%{_bindir}/%{name}-fstest
|
%{_bindir}/%{name}-fstest
|
||||||
|
@ -313,7 +316,7 @@ fi
|
||||||
%{_bindir}/%{name}-mkrescue
|
%{_bindir}/%{name}-mkrescue
|
||||||
%endif
|
%endif
|
||||||
%ifarch %{sparc}
|
%ifarch %{sparc}
|
||||||
/sbin/%{name}-ofpathname
|
%{_sbindir}/%{name}-ofpathname
|
||||||
%endif
|
%endif
|
||||||
%{_bindir}/%{name}-script-check
|
%{_bindir}/%{name}-script-check
|
||||||
%dir %{_sysconfdir}/grub.d
|
%dir %{_sysconfdir}/grub.d
|
||||||
|
@ -339,15 +342,15 @@ fi
|
||||||
/etc/bash_completion.d/grub-efi
|
/etc/bash_completion.d/grub-efi
|
||||||
%{_libdir}/grub/%{_arch}-efi
|
%{_libdir}/grub/%{_arch}-efi
|
||||||
%{_datarootdir}/grub/grub-mkconfig_lib
|
%{_datarootdir}/grub/grub-mkconfig_lib
|
||||||
/sbin/grub2-efi-mkconfig
|
%{_sbindir}/grub2-efi-mkconfig
|
||||||
/sbin/grub2-efi-mknetdir
|
%{_sbindir}/grub2-efi-mknetdir
|
||||||
/sbin/grub2-efi-install
|
%{_sbindir}/grub2-efi-install
|
||||||
/sbin/grub2-efi-probe
|
%{_sbindir}/grub2-efi-probe
|
||||||
/sbin/grub2-efi-reboot
|
%{_sbindir}/grub2-efi-reboot
|
||||||
/sbin/grub2-efi-set-default
|
%{_sbindir}/grub2-efi-set-default
|
||||||
/sbin/grub2-efi-bios-setup
|
%{_sbindir}/grub2-efi-bios-setup
|
||||||
/sbin/grub2-efi-ofpathname
|
%{_sbindir}/grub2-efi-ofpathname
|
||||||
/sbin/grub2-efi-sparc64-setup
|
%{_sbindir}/grub2-efi-sparc64-setup
|
||||||
%{_bindir}/grub2-efi-mkstandalone
|
%{_bindir}/grub2-efi-mkstandalone
|
||||||
%{_bindir}/grub2-efi-editenv
|
%{_bindir}/grub2-efi-editenv
|
||||||
%{_bindir}/grub2-efi-fstest
|
%{_bindir}/grub2-efi-fstest
|
||||||
|
@ -364,7 +367,7 @@ fi
|
||||||
%{_bindir}/grub2-efi-mkrescue
|
%{_bindir}/grub2-efi-mkrescue
|
||||||
%endif
|
%endif
|
||||||
%ifarch %{sparc} ppc ppc64
|
%ifarch %{sparc} ppc ppc64
|
||||||
/sbin/grub2-efi-ofpathname
|
%{_sbindir}/grub2-efi-ofpathname
|
||||||
%endif
|
%endif
|
||||||
%{_bindir}/grub2-efi-script-check
|
%{_bindir}/grub2-efi-script-check
|
||||||
%dir %{_sysconfdir}/grub.d
|
%dir %{_sysconfdir}/grub.d
|
||||||
|
@ -384,6 +387,10 @@ fi
|
||||||
%attr(0755,root,root)/%{_datarootdir}/grub/
|
%attr(0755,root,root)/%{_datarootdir}/grub/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 19 2012 Peter Jones <pjones@redhat.com> - 2.0-0.23
|
||||||
|
- Update to 2.00~beta4
|
||||||
|
- Make fonts work so we can do graphics reasonably
|
||||||
|
|
||||||
* Thu Mar 29 2012 David Aquilina <dwa@redhat.com> - 2.0-0.22
|
* Thu Mar 29 2012 David Aquilina <dwa@redhat.com> - 2.0-0.22
|
||||||
- Fix ieee1275 platform define for ppc
|
- Fix ieee1275 platform define for ppc
|
||||||
|
|
||||||
|
|
2
sources
2
sources
|
@ -1 +1,3 @@
|
||||||
4509839183c4593ab49a2c6044c03f18 grub-2.00~beta2.tar.xz
|
4509839183c4593ab49a2c6044c03f18 grub-2.00~beta2.tar.xz
|
||||||
|
8c28087c5fcb3188f1244b390efffdbe unifont-5.1.20080820.pcf.gz
|
||||||
|
6902a2b408038b8d3263a86536ac4652 grub-2.00~beta4.tar.xz
|
||||||
|
|
Loading…
Reference in a new issue