mirror of
https://src.fedoraproject.org/rpms/grub2.git
synced 2024-11-24 06:22:43 +00:00
Fix changed symbol name.
Upstream's f8451af8 changed finalize_params to finalize_params_linux on aarch64, and so we got a build failure because one of our patches also referenced it. This rectifies the two patches. Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
parent
190143c8d4
commit
9074bf39f4
16 changed files with 54 additions and 40 deletions
1
.gitignore
vendored
1
.gitignore
vendored
|
@ -3,3 +3,4 @@ grub-*.tar.?z
|
|||
clog
|
||||
/unifont-5.1.20080820.pcf.gz
|
||||
/theme.tar.bz2
|
||||
kojilogs
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 56438f7e90e47de9c964272e6329ac5ef8ee9f0d Mon Sep 17 00:00:00 2001
|
||||
From aa0ad4b563fa2387e21a484895e23c4b9a45fb18 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Thu, 18 Sep 2014 11:26:14 -0400
|
||||
Subject: [PATCH 61/74] Load arm with SB enabled.
|
||||
|
@ -11,12 +11,12 @@ kernel command line, because we can't call systab->bs->LoadImage() if SB
|
|||
is enabled.
|
||||
---
|
||||
grub-core/Makefile.core.def | 2 +
|
||||
grub-core/loader/arm64/linux.c | 113 +++++++++++++++++++++-----------------
|
||||
grub-core/loader/efi/linux.c | 65 ++++++++++++++++++++++
|
||||
grub-core/loader/i386/efi/linux.c | 39 +------------
|
||||
include/grub/arm64/linux.h | 13 +++--
|
||||
include/grub/efi/linux.h | 31 +++++++++++
|
||||
6 files changed, 170 insertions(+), 93 deletions(-)
|
||||
grub-core/loader/arm64/linux.c | 124 +++++++++++++++++++-------------------
|
||||
grub-core/loader/efi/linux.c | 65 ++++++++++++++++++++
|
||||
grub-core/loader/i386/efi/linux.c | 39 +-----------
|
||||
include/grub/arm64/linux.h | 13 ++--
|
||||
include/grub/efi/linux.h | 31 ++++++++++
|
||||
6 files changed, 170 insertions(+), 104 deletions(-)
|
||||
create mode 100644 grub-core/loader/efi/linux.c
|
||||
create mode 100644 include/grub/efi/linux.h
|
||||
|
||||
|
@ -41,7 +41,7 @@ index 98b6485..38291ce 100644
|
|||
enable = x86_64_efi;
|
||||
};
|
||||
diff --git a/grub-core/loader/arm64/linux.c b/grub-core/loader/arm64/linux.c
|
||||
index 987f5b9..80647d2 100644
|
||||
index 987f5b9..e18faf3 100644
|
||||
--- a/grub-core/loader/arm64/linux.c
|
||||
+++ b/grub-core/loader/arm64/linux.c
|
||||
@@ -27,6 +27,7 @@
|
||||
|
@ -129,39 +129,35 @@ index 987f5b9..80647d2 100644
|
|||
if (loaded_fdt)
|
||||
grub_free (loaded_fdt);
|
||||
loaded_fdt = NULL;
|
||||
@@ -239,60 +281,20 @@ out:
|
||||
grub_err_t
|
||||
grub_arm64_uefi_boot_image (grub_addr_t addr, grub_size_t size, char *args)
|
||||
{
|
||||
@@ -236,73 +278,22 @@ out:
|
||||
return grub_errno;
|
||||
}
|
||||
|
||||
-grub_err_t
|
||||
-grub_arm64_uefi_boot_image (grub_addr_t addr, grub_size_t size, char *args)
|
||||
-{
|
||||
- grub_efi_memory_mapped_device_path_t *mempath;
|
||||
- grub_efi_handle_t image_handle;
|
||||
- grub_efi_boot_services_t *b;
|
||||
- grub_efi_status_t status;
|
||||
- grub_efi_loaded_image_t *loaded_image;
|
||||
- int len;
|
||||
+ grub_err_t retval;
|
||||
|
||||
-
|
||||
- mempath = grub_malloc (2 * sizeof (grub_efi_memory_mapped_device_path_t));
|
||||
- if (!mempath)
|
||||
- return grub_errno;
|
||||
+ retval = finalize_params();
|
||||
+ if (retval != GRUB_ERR_NONE)
|
||||
+ return retval;
|
||||
|
||||
-
|
||||
- mempath[0].header.type = GRUB_EFI_HARDWARE_DEVICE_PATH_TYPE;
|
||||
- mempath[0].header.subtype = GRUB_EFI_MEMORY_MAPPED_DEVICE_PATH_SUBTYPE;
|
||||
- mempath[0].header.length = grub_cpu_to_le16_compile_time (sizeof (*mempath));
|
||||
- mempath[0].memory_type = GRUB_EFI_LOADER_DATA;
|
||||
- mempath[0].start_address = addr;
|
||||
- mempath[0].end_address = addr + size;
|
||||
+ grub_dprintf ("linux", "linux command line: '%s'\n", linux_args);
|
||||
|
||||
-
|
||||
- mempath[1].header.type = GRUB_EFI_END_DEVICE_PATH_TYPE;
|
||||
- mempath[1].header.subtype = GRUB_EFI_END_ENTIRE_DEVICE_PATH_SUBTYPE;
|
||||
- mempath[1].header.length = sizeof (grub_efi_device_path_t);
|
||||
+ retval = grub_efi_linux_boot ((char *)kernel_addr, handover_offset,
|
||||
+ kernel_addr);
|
||||
|
||||
-
|
||||
- b = grub_efi_system_table->boot_services;
|
||||
- status = b->load_image (0, grub_efi_image_handle,
|
||||
- (grub_efi_device_path_t *) mempath,
|
||||
|
@ -194,13 +190,30 @@ index 987f5b9..80647d2 100644
|
|||
- BYTES_TO_PAGES (loaded_image->load_options_size));
|
||||
-
|
||||
- return grub_errno;
|
||||
-}
|
||||
-
|
||||
static grub_err_t
|
||||
grub_linux_boot (void)
|
||||
{
|
||||
+ grub_err_t retval;
|
||||
+
|
||||
if (finalize_params_linux () != GRUB_ERR_NONE)
|
||||
return grub_errno;
|
||||
|
||||
- return (grub_arm64_uefi_boot_image((grub_addr_t)kernel_addr,
|
||||
- kernel_size, linux_args));
|
||||
+ grub_dprintf ("linux", "linux command line: '%s'\n", linux_args);
|
||||
+
|
||||
+ retval = grub_efi_linux_boot ((grub_addr_t)kernel_addr, handover_offset,
|
||||
+ linux_args);
|
||||
+
|
||||
+ /* Never reached... */
|
||||
+ free_params();
|
||||
+ return retval;
|
||||
}
|
||||
|
||||
static grub_err_t
|
||||
@@ -383,6 +385,7 @@ grub_cmd_linux (grub_command_t cmd __attribute__ ((unused)),
|
||||
@@ -383,6 +374,7 @@ grub_cmd_linux (grub_command_t cmd __attribute__ ((unused)),
|
||||
{
|
||||
grub_file_t file = 0;
|
||||
struct grub_arm64_linux_kernel_header lh;
|
||||
|
@ -208,7 +221,7 @@ index 987f5b9..80647d2 100644
|
|||
|
||||
grub_dl_ref (my_mod);
|
||||
|
||||
@@ -427,6 +430,15 @@ grub_cmd_linux (grub_command_t cmd __attribute__ ((unused)),
|
||||
@@ -427,6 +419,15 @@ grub_cmd_linux (grub_command_t cmd __attribute__ ((unused)),
|
||||
|
||||
grub_dprintf ("linux", "kernel @ %p\n", kernel_addr);
|
||||
|
||||
|
@ -224,7 +237,7 @@ index 987f5b9..80647d2 100644
|
|||
cmdline_size = grub_loader_cmdline_size (argc, argv) + sizeof (LINUX_IMAGE);
|
||||
linux_args = grub_malloc (cmdline_size);
|
||||
if (!linux_args)
|
||||
@@ -465,7 +477,6 @@ fail:
|
||||
@@ -465,7 +466,6 @@ fail:
|
||||
return grub_errno;
|
||||
}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From d0ed2021aea192f40486b67c6fb7a0ca1da1ac20 Mon Sep 17 00:00:00 2001
|
||||
From 434c09b3b8dfc4f4c556a5897b7eb4540e943c03 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Fri, 3 Oct 2014 11:08:03 -0400
|
||||
Subject: [PATCH 62/74] Try $prefix if $fw_path doesn't work.
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 8bc3f3da2d6a5b372d120c2d07efbcc5ad17eddc Mon Sep 17 00:00:00 2001
|
||||
From 32a2d1ac838e9d8dc0c05d84ceea65acb826fb1d Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Mon, 27 Oct 2014 09:22:55 -0400
|
||||
Subject: [PATCH 63/74] Try to emit linux16/initrd16 and linuxefi/initrdefi in
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 402afd14075d41885ffeb48112343ec319b4af13 Mon Sep 17 00:00:00 2001
|
||||
From b8e1b5e1042a35bd66eaff00c1402ef058fc4479 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Thu, 4 Dec 2014 15:36:09 -0500
|
||||
Subject: [PATCH 64/74] Update to minilzo-2.08
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 3dd1e0b3978fe49960000d407672dac6fb8042d8 Mon Sep 17 00:00:00 2001
|
||||
From 7fd40157778bf9021ea8228b6a87520b2e8bc926 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Tue, 28 Apr 2015 11:15:03 -0400
|
||||
Subject: [PATCH 65/74] Make grub2-mkconfig construct titles that look like the
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From fadcf2216e668dcfe6b4d0278101eef03400aa1f Mon Sep 17 00:00:00 2001
|
||||
From 7c406374a383c23cdaf1053efee00f90b5013674 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Tue, 28 Apr 2015 11:17:02 -0400
|
||||
Subject: [PATCH 66/74] Make rescue and debug entries sort right /again/ in
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 5ca1f600b419264e712b0a7e841837a4ce39418c Mon Sep 17 00:00:00 2001
|
||||
From 6790364166f755f4e6d9eb427fe3535059d2d9b1 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Tue, 7 Jul 2015 10:13:14 -0400
|
||||
Subject: [PATCH 67/74] Make .gitignore suck way less
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 722feabf3772d18d008ed9d53091c91fbafa85a9 Mon Sep 17 00:00:00 2001
|
||||
From 10cb311daec38e6098c583f48136d9c24db58624 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Marshall <rmarshall@redhat.com>
|
||||
Date: Mon, 16 Mar 2015 16:34:51 -0400
|
||||
Subject: [PATCH 68/74] Update info with grub.cfg netboot selection order
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 52da7ccd886fc26ca8989c4632bd5330d833ddc5 Mon Sep 17 00:00:00 2001
|
||||
From e00237f383d6c5cce444e3ac4c8991573b8a518c Mon Sep 17 00:00:00 2001
|
||||
From: Robert Marshall <rmarshall@redhat.com>
|
||||
Date: Mon, 16 Mar 2015 14:14:19 -0400
|
||||
Subject: [PATCH 69/74] Use Distribution Package Sort for grub2-mkconfig
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From d6e5091112cf708784ba0ee57245b20d0aceb5f1 Mon Sep 17 00:00:00 2001
|
||||
From d41ecd85b4a086643bc17d6bd96d9cf644017199 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Marshall <rmarshall@redhat.com>
|
||||
Date: Thu, 25 Jun 2015 11:13:11 -0400
|
||||
Subject: [PATCH 70/74] Add friendly grub2 password config tool (#985962)
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From ec51384985765e1b0c56decdec58e00eb47f7bf1 Mon Sep 17 00:00:00 2001
|
||||
From 0bc88ef1f983924c9fdc82c5f3a55213ec71ea4c Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Tue, 7 Jul 2015 12:00:26 -0400
|
||||
Subject: [PATCH 71/74] Make "exit" take a return code.
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From ba6c77f7bd141f4f34c93c33ef5ecd51b971c283 Mon Sep 17 00:00:00 2001
|
||||
From de4b00b23dcbe9218650565cb55b15866cb51868 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Tue, 7 Jul 2015 12:04:28 -0400
|
||||
Subject: [PATCH 72/74] Add some __unused__ where gcc 5.x is more picky about
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From dbd2b5884c493f3fb78a8259b7375dd2c0349a2f Mon Sep 17 00:00:00 2001
|
||||
From 2636009baa0bed56168f41f97e2396afdb183a0d Mon Sep 17 00:00:00 2001
|
||||
From: Matthew Garrett <mjg59@coreos.com>
|
||||
Date: Tue, 14 Jul 2015 16:58:51 -0700
|
||||
Subject: [PATCH 73/74] Fix race in EFI validation
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 9d24c88e23ac11043c9ea3a61eceb41b9430589c Mon Sep 17 00:00:00 2001
|
||||
From 98d1d5afe30a77125a153c09e73e9dc71b5ef8da Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Wed, 22 Jul 2015 11:21:01 -0400
|
||||
Subject: [PATCH 74/74] Mark po/exclude.pot as binary so git won't try to diff
|
||||
|
|
|
@ -63,7 +63,7 @@ Source6: gitignore
|
|||
Patch0000: grub-2.02-beta2-to-origin-master.patch
|
||||
|
||||
# generate all the patches after this with:
|
||||
# git format-patch origin/master..fedora-23
|
||||
# git format-patch fedora-diff-from-here..fedora-23
|
||||
Patch0001: 0001-Migrate-PPC-from-Yaboot-to-Grub2.patch
|
||||
Patch0002: 0002-Add-fw_path-variable-revised.patch
|
||||
Patch0003: 0003-Add-support-for-linuxefi.patch
|
||||
|
|
Loading…
Reference in a new issue